SBS IIS is always trying to push a certificate and asks about secure/nonsecure data

I don't remember what I did.  I had been putting in an ASP page and kept getting errors with file uploads which go through this new ASP page.  The permissions were wrong on the upload folder.  I fixed that BUT...

Just to go to the company's home page, you get the certificate dialog box.  

After you click the Yes button, you are warned that this page has secure and insecure data -- do you want to proceed...

Why?

This is a SBS with Exchange installed and it uses SSL.  It was working fine.  You could go to the home page without certificate requests.  If you went to the Company\Exchange page--then you got prompted.

I did pull up IIS and verify that the properties on the \inetpub\wwwroot (the default server) were Anonymous & Integrated, but I am not sure what else I may have done.  I have been working on this too long and too late.

Please, help.

Thanks.

William
wjolsonAsked:
Who is Participating?
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Is this happening on machines that are members of your domain? Or from outside?

If it's domain member machines then you may not have added them to the network correctly using the http://<servername>/connectcomputer method which would have installed the server's ssl certificate on them.  If you didn't follow this procedure, you must do as follows:

The following needs to be done with the client machine:
1.  Log in with THAT machine's LOCAL administrator account.
2.  Unjoin the domain into a WORKGROUP
3.  Change the name of the computer
4.  Delete or rename the following directory C:\Program Files\Microsoft Windows Small Business Server\Clients if it exists
5.  Ensure that DHCP is enabled and there are  no manually configured network settings
6.  Reboot

Then on the server, from the Server Management Console:
1.  Remove the client computers if it still shows in the Client Computer screen on the Server Management Console
2.  Add the client with it's NEW name using the Add Computer wizard

Then, go back to the client machine and join the domain by opening Internet Explorer and navigating to http://servername/connectcomputer

If this is happening from OUTSIDE your LAN, then instead of clicking "YES" on the certificate warning you should click "VIEW CERTIFICATE" and then follow the steps to install it, choosing all of the defaults.

Jeff
TechSoEasy
0
 
Irwin SantosComputer Integration SpecialistCommented:
clear you cookies
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
FYI, IIS permissions are not the ones you would look at under \inetpub\wwwroot.  Those are NTFS permissions.

To look at your IIS permissions, you need to go to the IIS Manager and open the properties of the particular website and then click on the "Directory Security" tab.

Jeff
TechSoEasy
0
 
wjolsonAuthor Commented:
Okay.  Thanks guys.

Cookies where not the right answer.  The good news is that this was not occurring on their domain but only from my domain behind my ISA firewall.

Jeff - I did review both the NTFS and IIS Permissions.

For some reason, I did not do the obvious in your first response and follow through on the certificate installation.  DOH!

Thanks for the reminder.

William
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.