Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 380
  • Last Modified:

Shutting Down

Hi i have SUSE Linux installed on My PC when im at promt i type shutdown now it does all its things then comes back with

Give Root Password for Login:

I type it

then i get prompt again

Its a vicious loop????

How do i Shutdown?
0
bryanchellen
Asked:
bryanchellen
1 Solution
 
xDamoxCommented:
Hi,

You can try typing:

halt

This will power the machine off or you can try

poweroff

With shutdown you can create a file called: " /etc/shutdown.allow"
and issue the following:

shutdown -a
0
 
bryanchellenAuthor Commented:
can you explain more about creating the file /etc/shutdown.allow please?
0
 
xDamoxCommented:
Hi,

As root type:

touch /etc/shutdown.allow
chmod 755 /etc/shutdown.allow

Once you have created the file just add the usernames that are allowed to shut the machine down. Your shutdown.allow
file will look like:

username1
damian
bryanchellen

This means the users username1, damian and bryanchellen will be allowed to shutdown the machine.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
xDamoxCommented:
I forgot to note you can now shut the machine down by doing:

/sbin/shutdown -a -h 0
0
 
bryanchellenAuthor Commented:
ok done all that

I get this responce

shutdown: you must be root to do that!
0
 
rindiCommented:
Check your keyboard mapping, and if you have caps locked or something similar. It could be that you are normally using another keyboard mapping, and the standard system uses another. This would be a problem for special keys you used for your password, so you might have to try the other mapping. A swiss german keyboard as an example has the z key in the place of the y when compared with a us ascii keyboard, among other differences as well.
0
 
bryanchellenAuthor Commented:
as soon as i type /sbin/shutdown

it says

shutdown: you must be root to do that!
0
 
xDamoxCommented:
Hi,

The reason is because you never specifiedthe -a

/sbin/shutdown -a
0
 
Heem14Commented:
once you see the

give root password for login:

you can just turn the power off. You've ended up in single user mode.


It's likely this is happening because you are not using acpi. if you are using grub for a boot loader, make sure acpi=on is included in /boot/grub/menu.lst -

example, here's mine

title SUSE LINUX 10.0
    root (hd0,0)
    kernel /vmlinuz root=/dev/hda4 selinux=0  resume=/dev/hda2  splash=silent showopts acpi=on
    initrd /initrd

note that in the failsafe mode, acpi should be set to off.
0
 
bryanchellenAuthor Commented:
thanks my friend but i added acpi=on to the grub config, it make boot up really slow and i still get the same problem!

ive root password for login:

i have found if i do shutdown -h now it works ok, is this ok to use?

why is linux so hard?


0
 
xDamoxCommented:
Hi,

shutdown -h is fine. it just tells the machine to shutdown asap as with the -h you can specify how long until a shutdown.

>why is linuxso hard?

At first it will seem a little tricky but you soon get use to it. Once you master it you will love it:)
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now