[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1162
  • Last Modified:

postfix sasl smtp problem

Hi,
I am using centosl 4.3,

cyrus-sasl-devel-2.1.19-5.EL4
cyrus-sasl-2.1.19-5.EL4
cyrus-sasl-plain-2.1.19-5.EL4
cyrus-sasl-md5-2.1.19-5.EL4

After compile and installtion of postfix-2.2.10 from source with (during installation I selected default locations), SMTPD is killing by throwing the following error: if i do a 'telnet localhost 25'

Jun  2 18:50:12 email02 postfix/smtpd[7170]: match_string: smtpd_access_maps ~? qmqpd_authorized_clients
Jun  2 18:50:12 email02 postfix/smtpd[7170]: match_string: smtpd_access_maps ~? relay_domains
Jun  2 18:50:12 email02 postfix/smtpd[7170]: match_string: smtpd_access_maps ~? smtpd_access_maps
Jun  2 18:50:12 email02 postfix/smtpd[7170]: smtpd_sasl_initialize: SASL config file is smtpd.conf
Jun  2 18:50:12 email02 postfix/smtpd[7170]: match_string: fast_flush_domains ~? debug_peer_list
Jun  2 18:50:12 email02 postfix/smtpd[7170]: match_string: fast_flush_domains ~? fast_flush_domains
Jun  2 18:50:12 email02 postfix/smtpd[7170]: attr_clnt_create: transport=local endpoint=private/anvil
Jun  2 18:50:12 email02 postfix/smtpd[7170]: connection established
Jun  2 18:50:12 email02 postfix/smtpd[7170]: master_notify: status 0
Jun  2 18:50:12 email02 postfix/smtpd[7170]: name_mask: resource
Jun  2 18:50:12 email02 postfix/smtpd[7170]: name_mask: software
Jun  2 18:50:12 email02 postfix/master[7166]: warning: process /usr/libexec/postfix/smtpd pid 7170 killed by signal 11
Jun  2 18:50:12 email02 postfix/master[7166]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling

I was able to use the default rpm from centos without any probelm. I was using the same config for my compiled version..

Any Idea?

bimal_linux
0
bimal_linux
Asked:
bimal_linux
  • 4
  • 3
1 Solution
 
Cyclops3590Commented:
what are the contents of your master.cf
0
 
Cyclops3590Commented:
oops and main.cf
0
 
bimal_linuxAuthor Commented:
Sorry for the late reply..I was bit busy.. Than you for the reply .. That was the problem with SASL + LDAP  library. I fixed it by compiling new curus after installing latest version of openldap and specifying the path while compiling..

Regards,
Bimal
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 
Cyclops3590Commented:
gotcha.  Can you please post, in a little more detail, step by step what you did?  Then post a Q in the Community Support area requesting a PAQ/Refund.  Someone may search and come across this question and need to know a little more indepth what you did.

Thanks
0
 
bimal_linuxAuthor Commented:
Sorry, it took a long time to respond.. I was little busy with other stuff.. Here follows what I did to fix it..

First download and install cyrus sasl
wget http://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-2.1.22.tar.gz
tar -zxvf cyrus-sasl-2.1.22.tar.gz
cd cyrus-sasl-2.1.22
./configure --prefix=/usr/local/cyrus-sasl
make;make install

Download ,compile and install openldap: (from openldap.org)
./configure --prefix=/usr/local/openldap
make depend; make install
will do that for you..

now download and compile postfix with the following arguments in it. (from postfix.org)
make makefiles CCARGS="-I/usr/local/include -DHAS_LDAP -DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/local/cyrus-sasl/include/sasl  -DUSE_TLS  -I/usr/local/openldap/include" AUXLIBS="-L/usr/local/cyrus-sasl/lib -L/usr/local/lib -lldap -llber -L/usr/local/lib -lsasl2 -L/usr/local/openldap/lib  -lssl -lcrypto"

make; make upgrade (if you have a postfix preinstalled, else, make install)

While make install, it will ask for the libldap and liblber libiraries. Go to create a  symlink from /usr/local/openldap/lib  to /lib for the corresponding library files to resolve this issue.  :)
After stop and start, Postfix will behave properly ...

I have noticed the same postfix  sasl issue with Fedora Core 4. Above mentioned steps will help to fix that unpleasant surprise too.. :)

Good Luck..
Bimal Mankara
0
 
bimal_linuxAuthor Commented:
Now, please tell me how can i refund those points..
Support, Please do that for me..

Regards
Bimal
0
 
Cyclops3590Commented:
If you look at the very upper right of this page you will see a link for Support.  Click on that, then in that section post a Q referenceing the URL for this Q.  Say that you answered your own question and wish to PAQ/Refund this question.

A moderator will then post a comment stating your intentions and then wait a few days to make sure there are no objections.  If none, then the request is finalized
0
 
ee_ai_constructCommented:
Closed, 500 points refunded.
ee ai construct
Community Support Moderator
replacement part #xm34
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now