• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2094
  • Last Modified:

Line protocol down on an E1 connection

Hi experts, I have been really stressed out about this one. I have a customer that lease 1 E1 line in Mexico and wants to setup a Cisco 2801 as a router. Here is my problem: The telco is saying I have an issue at my end. The physical connection is as follows


telco-------Schimidtt Watson SHDSL DSU/with v.35 interface--------Cisco male v.35 DTE cable-------Cisco 2801 w/Wic 1T
                  E1 with 31 channels for data 1 reserved for ISP


My problem is they claim they cannot see past the watson DSU. They sent a Tech out to physically loop the circuit and they say everything is fine. However when I plug the router in the line protocol does not come up and the interface reset constantly. Now they are at a point where they say the line is up and if I need assistance they charge $300 dlls an hour whether Im right or wrong. I have done several of these implementation in the US and they are not complicated at all. But the HDSL factor is new to me. My current nterface config is as follows:

interface Serial0/1/0
 ip address 201.xx.xx.xx 255.255.255.252
 Bandwidth 1984
 ip nat outside
 ip rtp header-compression
!

Any comments would be greatly appreciatted. We purchased A Smartnet from Cisco but have not found any help from them.

Thanks


0
amanytx
Asked:
amanytx
  • 10
  • 5
  • 2
  • +2
1 Solution
 
Irwin SantosComputer Integration SpecialistCommented:
Record your router seconds.. then reset the Cisco to the default configuration, then reapply your settings.
0
 
amanytxAuthor Commented:
Could you clarify alittle bit. I have been reading a lot of threads on here and pretty much I think it is a clock/timing issue. This is an uneducated assumption. Could you or someone please clarify if my assumption is correct!
0
 
Don JohnstonInstructorCommented:
I think what irwinpks was trying to say is: Record your router settings.. then erase and reconfigure.

Rather than do that, lets look at this a little closer. Can you post the results of a "show interface S0/1/0"?
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
lrmooreCommented:
Does the interface encapsulation need to be PPP for this application?
Did the telco require the rtp header-compression ?
Output of show interface will tell us a lot more.
0
 
amanytxAuthor Commented:
the Telco only specified HDLC encapsulation. RTP header compression I added it just to try something different
here it is

Serial0/1/0 is up, line protocol is up
  Hardware is GT96K Serial
  Internet address is 201.117.192.89/30
  MTU 1500 bytes, BW 768 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive not set
  Last input never, output 00:00:32, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     28 packets output, 3881 bytes, 0 underruns
     0 output errors, 0 collisions, 5 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
0
 
amanytxAuthor Commented:
Right now obviously it only shows line proticol up because of the no keep command. I took the snapshot after a reboot but after a while the interface resets grow exponentially as well as packet output
0
 
Irwin SantosComputer Integration SpecialistCommented:
@donjohnston..."I think what irwinpks was trying to say is: Record your router settings.."

yikes!! my bad.  yeah router settings.  must've been tired.
0
 
amanytxAuthor Commented:
A new comment. The Telco says the interface has been "chanelized" and now they can se the equipment but still on my side line protocol is down.

Thanks
0
 
amanytxAuthor Commented:
OK FYI for anyone turning up a circuit in Mexico. CHOOOSE someone else aside from TELMEX. But anyway I have line protocol up now and I have internet access as far as telneting into the router from a remote location and pinging from the router out. But I have no internet access and I cannot ping anything from the LAN side. The telco gave me their WAN ip at xx.xx.90.66 my wan ip at xx.xx.90.65  255.255.255.252 and my Ip space as xx.xx.92.16 255.255.255.240 I will post the config as it is now. I knwo it a rounting issue hopefully someone can help.

Current configuration : 1443 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname xxxxxx
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret 5 $1$PPNb$imj5nFtzPeML0rAbeBIwt/
enable password xxxxxx
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
ip cef
!
!
ip dhcp excluded-address 192.168.101.1 192.168.101.250
!
ip dhcp pool 1
   network 192.169.101.0 255.255.255.0
   default-router 192.168.101.1
   dns-server 200.33.146.217 200.4.144.117
!
!
ip ips po max-events 100
no ftp-server write-enable
!
voice-card 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
no crypto isakmp ccm
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.101.1 255.255.255.0
 ip nat inside
 speed auto
 full-duplex
!
interface FastEthernet0/1
 ip address 148.233.92.16 255.255.255.224
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1/0
 bandwidth 1984
 ip address 148.233.90.65 255.255.255.252
!
interface Serial0/1/0.1
 ip address xx.xx.92.17 255.255.255.240
 ip nat outside
!
ip classless
ip route 0.0.0.0 0.0.0.0 xx.xx.90.66
!
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Serial0/1/0.1 overload
!
access-list 1 permit 192.168.101.0 0.0.0.255
!
!
!
!
control-plane
!
!
!
voice-port 0/2/0
!
voice-port 0/2/1
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password xxxxxx
 login
!
end


0
 
Don JohnstonInstructorCommented:
ip nat inside source list 1 interface Serial0/1/0.1 overload

Should be:

ip nat inside source list 1 interface Serial0/1/0 overload
0
 
amanytxAuthor Commented:
Don, thanks for the quick reply, although I have not made it to the customers site I wanted to post a sh int so you can give me some feedback. I know I read in one of the trheads here that CRC's on an interface are not good. I have some input errors along with CRC's. Could this be the cause of no browsing ability?

THanks


Serial0/1/0 is up, line protocol is up
  Hardware is GT96K Serial
  Internet address is 148.233.90.65/30
  MTU 1500 bytes, BW 1984 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters 07:12:37
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/2/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1488 kilobits/sec
  5 minute input rate 5000 bits/sec, 5 packets/sec
  5 minute output rate 4000 bits/sec, 4 packets/sec
     299674 packets input, 35705047 bytes, 0 no buffer
     Received 3028 broadcasts, 0 runts, 0 giants, 0 throttles
     670 input errors, 670 CRC, 1 frame, 0 overrun, 0 ignored, 267 abort
     299899 packets output, 35470414 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
0
 
Don JohnstonInstructorCommented:
The reason for no internet access was the NAT configuration.

According to Cisco's guide for troubleshooting serial links, only when the errors hit 1% of the total traffic is it considered a "problem". Yours is at .2%.

http://www.cisco.com/univercd/cc/td/doc/cisintwk/itg_v1/tr1915.htm#xtocid5

Having said that, it still indicates an issue. It could be:

Telco problem
Noise
Bad cable/connector
Clocking misconfiguration
Bad CSU/DSU
0
 
amanytxAuthor Commented:
Ok still no internet access. finally found someone at the telco nice enough to help. He modifed the config as follows. But still no access. The problem is from the lan pc's out we did notice than when you try to ping from the router to the local lan it does not recognize any of the ip's but from the lan the pc's can see the router. We did so nat translations from the router using the internal ip and they work. I am now puzzled as why the router does not see the pc's. Here is the config

Building configuration...

Current configuration : 1403 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname xxxxxx
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret 5 $1$QMxg$PuAeyjyZL15LeeyzcPwZF0
enable password xxxxxxx
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
no ip routing
no ip cef
!
!
!
!
ip name-server 200.23.242.193
ip name-server 200.23.242.201
ip ips po max-events 100
no ftp-server write-enable
!
voice-card 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.102.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 no ip route-cache
 speed auto
 full-duplex
!
interface FastEthernet0/1
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1/0
 bandwidth 768
 ip address xx.xx.192.89 255.255.255.252
 ip nat outside
 ip virtual-reassembly
 no ip route-cache
 no fair-queue
!
ip classless
ip route 0.0.0.0 0.0.0.0 xx.xx.192.90
!
no ip http server
no ip http secure-server
ip nat pool Internet xx.xx.235.97 xx.xx.235.98 netmask 255.255.255.240
ip nat inside source list 1 pool Internet overload
!
!
access-list 1 permit 192.168.102.0 0.0.0.255
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password toxa4321
 login
!
end
0
 
Don JohnstonInstructorCommented:
I'm not sure I understand.

Are you saying the PC's out the f0/0 interface can ping the router, but the router can't ping the PC's?

If that's correct, it's probably the windows firewall settings on the PC's. Windows XP will block incoming pings by default.
0
 
amanytxAuthor Commented:
Already disabled it and still the same. And yes that is exactly true what you are saying in your statement.

"Are you saying the PC's out the f0/0 interface can ping the router, but the router can't ping the PC's?  YES"

Any ideas or suggestions. We tried lowering fe0/0's speed, duplex bandwidth everything to make the router see the lan and still no dice.

Thanks in advance
0
 
Don JohnstonInstructorCommented:
Pinging is bidirectional. In order for a ping to work, the destination has to receive the request and send a response. If you can ping in ANY direction, you have established layer 3 communications.

The only way what you're describing can happen is through a traffic filter. Since there's no access list on the router, there is something on the PC that is blocking ICMP echo requests packets.
0
 
robinluoCommented:
okay, my comment might sound crazy but IT DID HAPPENED to one of our clients before:

- User is able to PING the router
- Router cannot PING the user
- No WAN connectivity

Turned out to be: user forgot to disconnect the old router from the LAN, basicaly they were PING the old router which had the same IP as the new one.
0
 
amanytxAuthor Commented:
It turned out to be an issue witht the pc. I will post the config later so people delaing with Telmex do not have to go thru what I went thru. I will award points to Donjohston since he stuck by the longest. Thanks
0
 
amanytxAuthor Commented:
Here is the config that finally worked. Thanks to everyone especially Don Johnston

!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname xxxxxx
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret 5 $1$BkYB$jYyEJtqiQr.W5tI1Po2m.0
enable password xxxx
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
ip name-server 200.23.242.193
ip name-server 200.23.242.201
ip ips po max-events 100
no ftp-server write-enable
!
voice-card 0
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.101.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly
 ip route-cache flow
 speed auto
 full-duplex
 no keepalive
 no mop enabled
!
interface FastEthernet0/1
 ip address xx.xx.92.17 255.255.255.240
 speed auto
 full-duplex
!
interface Serial0/1/0
 bandwidth 1984
 ip address xx.xx.90.65 255.255.255.252
 ip nat outside
 ip virtual-reassembly
 no fair-queue
 
!
ip classless
ip route 0.0.0.0 0.0.0.0 xx.xx.90.66
!
!
ip http server
no ip http secure-server
ip nat inside source list 1 interface Serial0/1/0 overload
!
access-list 1 permit 192.168.101.0 0.0.0.255
!
control-plane
!
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password xxxxxxxx
 login
!
end
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 10
  • 5
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now