best location for  echo 100 > /sys/class/firmware/timeout

Posted on 2006-06-03
Last Modified: 2011-08-18
My Dell D610 runs  FC 3 2.6.12-1.1381_FC3.  I  installed
ieee80211-1.1.9 and ipw220-1.1.0 for my wireless NIC.
ipw2200 always fails to load during boot.  To work around
this, I  have to add "echo 100 > /sys/class/firmware/timeout"
to system startup scripts prior to the point at which the driver
module would be loaded. I tried to add the command to /sbin/
hotplug  and rc.sysint,  both of them didn't work.  I also added
"install ipw2200 /sbin/modprobe  --ignore-install ipw2200;
echo 100 > /sys/class/firmware/timeout"  to /etc/modprobe.conf.  
It still didn't work and took a very long time for probing hardware
during boot.

What file do I edit to do this?  I really have no clue!

Any help on this would be greatly appreciated.

Question by:Jerryleo
    LVL 16

    Expert Comment


    Have you tried editing the /etc/rc.local file
    LVL 51

    Expert Comment

    /etc/rc.boot, or /etc/init.d/boot (whatever exists)

    Author Comment

    Both of them didn't work. It must be added to system startup scripts prior to the point at which the driver module would be loaded.  Which system startup script it should be?
    LVL 22

    Expert Comment

    Is there a manual command to shutdown the wireless and restart it?

    Insert it into the first few lines of that script, and then add the restart wireless network command to the rc.local file.

    Alternatively, if you want to carry this out 'correctly', then you need to edit the /etc/modules.conf file adding the following line or similar:

    pre-install ipw2200 echo 100 > /sys/class/firmware/timeout

    man modules.conf

    for more info on the modules.conf file and available directives.


    Author Comment

    There is no modules.conf in FC 3.

    It looked like it could have been a red herring.  IPW2200 can be loaded manually after loginning without increassing the timeout value.

    I fixed the problem by adding an entry "alias eth1 ipw2200" in /etc/modprobe.conf.

    LVL 22

    Expert Comment

    /etc/modprobe.conf is the FC3 equivalent of modules.conf in FC 4

    ..possibly pointed in the right direction?..but feel free to PAQ and refund

    LVL 5

    Accepted Solution

    Closed, 50 points refunded.
    Site Admin

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    6 Surprising Benefits of Threat Intelligence

    All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

    Suggested Solutions

    Title # Comments Views Activity
    SIP Trunk provider 20 59
    IPA client Config problems 2 53
    Full Backup software for Linux 5 38
    shell script to send sms 2 34
    rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
    Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
    Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
    Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

    761 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    10 Experts available now in Live!

    Get 1:1 Help Now