Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 375
  • Last Modified:

Cannot set correct screen res. - I get virtual resolution instead of real (Dual monitors with an ATI X800 on Kubuntu Dapper)

Hi,

Let me try to explain what's happening:

After installing Kubuntu 6, I configured my card with the drivers provided by it (fglrx). It didn't work, so I then tried with the drivers directly from ATI.com. That didn't work either.

I have a Dell M991 (19") and a E153FP (15").

What happens is that when I set the resolution for the 19" to anything *other*  than 2048x1536, and the 15" to any resolution, both monitors work as if they didn't support the resolution natively, and they act as "viewports". Kind of like a virtual resolution, where by moving the cursor to the edges of the screen makes it pan accross all the screen space. I think this is typical on laptops, where you can set higher resolutions than the LCD will support and it'll create this kind of "virtual resolution".

Strange thing is that if I set the 19" to 800x600, it still creates a virtual resolution, of course with *huge* windows and fonts. And strangest of all is that I don't believe this monitor supports anything higher than 1600x1200, so it seems weird that it works as *expected* only when using the high resolution I mentioned earlier.

Another strange thing is that on the Screen hardware manager, it shows two video cards, both "ATI Radeon (fglrx)", the difference being that one shows two monitors and another one just shows one, and also under "driver" one shows "fglrx" and the other shows "ati".

Note that I *don't* have two cards, just one (and the one integrated with the mobo).

I hope I explained the problem correctly, but if I didn't I suppose I could record a short movie with my phone and upload it so you can clearly see what the problem is.

On an unrelated not-so-important issue, I find it disconcerting that when the monitors have different resolutions, the windows appear larger on the lower resolution one, and also that I can go from one monitor to the other through the "no-shared" zone (if the smaller monitor is aligned to the top, you'd expect that the cursor couldn't go from the big to the small one passing through the lower edge), which is also frustrating (because the cursor jumps too much). Not that I miss Windows, but these weren't issues on there... (feel free to ignore this whole paragraph).

Please help me out, I've been dealing with this since yesterday when I made the switch from Windows XP. I actually find the experience overall to be much more pleasant (and powerful), albeit this irritating issue with the monitors.

Thanks in advance!

- Ivan V.
0
ivanvega
Asked:
ivanvega
  • 3
  • 2
  • 2
1 Solution
 
nedvisCommented:
Note that I *don't* have two cards, just one (and the one integrated with the mobo).

MAKE SURE TO DISABLE INTEGRATED VIDEO CHIPSET ( CARD)  IN SYSTEM BIOS !!!
ALSO MAKE SURE TO DISABLE  "BIOS CASHEABLE" " VIDEO CASHEABLE"  FEATURES ( if there are any of these ).

nedvis

sorry for ALL CAPS !
I can't stress enough how important is to not to confuse Linux with the presence of two video chipsets on one system.




0
 
ivanvegaAuthor Commented:
It seems I can't disable it, as it only allows to change the buffer, but not disable the card.

It's a Dell Dimension 4600.
0
 
nedvisCommented:
I definitely think that's what is causing your problems with acctual screen resolution.

I've got similar problem with my SiS motherboard with onboard video card. Despite the fact I can disable on-board video-chipset
Linux ( SuSE 10 ) still detects it and sets xorg.conf file  as if SiS video chipset was my primary video device so I had to edit xorg.conf
and manually set all parameters for my ( poor ) nVIDIA Riva TNT 2 .

Dell DImension 4600 has on-board ATI All-In-Wonder Radeon 9000 with 64MB Memory ? Is that correct ?
I still  think you should be able to find ( somewhere in BIOS advanced settings screens ) the way to disable it.

If nothing, you can still analyse , edit end reconfigure your display configuration file ( xorg.conf) manually.

as regular user locate and open xorg.conf  file and see its contents from terminal (console) windows  --- command is :

            cat     /etc/xorg.conf

-----------------------------------------
 Pay attention to   :   Section "Device"
                                 Section "Monitor"
               and            Section  "Screen"  
______________________________
Make sure Kubuntu has detected and configured your acctual video card  ( the one you're really using) and not the one on-board.
----------------------------------------
Please refer to this "X Resolutions Dilema"  thread too:

http://people.ubuntulinux.org/~mako/ubuntu-traffic/u20040827_01.html#5 
-------------------------------------------------

nedvis



   

                                                                                             
                                                                                         

 


0
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

 
nedvisCommented:
http://forums.bit-tech.net/showthread.php?t=109656
for more references try Google.com   keyword : "Ubuntu dual monitor ATI xorg"
It seems to be the problem with Dapper Drake.
BTW I'm runnning Ubuntu Dapper but  it works fine with my SiS board(s)

nedvis
0
 
GnsCommented:
Arhum, you shouldn't need to disable the builtin card, no. Just see to it that the relevant Device section have the correct BusIDs set, so that you (and the system:-) can keep them apart. Just don't configure the "wrong" one in any Screen section, and all will be fine.

What is described in the original question, and in one of the links from nedvis above, is actually an unfortunate default behaviour by the X server.... Lacking a Virtual  X Y specification in the Display subsection of the Screen section(s), it'll grab that from the largest available ModeLine specified in the Modes.... Meaning that just placing another Mode as the first one will not change this Virtual resolution specification. Simply edit the file and remove any modes you don't want.

Now, managing a dual head setup can be done in several, more or less cumbersome ways. I'm sure there are spiffy tools that can thoroughly mess this up, but all you need is 1) read "man xorg.conf" with a special emphasis on the Screen section and the ServerLayout section, and 2) edit the file to achieve the placement (and sizes) you want.
Sticking with "fglrx" driver would, of course, change this slightly, since the proprietary driver has some notion of handling this itself... All rather well documented by ATI:-):-)

-- Glenn
0
 
ivanvegaAuthor Commented:
Hey Gns,

Thanks for the info. I tried manually editing the xorg.conf file, but I got some weird results. The second screen didn't accept the resolution and I can't really explain what happened to the main one, but here is the file, in case you can help me find what I did wrong (I got the modeline settings from http://www.dkfz.de/spec/linux/modeline/index.html.en):

Section "Files"
  FontPath "/usr/share/X11/fonts/misc"
  FontPath "/usr/share/X11/fonts/cyrillic"
  FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
  FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
  FontPath "/usr/share/X11/fonts/Type1"
  FontPath "/usr/share/X11/fonts/100dpi"
  FontPath "/usr/share/X11/fonts/75dpi"
  # path to defoma fonts
  FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
  Load "i2c"
  Load "bitmap"
  Load "ddc"
  Load "extmod"
  Load "freetype"
  Load "int10"
  Load "type1"
  Load "vbe"
  load "glx"
  load "dri"
  load "v4l"
EndSection

Section "InputDevice"
  Identifier "Logitech MX 500"
  Driver "kbd"
  option "CoreKeyboard"
  option "XkbRules" "xorg"
  option "XkbModel" "pc105"
  option "XkbLayout" "es"
EndSection

Section "InputDevice"
  Identifier "Logitech G7"
  Driver "mouse"
  option "CorePointer"
  option "Device" "/dev/input/mice"
  option "Protocol" "ExplorerPS/2"
  option "ZAxisMapping" "4 5"
  option "Emulate3Buttons" "true"
EndSection

Section "Device"
  identifier "ATI Radeon X800 A"
  boardname "ATI Radeon (fglrx)"
  busid "PCI:1:0:0"
  driver "ati"
  screen 0
  vendorname "ATI"
  option "MergedFB" "off"
EndSection

Section "Device"
  identifier "ATI Radeon X800 B"
  boardname "ATI Radeon (fglrx)"
  busid "PCI:1:0:0"
  driver "ati"
  screen 1
  vendorname "ATI"
  option "MergedFB" "off"
EndSection

Section "Monitor"
  identifier "Dell M991"
  vendorname "Dell"
  modelname "Dell M991"
  HorizSync 30.0-96.0
  VertRefresh 50.0-110.0
  modeline  "1280x1024@100" 247.5 1280 1408 1712 2272 1024 1024 1028 1089 +hsync +vsync
  gamma 1.0
EndSection

Section "Monitor"
  identifier "Dell E153FP"
  vendorname "Dell"
  modelname "Dell E153FP"
  HorizSync 30.0-63.0
  VertRefresh 56.0-75.0
  modeline  "1024x768@75" 81.54 1024 1064 1168 1352 768 768 770 804 +hsync +vsync
  gamma 1.0
EndSection

Section "Screen"
  Identifier "M991"
  Device "ATI Radeon X800 A"
  Monitor "Dell M991"
  DefaultDepth 24
  SubSection "Display"
    depth 24
    virtual 1280 1024
    modes "1280x1024@100"
  EndSubSection
EndSection

Section "Screen"
  Identifier "E153FP"
  Device "ATI Radeon X800 B"
  Monitor "Dell E153FP"
  DefaultDepth 24
  SubSection "Display"
    depth 24
    virtual 1024 768
    modes "1024x768@75"
  EndSubSection
EndSection

Section "ServerLayout"
  Identifier "Default Layout"
  screen 0 "M991" 0 0
  screen 1 "E153FP" RightOf "M991"
  InputDevice "Logitech MX 500"
  InputDevice "Logitech G7"
EndSection

Section "DRI"
  Mode 0666
EndSection

Section "ServerFlags"
EndSection

Thanks!
0
 
GnsCommented:
Remove the ModeLines, you don't need them. Or generate modelines that are a bit more sane.... Flat panels *don't* need higher refresh rates than 60 Hz. Some may do 75 Hz, but that is only an interface thing... They really don't need more than staid ol' 60;-)

Both your monitors will operate perfectly well with the "automagic" default ModeLines, as you had before. Just specify
Modes "1280x1024"
and
Modes "1024x768"
respectively.

-- Glenn
0

Featured Post

Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

  • 3
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now