localhost not working...

Ninjas...

My localhost suddenly isn't working. I'm being told it's experiencing technical difficulties. The Inetpub folder is still intact but something has changed and I'm wondering if someone has any ideas as to what might be the matter.

Thanks!
brucegustPHP DeveloperAsked:
Who is Participating?
 
DazmCommented:

The reason i ask you if you surf the net, was to see if i can give you another suggestion.
Now that you said something about PWB, thats you problem right there, it happen all the
times.

Try to put everything back to the default setting.

0
 
Irwin SantosComputer Integration SpecialistCommented:
What server operating system?
What's the exact error message?
can you post the URL so that we can test?
0
 
UnexplainedWaysCommented:
Have you made any changes in the last day or 2?  That's ususaly a good place to first look.

What is the exact error message your getting?
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

 
brucegustPHP DeveloperAuthor Commented:
Here's an example:

http://localhost/Supplies/Supplies.asp?StoreID=15

I get a white screen - absolutely nothing written on it. I'm getting a message on the title bar that says it can't find server.

I have no idea if this makes any difference but I've been dealing with an annoying little message from Norton that tells me my protection isn't up to date.  When I go to try and update it, I'll get an error message (LU1875) that says it didn't work.

Whether or not that's a related issue, I don't know. But this just now happened and after retracing my steps, I don't come up with anything.
0
 
Irwin SantosComputer Integration SpecialistCommented:
that link won't help us as it is on your machine and not public.
what server operating system?

if you can't find the server, are you running DNS?
is IIS running?
how about restarting your machine?
0
 
UnexplainedWaysCommented:
Try to wack a simple html file in the Supplies folder, and see if that works.  Then create a simple asp file that just prints hello world to the screen and see if that works.

If they both work, then it might be a problem with your code.
0
 
EECDMLCommented:
Have you tried using the default loopback IP of 127.0.0.1 inplace of localhost.
0
 
david_levineCommented:
Try the following:

http://127.0.0.1/Supplies/Supplies.asp?StoreID=15

http://127.0.0.1

Do those work? If you haven't rebooted, try that too.

If not, check your machine's Event Viewer and see if there's anything showing up in the System or Application logs related to IIS.
0
 
basicinstinctCommented:
Have you rebooted the machine...?

You would be amazed what that can fix.
0
 
Irwin SantosComputer Integration SpecialistCommented:
so 3 Experts say to reboot...well?????
0
 
rangasumanCommented:
First, I would suggest you to see if the server is up and running. Create a simple html page and call it ex: http://localhost/test.html
Then try to restart the IIS server (I am assuming since you are using asp). For restarting it, you can go to control panel, select administrative tools and
   1. In the Internet Information Services snap-in, select the Computer icon in the contents pane and click the Action button.
   2. Click the Action button and select Restart IIS.
   3. From the drop-down menu, select Restart Internet Services, Stop Internet Services, Start Internet Services, or Restart computer name.
Also you need to provide more information to debug the error. Hope that helps.
0
 
scrathcyboyCommented:
REMOVE NORTON COMPLETELY.  It is FLAWED software.  Every PC I have seen this new version of NORTON on, it is giving a similar message.  This program is worse than a virus.  Purge your system of it first, then you can see clearly to fix the remaining problems, if any.
0
 
deepaknetCommented:
Most probably, your webserver is not running or a personal proxy or firewall is blocking connections.
0
 
wilniukCommented:
Try "ping localhost" first. If that works, try
    net.exe start "World Wide Web Publishing"
If ping does not work, check your C:\WINDOWS\system32\drivers\etc\hosts. There should be a line in it:
    127.0.0.1       localhost
0
 
DazmCommented:

I use 'AppServ' to share my page to the world wide web : ) just kidding.

Have you try to go here?
Explorer >> Internet Options >> Now choose the connections tab and click on the LAN Settings button >> then make sure to check off  "Automatically detect settings"

Good luck.
0
 
netmunkyCommented:
make sure your firewall isn't blocking incoming port 80. test by stopping IIS admin service, and use 'nc -l -p 80' (you can find nc.exe on google). try http://localhost and try http://yourcomputer from a seperate computer. you should see the HTTP get request in netcat.

if that works, start IIS back up. check your website settings under the general tab and see what IP the server is bound to. if it is bound to a specific address (192.168.1.32) instead of '(All Unassigned)', localhost will not work. click Advanced to add localhost to the list of IP addresses that are used if you want localhost to work.
0
 
DazmCommented:

But even if his firewall is blocking port 80, he should be able to display http://127.0.0.1

0
 
netmunkyCommented:
firewalls can block localhost as well.
0
 
DazmCommented:

What do you get if you browse http://127.0.0.1

?
0
 
DazmCommented:

did you fallow my first post ?

Explorer >> Internet Options >> Now choose the connections tab and click on the LAN Settings button >> then make sure to check off  "Automatically detect settings"

0
 
DazmCommented:

Ok i agree with netmunky.

But can you surf the net?
0
 
DazmCommented:

Open command prompt and type ipconfig /all
lest see what you get.


0
 
brucegustPHP DeveloperAuthor Commented:
When I attempt to access http://localhost I get nothing. I get a blank page and / or sometimes I get a page that says "...page is not available." But in both situations, in the title bar it says that "Server Cannot be found..."

What do you think?
0
 
DazmCommented:

Can you surf the net?

Lest start from the bigining...
Normally if we try to access our localhost just like that, we never going to get
an answer, we always going to get this result => "The page cannot be displayed"

But if you are dealing with something like Apache, MySQL, or AppServ Win32...
or some other server configuration, it may be that you did some bad configuration.

0
 
brucegustPHP DeveloperAuthor Commented:
Yeah, I can access the net.

I'm thinking from having installed PWB before, it may be "off," I just can't remember how to turn it back on.

But, to answer you question, yes, regular internet is good to go...
0
 
brucegustPHP DeveloperAuthor Commented:
How?
0
 
DazmCommented:

Uninstall everything that have to do with PWB.
dir, reg, dat, etc.
0
 
DazmCommented:

Then install it back again and see what is it that you been doing wrong.

0
 
netmunkyCommented:
there seem to be a lot of questions being asked of the original poster and requests for more information that are going unanswered.

i just went back and read through, and i still don't see any mention of what operating system you are using (other than windows)
are you using win98? nt4? 2k? xp? 2k3? it does make a difference.

have you tried the suggestions with netcat? what were the results? can other computers view your website?

you make reference to PWB? do you mean PWS (personal web server)? PWS hasn't been around since win98 or NT4 workstation, everything above that uses IIS. make sure your IIS services are running (administrative tools -> services). IIS Admin and World Wide Web Publishing service need to be running.
you also need to check the Internet Information Services Manager (also in administrative tools), and make sure your website isn't stopped. it's possible to stop the website *without* stopping the service. it's also possible that the website is not bound to all IP addresses, but only to your non-loopback address.

give more details please!
0
 
NerdxCommented:
Try uninstalling IIS from Add/Remove Windows Components and then installing it again. Also, have you got Microsoft .NET Framework installed?

If you haven't, here is the direct link to Microsoft .NET Framework 1.1:

http://www.microsoft.com/downloads/info.aspx?na=90&p=&SrcDisplayLang=en&SrcCategoryId=&SrcFamilyId=262D25E3-F589-4842-8157-034D1E7CF3A3&u=http%3a%2f%2fdownload.microsoft.com%2fdownload%2fa%2fa%2fc%2faac39226-8825-44ce-90e3-bf8203e74006%2fdotnetfx.exe

Hope this helps - GL

# Nerd
0
 
netmunkyCommented:
.NET Framework is only necessary if you are using ASP.NET, C#, etc. If .NET Framework is already installed, but .aspx is not working, you need to run aspnet_regiis.exe.

but, that has nothing to do with not being able to access http://localhost
0
 
DazmCommented:

I agree with netmunky
0
 
brucegustPHP DeveloperAuthor Commented:
Hey!

Forgive the reference to PWB, it is IIS.

I'm going with the DAZM's suggestion to just reinstall the beast and we'll go from there.

Thanks everyone for weighing in!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.