two pcs, pc1 can see pc2, pc2 cant see pc1, both share the same internet

i have a friend with 2 computers on her home network, both pcs are windows xp with service pack 2 installed. my friend wanted to be able to share files between them, so i put them in the same workgroup, rebooted and looked for each computer in the microsoft network, i was able to see pc2 with pc1 (for lack of a better way to say it), but pc2 couln't see pc1, i disabled all firewalls and antiviruses, pc2 just told me that i might not have permission to use network resources, but pc1 could fully use pc2 resources over the network, just not the other way around... they are going through a linksys wap pc1 is wired, pc2 is wireless. please help me, ive ran into this before (im a computer tech), but im a little confused. my email is mailjasonb@gmail.com

thank you!
jasonbeardAsked:
Who is Participating?
 
FriarTukConnect With a Mentor Commented:
1) Cntl Panel - Sys prop's - computer name tab - make the workgroup name the same on both PCs.
2) Cntl Panel - Firewall - Verify file sharing is permitted
3) Cntl Panel - folder opt's - view tab - adv settings box (scroll to bottom) & check use simple file sharing
4) Network connection prop's - adv button - wins tab - enable netbios over tcp/ip
     --> Try using the IP address instead of the pc name "\\192.168.1.2\Shares". If NetBIOS is not properly exchanging info, this method might get around that.
5) With XP Pro, you  need to be logged in to "client" PCs with a Userid/pwsd that matches an Account set up in the "host" PC.

     --> By default, a user account is created with no password.  This means the user may sit down locally at the XP machine and log on without entering a password.
     --> However, by default, Windows XP will not permit a network user to access the XP machine using an account set up without a password!

   Permitting Network Access an XP Pro box w/o a Pswd
   Go to Control Panel | Performance and Maintenance | Administrative Tools | Local Security Policy.
   Expand Local Policies | Security Options.
   Double-click Accounts: Limit local account use of blank passwords to console login only, which is enabled by default. Disable this option and click OK.
   * This will permit network access without a password. The user's computer can boot directly to the Windows desktop, and be validated against the corresponding XP Professional user account, without a password.
0
 
ChrisMacleodCommented:
Check the permissions of the shared folder.  Give the everyone group full control.


Hope this helps
0
 
jasonbeardAuthor Commented:
looked at that, set full permissions on both pcs, i was thinking is may be the NetBIOS, but i don't im not sure,
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Jay_Jay70Commented:
Hi jasonbeard,

you need to first make sure you have connectivity.... make sure both can ping each other

after that you need to create identical accounts with the same password on each machine
0
 
jasonbeardAuthor Commented:
i will give this a shot. thanks, ill let you know.
0
 
Keith AlabasterEnterprise ArchitectCommented:
The fact that one PC can see the other shows the base connectivity is present.

Can you provide an ipconfig /all of both machines?
Are the node-types the same?
Do you have some of the 'unmentionable' products such as McAfee or Nortons security software installed?
Is this xp home or Pro?
0
 
jasonbeardAuthor Commented:
keith, i can pull a full ipconfig /all on both machines, one pc has panda antivirus 2006 (pc1), the other came from goodguys and has some antivir or what ever, pc1 is pro, pc2 is home, not quite sure what a node type is?
0
 
Keith AlabasterEnterprise ArchitectCommented:
Can you post the output?
0
 
jasonbeardAuthor Commented:
yea, i will go over there after work tommorrow. thanks kieth
0
 
Keith AlabasterEnterprise ArchitectCommented:
No problem. Sorry its so many questions but ......
0
 
tatkuuCommented:
I had a year ago similar problem, only with Win2000Pro and WinXP(Home). I did everything mentioned here with no success. The problem was solved when I did new clean XP install to this XP-computer. It was couple of years old pc and had updates from Win98 -> Win2000 -> WinXP.

I don't need any answer to this my "problem", just thought this is relevant to mention here... :)

-t-
0
 
FriarTukCommented:
glad i could help
for furture reference could you plz indicate which step (or combo of steps) in particular resolved the issue, thx
0
 
jasonbeardAuthor Commented:
changing local security pocily resolved the issue, thanks for all your help guys
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.