?
Solved

switched ISP, now DNS server cannot resolve *.gov URLs

Posted on 2006-06-03
7
Medium Priority
?
475 Views
Last Modified: 2010-04-18
Hello experts.
I recently switched ISPs, now my DNS server cannot resolve any URL ending in .gov
Everything else seems to work fine
I only use root hints, not forwarders

While troubleshooting, I added SBC's national DNS servers (68.94.156.1 and 68.94.157.1) as forwarders.  This fixed the problem on one subnet, but not another.  Both subnets have the same ISP.

I have tried to re-install DNS by using add/remove Windows components (I don't know if this really re-installs DNS), to no avail.

This is a rather important issue.  Is there is some kind of trick to re-configure or re-install DNS?

Thanks in advance!
0
Comment
Question by:starmonkey
  • 4
  • 3
7 Comments
 
LVL 30

Accepted Solution

by:
Irwin Santos earned 2000 total points
ID: 16824349
don't reinstall DNS..

go to your forward zone, modify the properties of your NS record and increment the SOA. update your server data files, then restart your DNS server.
------------------- this will make sure that your server will be current ------------------------

as for your other subnet...is there another router in place, and if you are running DHCP?  Whatever is issuing the DHCP, confirm you have SBC DNS servers configured.
0
 
LVL 4

Author Comment

by:starmonkey
ID: 16824532
When I did this the serial number increased from 94 to 95.  Is there a particular ser number I need to increment it to?What does incrementing the SOA do?  Also, I have multiple AD integrated DNS servers.  Is there an order I need to set the serial number to?  Sorry, to ask so many questions, but I'm trying to understand this.

The other subnet is a remote location on an entirely different router connected via firewall to firewall VPN tunnels.  The remote subnet has a local DC running DHCP for that subnet.  All 3 DCs are part of the same domain.  The remote DC issues IPs that points DNS to back to itself.  The 3 DNS servers all share the same AD DNS zones.  Like the main site, the remote DC/DNS server never had forwarders, only root hints.  Possibly, the reason adding that the forwarders to the remote site wasn't effective was I didn't re-start the server.  I'd rather get the whole system working without forwarders, and I can't shake the suspicion the problems at both locations has the same root cause.

I'm more concerned with getting the main site up for now.  In a pinch, I can have the remote DNS point back to the main site's DNS servers.
0
 
LVL 30

Expert Comment

by:Irwin Santos
ID: 16824593
The correct format is

YYYYMMDDXX  where xx is the version

when you increment SOA and update your server datafiles.. this alerts routers upstream that you have a more current entry.  Dynamic update your other AD servers to your MAIN DNS server, that way, any changes on the main will reflect on the AD servers.

Here's a place to test your configuration.
http:/www.dnsreport.com

Regarding your subnet..apply what you stated in your question, and you should be all good.  OR have the remote dynamic update to your main DNS server.
0
Restore individual SQL databases with ease

Veeam Explorer for Microsoft SQL Server delivers an easy-to-use, wizard-driven interface for restoring your databases from a backup. No expert SQL background required. Web interface provides a complete view of all available SQL databases to simplify the recovery of lost database

 
LVL 4

Author Comment

by:starmonkey
ID: 16824948
I tried it, no luck.  Still having the same problem.

regarding dnsreport.com, these are all internal DNS servers not public dns servers.

I think I'm missing somethinig obvious here.
0
 
LVL 30

Expert Comment

by:Irwin Santos
ID: 16825165
how about clearing the DNS cache??
0
 
LVL 4

Author Comment

by:starmonkey
ID: 16827474
Tried that.
There is something else going on here.  I tried installing DNS on stand alone servers at the same site and here at my house.  The stand alone server at the site had the same problem, but the one here at my home did not.  I used identical procedures in both locations, and neither server has had DNS installed in the past.

I can only conclude this must be a problem with the specific DSL service, or some setting on the DSL router.  Monday I will contact SBC and work it out with him.

Until then I have the network functioning by adding the SBC DNS forwarder to the main site and adding the main site DNS as a forwarder for the remote site.

Even though I still have the issue, I feel you answered my question thoroughly and very quickly, so I'm accepting your answer with my thanks.
0
 
LVL 30

Expert Comment

by:Irwin Santos
ID: 16828111
cool.. thank you starmonkey..!!

Aloha from Hawaii,

Irwin
0

Featured Post

Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Organizations create, modify, and maintain huge amounts of data to help their businesses earn money and generally function.  Typically every network user within an organization has a bit of disk space to store in process items and personal files.   …
This may not be a text book method to resolve VSS backup issues but it seemed to have worked on few of the Windows 2003 servers we had issues while performing a Volume Shadow Copy backup. If you have issues while performing a shadow copy backup usin…
Integration Management Part 2
Whether it be Exchange Server Crash Issues, Dirty Shutdown Errors or Failed to mount error, Stellar Phoenix Mailbox Exchange Recovery has always got your back. With the help of its easy to understand user interface and 3 simple steps recovery proced…

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question