[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Network Configged - Netpkg error says "network not found"

Posted on 2006-06-03
17
Medium Priority
?
424 Views
Last Modified: 2008-01-09
The internet works perfect. I configged the network and and on Experts-Exchange. Yet when I try to run Netpkg, it says "Network not found".

I have a LAN based internet connection. It has the auto config option so I'm not required to mention any network addresses etc.

Any clue? Thanks!
0
Comment
Question by:lexxwern
  • 9
  • 5
  • 2
  • +1
17 Comments
 
LVL 12

Author Comment

by:lexxwern
ID: 16826706
Only Firefox and Thunderbird are the apps working. Every other net based app doesn.t. Network settings are using an auto-DHCP
0
 
LVL 11

Expert Comment

by:mwnnj
ID: 16826839
Hi lexxwern,
type
#netpkg list - all -->to check out for new software packages;
also reassure to run netpkg as root;
here are the forum topics regarding zenwalk:
http://support.zenwalk.org/index.php?PHPSESSID=48b6843732d0a5e48d1fdedfc07871c0
also check out the zenwalk manual:
http://manual.zenwalkers.tuxfamily.org/manual_en.pdf


Cheers!
0
 
LVL 12

Author Comment

by:lexxwern
ID: 16826868
I've tried all those. Didn't find any help. :S
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
LVL 22

Expert Comment

by:pjedmond
ID: 16827611
We love 'auto config'! - Do you really trust a computer;)

OK - A number of things - First do you have more than 1 network interface? This may cause some problems if linux by default. It may be that netpkg and the rest of the OS is using the wrong ethernet connection?

Second possibility is that you have a router, and there is no 'gateway' in the network configuration. Firefox and Thunderbird may have automatically worked this out and as a result have a proxy/gateway element configured to ensure that they work successfully. There fore we need the following information from your system:

1.    The outpuf from:

ifconfig

2.    The output from:

route print

My guess is that you will need to specify a gateway for the default network using "route add", or your usual network configuration tools.

HTH:)


0
 
LVL 12

Author Comment

by:lexxwern
ID: 16827691
root[~]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:40:95:30:B5:21
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:367 errors:0 dropped:0 overruns:0 frame:0
          TX packets:369 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:236251 (230.7 KiB)  TX bytes:98578 (96.2 KiB)
          Interrupt:10 Base address:0xcc00

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:26 errors:0 dropped:0 overruns:0 frame:0
          TX packets:26 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1634 (1.5 KiB)  TX bytes:1634 (1.5 KiB)



..

1) Yes I just have eth0 .. that's the only one .. :)

2) I don't have a router (just a normal PC) and the Gateway is set to "auto config" by the DHCP.
0
 
LVL 12

Author Comment

by:lexxwern
ID: 16827695
The default gateway is set successfully btw. Only the host/domain of the machine are left unset.
0
 
LVL 20

Expert Comment

by:Gns
ID: 16829709
Um, what is needed is the output from the route command, not any "router". This will wshow what your linux box thinks is the next hop.

Further, if you have nothing else, where did your linux box get the config from? Your "gateway"? Well, "gateway" is just anothr word for "router" most of the time;-).
If your "gateway" is some form of "broadband gateway", it's also likely a firewall (NATing fromthe looks of it;), it might be that particular hunk of junk, er, fine piece of HW that is the culprit.
To be able to help determine better what is up, you need provide more info on your topology and your systems (auto-)config (menaing: what it actually got fed from the DHCP server).

-- Glenn
0
 
LVL 11

Expert Comment

by:mwnnj
ID: 16830763
lexxwern,
> inet addr:192.168.1.2 --> this means it's your internal ip address ,so i assume you're using a special proxy and NTAT to get access to the internet;
if netpkg is reading only your internal ip address ,then surely it will state that you don't have access to the internet ;
how did you configure the settings for firefox and thunderbird?
also to make sure check out your internet settings on your windows xp installation:
start->run->cmd,then type ipconfig /all

cu
0
 
LVL 12

Author Comment

by:lexxwern
ID: 16830785
The firefox connections are set to "direct connection to the internet". I'm now being forced to download mozilla irc and ftp extensions. ;-)

Windows settings are much the same, auto detects DHCP .. gives me 192.168.1.2 and the dns and gateways as 192.168.1.1 ... I'm honestly amused!
0
 
LVL 20

Expert Comment

by:Gns
ID: 16831524
Ah, then we can probably scrap the idea about this being a route(r) issue... Just for completeness, would you mind providing the info from "route" command (do it like "route -n" as root, as well). should confirm your statement above, but it'll also tell us a bit about the name resolution bit.

Could you please confirm that simple commandline network tools like "ping 192.168.1.1" and "ftp ftp.sunet.se" (or some other ftp site, perhaps closer to you...) work as expected. It doesn't hurt to quote the results here, so that we get the verbatim error messages.

I'm no zenwalk guru, but just perhaps the error message usn't litteraly "the network", but "that particular network 'place'"... Would be a merry chase:-)

-- Glenn
0
 
LVL 12

Author Comment

by:lexxwern
ID: 16831595
root[~]# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 eth0

root[~]# ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_seq=1 ttl=255 time=3.56 ms
64 bytes from 192.168.1.1: icmp_seq=2 ttl=255 time=0.596 ms
64 bytes from 192.168.1.1: icmp_seq=3 ttl=255 time=0.634 ms
64 bytes from 192.168.1.1: icmp_seq=4 ttl=255 time=0.615 ms
64 bytes from 192.168.1.1: icmp_seq=5 ttl=255 time=0.612 ms
64 bytes from 192.168.1.1: icmp_seq=6 ttl=255 time=0.616 ms
64 bytes from 192.168.1.1: icmp_seq=7 ttl=255 time=0.605 ms
64 bytes from 192.168.1.1: icmp_seq=8 ttl=255 time=0.607 ms
64 bytes from 192.168.1.1: icmp_seq=9 ttl=255 time=0.618 ms
64 bytes from 192.168.1.1: icmp_seq=10 ttl=255 time=0.598 ms
64 bytes from 192.168.1.1: icmp_seq=11 ttl=255 time=0.623 ms
64 bytes from 192.168.1.1: icmp_seq=12 ttl=255 time=0.615 ms
64 bytes from 192.168.1.1: icmp_seq=13 ttl=255 time=0.625 ms
64 bytes from 192.168.1.1: icmp_seq=14 ttl=255 time=0.551 ms
64 bytes from 192.168.1.1: icmp_seq=15 ttl=255 time=0.532 ms
64 bytes from 192.168.1.1: icmp_seq=16 ttl=255 time=0.619 ms
64 bytes from 192.168.1.1: icmp_seq=17 ttl=255 time=0.617 ms
64 bytes from 192.168.1.1: icmp_seq=18 ttl=255 time=0.620 ms
64 bytes from 192.168.1.1: icmp_seq=19 ttl=255 time=0.628 ms
64 bytes from 192.168.1.1: icmp_seq=20 ttl=255 time=0.613 ms
64 bytes from 192.168.1.1: icmp_seq=21 ttl=255 time=0.620 ms
64 bytes from 192.168.1.1: icmp_seq=22 ttl=255 time=0.618 ms
64 bytes from 192.168.1.1: icmp_seq=23 ttl=255 time=0.646 ms
64 bytes from 192.168.1.1: icmp_seq=24 ttl=255 time=0.630 ms
64 bytes from 192.168.1.1: icmp_seq=25 ttl=255 time=0.594 ms
64 bytes from 192.168.1.1: icmp_seq=26 ttl=255 time=0.537 ms
64 bytes from 192.168.1.1: icmp_seq=27 ttl=255 time=0.549 ms
64 bytes from 192.168.1.1: icmp_seq=28 ttl=255 time=0.623 ms
64 bytes from 192.168.1.1: icmp_seq=29 ttl=255 time=0.539 ms
64 bytes from 192.168.1.1: icmp_seq=30 ttl=255 time=0.547 ms
64 bytes from 192.168.1.1: icmp_seq=31 ttl=255 time=0.553 ms
 << ctrl+c>>
--- 192.168.1.1 ping statistics ---
31 packets transmitted, 31 received, 0% packet loss, time 30133ms
rtt min/avg/max/mdev = 0.532/0.695/3.560/0.524 ms
root[~]# ftp ftp.sunet.se
Connected to ftp.sunet.se.
220 Welcome to ftp.sunet.se
Name (ftp.sunet.se:root): anonymous
331 Any password will work
Password:
230 Any password will work
Remote system type is UNIX.
Using binary mode to transfer files.
ftp>
0
 
LVL 20

Expert Comment

by:Gns
ID: 16831837
Good, then we have established beyond any doubt that this is not a networking problem, but rather an application problem.

The Merry chase it is then. Sigh.

Have you edited /etc/netpkg.conf since install? Looking at that file, does it look ... OK?
Are you running the CLI or the GUI?
Can you manually reach the update server(s) (as read from the config file)? <--- I suspect this is the problem... A quick google seem to corroborate this...
Or perhaps not. Look at http://support.zenwalk.org/index.php?PHPSESSID=9977b297c8f86e64c2e9d5315d8a9ca0&topic=1259.msg7096
Seems that you either have a very specific error condition, or that your wget package is hosed somehow. Try (re-)installing it, as per thils advice in the link.

-- Glenn
0
 
LVL 12

Author Comment

by:lexxwern
ID: 16831856
I doubt its a netpkg related issue.. simply because firefox/thunderbird is the only internet based apps that are working!

I'm using the GUI atm.
0
 
LVL 20

Expert Comment

by:Gns
ID: 16831919
?
No no, you've just proved that ping and ftp works equally well as firefox and thunderbird.

What tools, apart from netpkg, doesn't work?
What exact error messages do you get?
Is it feasible they rely on wget in some way? Then there is your culprit;-).

I suspect that running the CLI will possibly reveal some more error messages, but likely won't work any better than the GUI... Doesn't harm trying though;-).

A bit irritating when the update tool is the most prominent one to _not_ work... Means one has to rely on more ... manual... methods to get/apply ones updates, which isn't that feasible.
When you check the update repository, check both for wget and netpkg updates.

-- Glenn
0
 
LVL 12

Author Comment

by:lexxwern
ID: 16832019
They don't give any error as such. gIRC/Gain/GTFP keep trying to connect till timeout.
0
 
LVL 12

Author Comment

by:lexxwern
ID: 16832239
wget is extracted to /root/Desktop/wget/  .. what's the command line to install it, the package tool fails me .. ;)
0
 
LVL 20

Accepted Solution

by:
Gns earned 2000 total points
ID: 16832441
> They don't give any error as such. gIRC/Gain/GTFP keep trying to connect till timeout.
Well, IRC and Gaim might need some "help" through the gateway (port forwarding rules or similar, on that device... Not unheard of:-), but gFTP should be able to connect... Can you use that to connect to ftp.sunet.se, as you did above with the command-line tool?

> wget is extracted to /root/Desktop/wget/  .. what's the command line to install it, the package tool fails me .. ;)
installpkg /path/to/tgz
... with appropriate privs etc, on a commandline. Just as it'd be on any slackware, I'd imagine (as said, I'm far from a zenwalk guru, and it has been a couple of years since last I tangled with slackware proper...;)... So you don't have to unpack the tar-ball, installpkg should take care of that, as well as the build->install.

-- Glenn
0

Featured Post

Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will show you step-by-step instructions to build your own NTP CentOS server.  The network diagram shows the best practice to setup the NTP server farm for redundancy.  This article also serves as your NTP server documentation.
Often times it's very very easy to extend a volume on a Linux instance in AWS, but impossible to shrink it. I wanted to contribute to the experts-exchange community a way of providing a procedure that works on an AWS instance. It can also be used on…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Suggested Courses
Course of the Month17 days, 20 hours left to enroll

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question