Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

4GB limit while copying to the external drive

Posted on 2006-06-04
43
Medium Priority
?
2,389 Views
Last Modified: 2012-06-27
Hi!

My friends wanted to copy movie files larger then 4 GB from their PC to the external LACIE 250 GB drive and they were coming with the error that there is not enough space. I tried to help it various ways with no luck. I only succeeded when in editing program I split the files into pieces smaller then 4GB. I also tried to burn those files to the data DVDs, but then I got the message: "The current File System does not support file sizes larger then 4 GB.

We tried two different LACIE drives, we got the same error. I use the same LACIE drive and was copying across larger files, never came across any problems.

I research a bit and now now that it could be to do with formatting (FAT32 and NTFS), but as I said I use those LACIE drives and I have never had to format them.

My friends' PC is very slow, so very possible there is a problem somewhere, but before we reinstall anything we want thos files copied across in whole pieces. Is it possible that it's just doesn't recognize the size of the LACIE drive?

My questions are:
1.) I know the BIOS might not recognise the correct size of the drive. How do I check what it sees and can I change it and of course witout affecting the PC performance?
2.) If it doesn't help and I need to try to format the drive - are we talking here about formating the drive I copy TO (the LACIE) or the drive I copy FROM (I don't really want to do this, as they have their all work there and don't want to loose anything).

Thank you,

j.
0
Comment
Question by:justeena
  • 15
  • 12
  • 6
  • +4
43 Comments
 
LVL 11

Expert Comment

by:Zuhir Elgmati
ID: 16826789
Maximum Sizes

The maximum file size and volume size for the FAT file system is 2^32 bytes (4 GB). FAT can support a maximum of 65,535 clusters per volume.

The NTFS architecture is designed to use numbers up to 2^64 bytes (16 exabytes, or 18,446,744,073,709,551,616 bytes). In theory, it is possible to have a volume 264 bytes in size. Even if there were hardware available to supply a logical volume of that capacity, there are other limitations to the maximum size of a volume........etc

http://www.microsoft.com/technet/archive/ntwrkstn/reskit/file_sys.mspx?mfr=true
0
 
LVL 11

Expert Comment

by:Zuhir Elgmati
ID: 16826799
ok try these steps :

1- format u r pc with NTFS file System
2- get the latest update of your BIOS
3 Connect your EXternal HDD and format it
0
 

Author Comment

by:justeena
ID: 16826802
It doesn't really answer my questions. Can I check anything? Change anything? Without loosing data. We are talking of limitations on which drive? On the PC or on the LACIE?

j.
0
Who's Defending Your Organization from Threats?

Protecting against advanced threats requires an IT dream team – a well-oiled machine of people and solutions working together to defend your organization. Download our resource kit today to learn more about the tools you need to build you IT Dream Team!

 

Author Comment

by:justeena
ID: 16826845
If I format pc with NTFS file system will I not loose any data?

j.
0
 

Author Comment

by:justeena
ID: 16826854
Before I format how can I check the PC BIOS - what size drives it sees?

 
0
 
LVL 32

Expert Comment

by:willcomp
ID: 16827150
How about providing some info on PC such as OS and CPU.
0
 
LVL 11

Expert Comment

by:Zuhir Elgmati
ID: 16827217
1st at all what's your OS ?
-----------------------------------
let me tell you something :
1- as i understand u can't copy file's it size 4 GB . Is that true ?? so i suggest to format u r HDD with NTFS file system to Be able to copy largest files .
2- as i understand your PC can't recognize your external HDD with huge Size ..... is that true ?? so i suggest to update your BIOS of your pc to be able to recognize the huge size of your external HDD
3- format your EXT HDD with NTFS file system  to Be able transfer and receive huge data

have i understand you right ?
0
 
LVL 11

Assisted Solution

by:Zuhir Elgmati
Zuhir Elgmati earned 120 total points
ID: 16827231
by the way u can change your File System without formating ... u can convert your file system from FAT or FAT32 to NTFS file system
0
 
LVL 14

Expert Comment

by:mysticaldan
ID: 16827447
Try this.

1. Attach your External Drive so that its detected.
2. Open up Computer Management from under Control Panel>Admin Tools.
3. Go to Disk Management.
4. Delete all partitions marked under ur external drive. Make sure you check that the drive letters assigned and the drive number match that of the external drive. Also make sure u have all ur data on the external drive backed up.
5. Now right click on the blank drive and select create partition. Choose it as a Primary partition and select the size of the partition and the type as NTF. Do a quick format and thats it.

Now you shud have no problem.

Dan
0
 
LVL 7

Expert Comment

by:computerfixins
ID: 16827788
Like mystic said, as long as the device your are writing too is ntfs, you can create +4GB files.  

Does not matter what your OS os running on locally.

If you attempt the fat32-ntfs converision, backup first, can go horrible wrong.
0
 
LVL 31

Expert Comment

by:rid
ID: 16827856
The file size limit is in the file system - FAT32 - and it applies to internal and external drives alike. Obviously, the PC will have NTFS, as there seems to exist files larger than that on the system. The external drive, if FAT32, cannot accept those files. You will have to reformat the external drive NTFS. Make sure you copy off all data from it first.
/RID
0
 
LVL 70

Expert Comment

by:Gary Case
ID: 16828001
justeena --  this discussion is making things sound too hard :-)

Let's make it simple:

(1)  The issue you're having is (as noted) simply that FAT-32 does not allow files larger than 4GB;

(2)  Your COMPUTER is fine -- it's the external Lacie drive that's causing the restriction because of it's FAT-32 file system;

(3)  You do NOT have to reformat the Lacie (and lose everything) ... just do this:

(a)  Connect the Lacie, and note what drive letter it is (suppose it's drive L:)

(b)  Click Start, Run and type CMD - then click OK  to open a Command Prompt window

(c)  Type convert L: /fs:ntfs  ==>  This will convert the file system on the Lacie to NTFS without causing any loss of data.   (Be sure the drive letter is correct)

DONE  :-)

... incidentally, you don't have to worry about what size drives your PC's BIOS supports => with an external drive the 48-bit LBA support is in the external controller (and obviously Lacie's controller is fine).
0
 
LVL 70

Expert Comment

by:Gary Case
ID: 16828016
... if you want to read the details on convert, you can see them either of two ways:

(1)  In a Command Prompt window type "Help Convert"  ==> this will show you all the options

(2)  Read the Microsoft TechNet article on it:  http://www.microsoft.com/technet/prodtechnol/winxppro/maintain/convertfat.mspx

But it really is that simple:  Just type  "Convert  L:  /fs:ntfs"  and you're done :-)
0
 
LVL 70

Expert Comment

by:Gary Case
ID: 16828022
... one caveat (just so you're aware):  probably the main reason that Lacie uses FAT-32 format for their external drives is that both PC's and Mac's can read FAT-32 partitions.  Mac's CANNOT read NTFS partitions;  so if you do the conversion the drive will NOT be useable on a Mac anymore.   This may or may not be a consideration in your case -- but you should be aware of that before doing the conversion.
0
 

Author Comment

by:justeena
ID: 16828125
Thanks for all this. I will be able to try it tomorrow as it's on my freinds' PC.

We have two LACIE drives we can use, one is brand new and empty, I will work with this one than, so I won't loose any data.

I'm glad that you think the PC is fine, as if i had to format it, I'd have loooots of backing up to do. :(

What surprises me though is, that I have been using LACIE drives myself (my own ones not my friends', backing up onto them very big files (up to 10GB) and had no problems whatsoever. Besides we used two different LACIE drives. Also why I had problems writing the files to data DVD writer, which I use at home with my PC for larger files with no problems? Would I have to change it to NTFS? Why if it's fine on other machines?
Doesn't it look to you that the PC just doesn't see the external devices correctly or it doesn't want to let the files greater then 4GB go? :0
I believe you that PC is fine, I will try to convert the external drive, but I think that the fact that 3 devices were refused is a bit too much.
Don't you think?

(This LACIE will be used with PC. If we ever need those files on Mac, we will copy it elsewhere first. Thanks for letting me know.)

I will try all this in about 24 hrs and will let you know what happened.

Thank you.

j.
0
 
LVL 70

Expert Comment

by:Gary Case
ID: 16828313
I did make an assumption, since you indicated that there were files larger than 4GB:  the PC is using XP and the PC's hard drive (or at least one volume of it) is formatted with NTFS ==> is that correct?

Looking at your question again, I noted that you said you got the error message "... The current File System does not support file sizes larger then 4 GB" while writing to DVDs.  What writing application are you using (Roxio, Nero, Sonic, etc.) ??   DVD's are written in UDF format, which does not have any file size restrictions (at least none that will ever be encountered with a DVD).   But if you're using an application that's trying to write a DVD in ISO format, then the 4GB restriction of CDFS could be what's causing that message.   If that's the case, you need to use a different writing application.

... as for why your Lacie allows larger (> 4GB) files and your friends doesn't; it has to be a file system difference => yours must be formatted with NTFS.   Right-click on your Lacie drive in My Computer and do a "Properties".    What does it show for "File System" ??    Have your friend do the same.   I'd be very surprised if yours doesn't show "NTFS" and your friends doesn't show "FAT32".

0
 

Author Comment

by:justeena
ID: 16829288
Hi there,

Finally somebody is telling me wher I can find those info about NTFS and FAT32! :)
Thanks garycase!!!

Suddenly everything is much more clear. Ok, what happened is that my laptop is NTFS, while my LACIE drives are... FAT32. So are definitively my friends' (I will check their PC tomorrow, but I'm sure it must be NTFS as rid noticed above, the files got there in the first place).
Anyway I went back to the bigger files that I thought I could copy across on my LACIE and thinking they're over 4GB and actually the folders were over 4GB, but single files were split into pieces, so they never bigger really than 2GB!

So I created a larger file - 6GB on my laptop and... got the same error - not enough space on the external drive! Eureka! :)
So I think you are right I have to convert the LACIE to NTFS...

Then when I wanted to write a data DVD, I got the same error about File System as on my friends PC. I wasn't using the ISO, just wanted to write a data DVD to 8.5 GB disc using Roxio Easy Media Creator Basic DVD Home and then just choosing Data option - copy files to disc. Which software shall I use it to write data 8.5 DVDs? Or maybe my DVD writer is not for 8.5GB discs? How can I check it?

So thank you for this fantastic discussion, but don't leave me yet guys! :)
Tomorrow I will do the following:
(a)  Connect the Lacie, and note what drive letter it is (suppose it's drive L:)

(b)  Click Start, Run and type CMD - then click OK  to open a Command Prompt window

(c)  Type convert L: /fs:ntfs  ==>  This will convert the file system on the Lacie to NTFS without causing any loss of data.   (Be sure the drive letter is correct)

And I let you know what happened.

In the meantime, how to handle my DVD data writing for bigger files?

Thank you!!!

j.

0
 
LVL 70

Expert Comment

by:Gary Case
ID: 16829413
"... And I let you know what happened ..." ==> ... what will happen is the drive will then be NTFS and you can copy your large files to it :-)

... as for your DVD writing larger files ==>  I don't have the same version of Roxio, so the location may be slightly different;  but look on the File Menu for Project Settings;  then click the General tab and see what the File System is set to.   This SHOULD be "UDF 102" ==> which will allow you to write large files with no problem.   The error message you're getting indicates it may be set to Joliet or ISO 9660.

... I don't know if your burner is a dual-layer burner => if you don't know for sure, post the make/model # and I'll look it up for you.   But that's not the problem here -- Roxio will "span" files across multiple discs if they're too large;  your problem is it's not allowing you to write files larger than 4GB; which indicates it's trying to use a file system (e.g. CDFS) that's limited to 4GB files.

0
 
LVL 70

Expert Comment

by:Gary Case
ID: 16829429
... if you don't have a File System option under Project Settings, try the write again and post EXACTLY what the ENTIRE message you get says.
0
 
LVL 32

Expert Comment

by:willcomp
ID: 16829484
For EZ Media Creator 7, selection is located in Project Properties under General tab.  Choice of UDF102, Joliet, and ISO9660.  That's for a Data disk (Copy files to disk) project which should be used to copy files.  Also ensure that an 8.5GB DVD is selected vs standard DVD in main Creator Classic window.

As Gary indicated, UDF102 should be used.  If it is, can span disks.
0
 
LVL 11

Expert Comment

by:Zuhir Elgmati
ID: 16830945
Mr.  garycase  &  Author : i want to inform you if you check my answer i suggest to  Author to convert from fat32 to ntfs but he don't replay me . if he replay i will told him how ..... what you think??
0
 

Author Comment

by:justeena
ID: 16831381
Ok, sorry about that, I'll keep it in mind!
I wasn't near the Internet at that time and when I got back garycase has already posted the details. Pls look at my first comment to your first answer. Only garycase told me where I can check the formatting and things became clear.

j.

0
 

Author Comment

by:justeena
ID: 16837305
Unfortunately I need some more help here.

Yes my friends computer is NTFS, but LACIE is FAT32.

I did the following:
(a)  Connected the Lacie, it was letter I.

(b)  Clicked Start, Run and type CMD - then click OK  to open a Command Prompt window

(c)  Typed: convert L: /fs:ntfs  

Then I clicked enter and I received this:
Enter current volume label for drive I:

What is that?
:(

j.
0
 
LVL 31

Assisted Solution

by:rid
rid earned 120 total points
ID: 16837384
The volume label is usually a string of letters... it is optional and should show somewhere in the explorer window (like a comment for the drive).
/RID
0
 

Author Comment

by:justeena
ID: 16837449
I'm not any more in front of my friends' PC, but I look at mine and the LACIE and cannot see anything in the explorer window. More details pls.
0
 
LVL 32

Assisted Solution

by:willcomp
willcomp earned 120 total points
ID: 16837462
Open My Computer and see if the drive has a label.  Will be something besides Drive I:  Most likely, it has no label and you can just press enter (no label) when prompted for a label.

Drive label is added when drive is formatted.  Can be of your choosing such as My-Drive.
0
 

Author Comment

by:justeena
ID: 16837534
Next to I: it's just says LACIE.

Shall I then just typed LACIE then?
0
 
LVL 31

Expert Comment

by:rid
ID: 16837578
Seems OK...
/RID
0
 
LVL 32

Expert Comment

by:willcomp
ID: 16837582
Try blank first and then LaCie.  LaCie may just be from USB device designator.  There is no harm in entering an incorrect volume label and you'll know it's wrong.
0
 

Author Comment

by:justeena
ID: 16837704
As to my DVD writer - when I checked File>Project settings it was set to File System UDF102 and Bridge:Joilet Bridge.

I think my burner is dual layer. It's LACIE LightScribe 8.5GB 16x4x12x DVD±RW FW/USB.

Again the error when I try to burn to DVD (with 8.5 GB selected) is:
Compatibility Warning
Your project layout contains a file larger then 4GBs. The current file system does not support file sizes larger then 4GBs. Do you wan to delete it from the project and continue recording?

Still the same error.

:(

0
 

Author Comment

by:justeena
ID: 16837820
I think I tried blank, no success. Will try LaCie.
0
 
LVL 70

Accepted Solution

by:
Gary Case earned 1640 total points
ID: 16837843
Just in case the comments about the label aren't clear:

Open My Computer.

Point to one of your drives; right-click; and do Properties.

On the General tab (the one that is initially displayed) there's a picture of a disk drive.   To the right of that is the drive's label.   You can change it by just typing something new if you want to label your drives more descriptively.   Underneath that is where it shows the "Type" and the "File System"  (the same place you looked yesterday).

You said you did the following:

(a)  Connected the Lacie, it was letter I.
(b)  Clicked Start, Run and type CMD - then click OK  to open a Command Prompt window
(c)  Typed: convert L: /fs:ntfs  

I presume in (c) you actually typed an "I" instead of an "L"  :-)

The reason it asks for the label is to be SURE you're converting the drive you wanted to.   So if it's blank (nothing displayed in My Computer) just use that;  if it's "Lacie" just use that;  etc.

As for your DVD burner ==>  You said it was  "... set to File System UDF102 and Bridge:Joilet Bridge ..."
That is CORRECT.   It should allow you to burn large files with no problem !!   Are you burning to a BLANK CD (not one you're trying to append to; and not one that's been "formatted" with any packet writing software such as DirectCD, InCD, etc.) ??
0
 
LVL 70

Expert Comment

by:Gary Case
ID: 16837863
... one other thought r.e. your DVD burning issue:   In Roxio, look on the Tools - Options - General tab and see what the TEMP file location is set to.   Now open My Computer and do a right-click Properties on the drive that contains the TEMP file.    What file system is it using (NTFS or FAT32) ??
0
 

Author Comment

by:justeena
ID: 16837889
Thanks garycase,

Yes, of course I typed I: not L:  :)

Yes, it says LACIE, so I will type it in (tomorrow).

For burning I use blank new 8.5 Verbatim DVD. I use them often at work, no problems with them.
:(

0
 
LVL 70

Expert Comment

by:Gary Case
ID: 16837950
What version of Roxio are you using?      Do a "Help - About" and post what is shows ==> for example, mine says "Roxio Easy Media Creator 7 (Build 7.1.1.189 ENU)"
0
 

Author Comment

by:justeena
ID: 16837967
It's Roxio Easy Media Creator 7 Basic DVD Edition (Build 7.1.0.217 ENU)

It was supplied with the burner.
0
 
LVL 32

Expert Comment

by:willcomp
ID: 16838197
Gary, good catch on FAT32 for temp file.  This link's for you.  I may have to start using Intel chips again.

http://www.hexus.net/content/item.php?item=5692&page=3

0
 
LVL 70

Expert Comment

by:Gary Case
ID: 16838525
Ahhh yes ... another nice Conroe benchmark.   You may recall a couple months ago I was thinking seriously about building an AMD dual-core system ==> then I read a Conroe benchmark  --->   So ... my current plan is to build a nice dual-core Conroe system this fall :-)

justeena -- is your temp file on a FAT32 volume?   If not, I'm not sure why your copy of Roxio is refusing to write files > 4GB.   You should log onto Roxio's site and download the updates for Easy Media Creator, just in case there's something along the way that resolved that problem.
0
 
LVL 32

Expert Comment

by:willcomp
ID: 16838547
Those were supposedly first independent test results of Conroe vs FX62 on AM2 mobo.  Note that those are middle of the road Conroes and not EE version.
0
 
LVL 70

Expert Comment

by:Gary Case
ID: 16838616
Yep :-)  :-)    ... however, despite the huge windfall I anticipate by converting all my EE points into dollars;  I will probably still be limited to one of those "middle of the road" Conroes when I build my next system :-)  :-)

0
 

Author Comment

by:justeena
ID: 16842917
I checked -  In Roxio - Tools - Options - General tab the TEMP file location is set on my C drive, which is NTFS.


0
 
LVL 70

Expert Comment

by:Gary Case
ID: 16842968
Do you have the installation disc for Roxio?    If so, I would completely uninstall it; reboot; and then re-install it.   I would also log into Roxio's site (you'll have to register, but that's easy), and then download the updates for your software.    With the settings you've indicated, this SHOULD be working fine for files of ANY size !!
0
 

Author Comment

by:justeena
ID: 16847700
Ok, thanks for that. I'll keep trying, at least I know the settings now.

I finally converted my friends' Lacie to NTFS... and of course I could copy the files across with no problems! :)

Thank you all!!!

All the best!

j.
0

Featured Post

Who's Defending Your Organization from Threats?

Protecting against advanced threats requires an IT dream team – a well-oiled machine of people and solutions working together to defend your organization. Download our resource kit today to learn more about the tools you need to build you IT Dream Team!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This is about my first experience with programming Arduino.
This paper addresses the security of Sennheiser DECT Contact Center and Office (CC&O) headsets. It describes the DECT security chain comprised of “Pairing”, “Per Call Authentication” and “Encryption”, which are all part of the standard DECT protocol.
Integration Management Part 2
How can you see what you are working on when you want to see it while you to save a copy? Add a "Save As" icon to the Quick Access Toolbar, or QAT. That way, when you save a copy of a query, form, report, or other object you are modifying, you…
Suggested Courses

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question