?
Solved

HP 2300 Printer installation problem

Posted on 2006-06-04
4
Medium Priority
?
1,867 Views
Last Modified: 2013-12-15
I have a problem with installation of HP 2300L. Computer: WinXP SP2, Connection: USB. Everything worked perfectly (the printer works great - I tested with another computer), but then I installed HP D135, and after a while I had to uninstall it. All installations and unstallation were successful - no errors, nothing. Rebooted as required.
Now, after *successful* installation of HP 2300, and reboot, the printer is not on the Printers List, and can't even add it manually.
Do you know of any GOOD HP clean utility, to delete of every trace of HP garbage?
What do you suggest to do?
Thanks
0
Comment
Question by:athanasius296
  • 2
4 Comments
 
LVL 3

Expert Comment

by:Jbirk1
ID: 16828033
Hi,

What you will first want to do is use Add/Remove programs and uninstall all your HP printer stuff.  I am assuming you have already done that though.

Next, open Printers and Faxes.

Now right-click and select "Server-Properties"

Click on the drivers tab and select each printer you want to remove the drivers for and click on Remove.

You can also click on the ports tab and click on "Delete Port" if you want to clean up any USB or Network ports that were installed.  Leave all the LPT, COM, and Serial, and Print to File ports.  Also leave any ports you use.  Delete things like USB001...

You can also right click on MyComputer and go to properties and click the "Hardware Tab"  then the "Device Manager" button and possibly delete printers there.

Another thing you can do is cleanup the device manager previous device history.

Start Run and type CMD

AT the command prompt

set devmgr_show_nonpresent_devices=1
devmgmt.msc

That will open the device manager in special mode to show all devices ever attached to the computer.

Now, view "Show Hidden Devices"

You will really see all the hidden devices after doing this.  YOu will see every memory stick, usb hard drive, keyboard, cdrom drive, et cetera.  You can delete any remnents of your printer if you wish.


If the printer has documents that haven't printed, open the printer in Printers and Faxes and delete the documents.  Sometimes they hang up.

If this hangs up or you cannot uninstall the printer becuase it has jobs remaining in the queue, click on start then Run and put in C:\WINDOWS\System32\spool\PRINTERS

Now open the command prompt via start run cmd

type the following

net stop spooler

Now go to the open folder C:\WINDOWS\System32\spool\PRINTERS and higlight all the wierd file names and delete them.

Now go back to the prompt and type

net start spooler


Essentially, this process takes down the print spooler, deletes everything the spooler is supposed to spool to all your printers, then it brings the spooler back up.  Sometimes if deleting won't work and you delete a job hanging the printer object on deleteing, a restart will be enough to get the jobs deleted.


Anyway, at this point, you should be able to install your printer no problem just following the manufacturers instructions.  If it gets to a point where it is supposed to detect the printer and it doesn't, you can just continue anyway or you can sometimes go into device manager and scan for hardware, delete any unknown devices, et cetera.

Sometimes it just needs a little bit or coercing.   I think you will get you printer installed.


Justin


0
 

Author Comment

by:athanasius296
ID: 16829838
Hi Justin,
Thanks for an extensive instruction. To be sure, I've tried everything you suggested, again. I say 'again', because it's not the first time I went through all of these (except the command 'set devmgr_show_nonpresent_devices=1
devmgmt.msc', which I ran, but found nothing unusual.).
It's interesting, that when I plug in the USB Cable to the computer (without installing the software or the drivers), nothing happens (usually I got this "New hardware found"). I tried all USB ports which I'm sure work fine, since I've been using them for other devices.
Any more thoughts?
Thanks!
0
 
LVL 9

Expert Comment

by:joed
ID: 16830048
Have you tried the other devices since the printer problem started? You could have a defective USB port. Try re installing the USB ports.
0
 
LVL 3

Accepted Solution

by:
Jbirk1 earned 1000 total points
ID: 16830263
This is wierd but not exactly unsolvable.

Go to device manager and delete all of the USB ports.  Just highlight and hit delete.  Obviously, if you have a usb mouse or keyboard, this will stop them from functioning.

Regardless, restart and the USB stuff will be reinstalled, so you will be safe and good to go.  At the very most things won't work for about 5 minutes after you boot.  If this happens, just wait.

Another idea is to try to fix Windows because something might be wrong.  This is only a last resort though.  It should be a piece of cake to install that printer.  Have you tried to go to http://hp.com and download the latest driver via the folder containing the .inf file.  Then selecting Have Disk to install it?


Also, are you logged in as a Widnows Administrator?

0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When I recently replaced my image transfer kit on my office HP color laserjet 5550dn printer, I had a slight problem.  The left bracket that holds the transfer kit got stuck in the upright locked position instead of being at a 45 degree angle facing…
This article shows how to get a list of available printers for display in a drop-down list, and then to use the selected printer to print an Access report or a Word document filled with Access data, using different syntax as needed for working with …
In an interesting question (https://www.experts-exchange.com/questions/29008360/) here at Experts Exchange, a member asked how to split a single image into multiple images. The primary usage for this is to place many photographs on a flatbed scanner…
In a question here at Experts Exchange (https://www.experts-exchange.com/questions/29062564/Adobe-acrobat-reader-DC.html), a member asked how to create a signature in Adobe Acrobat Reader DC (the free Reader product, not the paid, full Acrobat produ…
Suggested Courses

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question