Name resolution within a workgroup

Posted on 2006-06-04
Last Modified: 2008-10-07
At ny home network behind Linksys router, I have 4 Windows XP Pro machines. All can do printer/file sharing using IP address. All except a laptop can do the same using NetBIOS name too. The laptop also fails to ping any other machine using their NetBIOS names but can ping them using their IP addresses. The laptop was brought to home by my son from his school and we changed its workgroup to match the other machines at home. Its network settings are auto i.e. use DHCP to get TCP/IP and DNS parameters. Tried using wired NIC in place of wireless but still the same problem. The only difference in the ipconfig/all output is that the other three machines show "Node Type" as "Unknown", the laptop shows it as "Peer-Peer". How can I make this laptop to resolve host names within my workgroup?

Question by:vinod
    LVL 48

    Expert Comment

    Hi vinod,

    dont rely on the DHCP setting, force netbios

    Author Comment

    > dont rely on the DHCP setting, force netbios

    All four machines are have same settings as far DHCP is concerned, I accepted all defaults.

    LVL 48

    Assisted Solution

    does this apply at all??

    under the properties of your TCPIP config, WINS TAB, enforce netbios
    LVL 14

    Expert Comment

    1) Cntl Panel - Sys prop's - computer name tab - make the workgroup name the same on both PCs.
    2) Cntl Panel - Firewall - Verify file sharing is permitted
    3) Cntl Panel - folder opt's - view tab - adv settings box (scroll to bottom) & check use simple file sharing
    4) Network connection prop's - adv button - wins tab - enable netbios over tcp/ip
         --> Try using the IP address instead of the pc name "\\\Shares". If NetBIOS is not properly exchanging info, this method might get around that.
    5) With XP Pro, you  need to be logged in to "client" PCs with a Userid/pwsd that matches an Account set up in the "host" PC.

         --> By default, a user account is created with no password.  This means the user may sit down locally at the XP machine and log on without entering a password.
         --> However, by default, Windows XP will not permit a network user to access the XP machine using an account set up without a password!

       Permitting Network Access an XP Pro box w/o a Pswd
       Go to Control Panel | Performance and Maintenance | Administrative Tools | Local Security Policy.
       Expand Local Policies | Security Options.
       Double-click Accounts: Limit local account use of blank passwords to console login only, which is enabled by default. Disable this option and click OK.
       * This will permit network access without a password. The user's computer can boot directly to the Windows desktop, and be validated against the corresponding XP Professional user account, without a password.
    LVL 19

    Accepted Solution

    The problem is that NetBIOS name resolution is failing. This makes sense if the "Node Type" is set to Point-to-Point because P-to-P requires a WINS or DNS server, which you almost certainly don't have. The laptop is probably remembering the "Node Type" setting that it received at your son's school. On your other three XP machines the node type is "Unknown" which means it will default to Broadcast - that's why they are working.

    To change the node type on the laptop you must edit the registry, so all the usual cautions about editing registry settings apply. There are two registry keys that could be forcing the node type to P-to-P (value 0x02):

    The latter trumps the former if both exist. I recommend that you set the value for this key to 0x04 which selects Mixed Node Type - it resolves names by first trying a broadcast. If that fails it will look in LMHOSTS, WINS, HOSTS and finally DNS so something should work in that mode. You'll have to reboot the laptop after changing that registry key.

    Here's a link if you want to read more about those registry parameters. (It's a long article: Read the Intro paragraphs, then you could skip forward in the list of parameters by searching for "NodeType"):;en-us;314053

    Author Comment

    Jay_Jay70's short answer was just right.
    feptias's details and additional suggestion to set registry key DhcpNodeType=0x04 seems to have an added value. I wonder why it is not Windows default.

    Thanks to both of you.

    LVL 48

    Expert Comment

    no problem at all, thankyou :)

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Enabling OSINT in Activity Based Intelligence

    Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

    A brief overview to explain gateways, default gateways and static routes OR NO - you CANNOT have two default gateways on the same server, PC or other Windows-based network device. In simple terms a gateway is formed when a computer such as a serv…
    This is the first one of a series of articles I’ll be writing to address technical issues that are always referred to as network problems. The network boundaries have changed, therefore having an understanding of how each piece in the network  puzzl…
    To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
    In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor ( If you're interested in additional methods for monitoring bandwidt…

    759 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    10 Experts available now in Live!

    Get 1:1 Help Now