• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 594
  • Last Modified:

Transaction Timeout

Hi,

  I´m having problems when saving or applying an action (button) on a remote (vpn) Notes application: it connects all right but when saving or pressing a button, a message pops up that "the network operation couldn´t complete in a reasonable amount of time" (of something like that). The problem is not connection timeout, as I can connect to the database, the problem seems to be a "transaction timeout". Is there any configuration I can change in the client? and in the Server?

thanks
0
andreom
Asked:
andreom
  • 15
  • 11
  • 7
  • +1
3 Solutions
 
Sjef BosmanGroupware ConsultantCommented:
You're asking two different things:
1) why do you get the message?
2) how can you prevent the message from appearing?

The message is actually quite "normal", and it has little to do with VPN but more with the structure and implementation of the application or database, the load on the server and the complexity of the operation(s) started. You could try to find out why the operation isn't completed, by checking the log.nsf database on the server. It might be that you need a very large view than needs to be updated, or you do a full-text search on a database that is not full-text indexed. Anything taking a lot of time.

AFAIK, there are no parameters you can set to prolong connection time.
0
 
marilyngCommented:
One other thing, when this happens, check your task bar for the list of events it was trying to do that led to the timeout problem.  If you click on the task bar, the full list of things will be there and you can screen shot them for reference.

It may also be that there's a lookup or number of lookups that are trying to occur.

In one case, we got the message for a bunch of users because the database was trying to do a lookup to a database on a server that no longer existed.  IN another case, the spam program was running some agent that just slowed it down and no one could complete any lookup to names.nsf, not in programs not in email.
0
 
SysExpertCommented:
And you might consider doubling or tripling the TCPIP timeout as a test to see if the error disappears.

The timeout is not just for initial connection, but for the continued connection.

sjef_bosman is correct that if it takes too long to do something on the server, you will also get this message.

0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
andreomAuthor Commented:
the strange thing is that the save or pass (an action) operations work when executed in the lan. They just fail when in the wan (vpn). It is common for databases to have connection timeout and transaction timeout configs. Probably there´s not very common settings for a "transaction timout".
0
 
marilyngCommented:
as sjef says:  structure and implementation of the application or database<<

Usually, if you know that people are accessing your application from the WAN, you test on the WAN, and then streamline to make sure things execute correctly... subforms, shared fields all take longer to process as does many dblookups as compared to one :)

So, you need to look at (if you can) the db construction, and see if you can streamline.  If this is controlled by someone else, the IT dept, etc., then you need to ask them to test on the WAN to see if they get the same error.

It's that reason that the mail template doesn't use many shared subforms, or fields :)
0
 
andreomAuthor Commented:
"then you need to ask them to test on the WAN to see if they get the same error" => the same function works on the Lan and other Users on Wan. My Wan link is a 4Mbps, downloading at almost 500kBps... it´s difficult to believe it's my link...

Anyway, despite the possible structure problems, probably there's a way to modulate an action timeout by configuration..
0
 
Sjef BosmanGroupware ConsultantCommented:
At that speed, it won't be the link speed or timeouts due to a "slow link". It might be the setup of the VPN, though...

Do a trace yourself, to find out what makes it take so long. See File/Preferences/User Preferences, Ports, select TCPIP, click Trace, select your remote server, select Full trace information, and click on Trace.
0
 
marilyngCommented:
Good suggestion.
0
 
andreomAuthor Commented:
The last suggestion was made and no problem was reported... but the problem operating the Notes database persists...

Is there a way to modulate an action timeout by configuration?
0
 
Sjef BosmanGroupware ConsultantCommented:
It is not necessarily a problem that needs to be reported. Can you dump the results of the trace here, so we can comment it? All steps taken by the Notes client to contact the server are interesting. What you need to know is what the path is that you want the server to take, so you can find out where it strays.
0
 
andreomAuthor Commented:
Determining path to server testdbserv/ITS
Available Ports:  TCPIP
Checking normal priority connection documents only...
Allowing wild card connection documents...
Checking for testdbserv/ITS at last known address 'testdbserv.boulder.ibm.com' on TCPIP...
    Using address '9.17.239.162' for testdbserv/ITS on TCPIP
Connected to server testdbserv/ITS
0
 
Sjef BosmanGroupware ConsultantCommented:
Try it also when the problems started, to see what changed.

What you would normally get with a Connection document is this:

Determining path to server Server/Domain
Available Ports:  TCPIP
Checking normal priority connection documents only...
Local network connection document found for Server/Domain
  Verifying address '192.168.0.2' for Server/Domain on TCPIP
  Connected to server Server/Domain

When I remove the Connection document (or disable it for the current location), I get this:

Determining path to server Server/Domain
Available Ports:  TCPIP
Checking normal priority connection documents only...
Allowing wild card connection documents...
Checking for Server/Domain at last known address '192.168.0.2' on TCPIP...
Connected to server Server/Domain

The address is either somewhere in the cache, or in the workspace or bookmarks somewhere, since there is a database on the workspace that is to be found on Server/Domain. Notes will copy the last used address. Even when you throw away cache.dsk, the address will be found. When you remove the last reference to a database on Server/Domain, Notes should forget the address. I tried to rename those databases and to start Notes, even then Notes knows somehow the IP-address of Server/Domain.

Anyway, there's an old address known somewhere. I think that, when the configuration gets updated, Notes verifies an address and discovers something has changed. Could you find out the differences and post a new trace?
0
 
andreomAuthor Commented:
How can I set a Connection document?
Is it going to change the problem that is "transaction (not connection) timeout on the wan)?
0
 
marilyngCommented:
Just a wild thought.. I would guess from your first trace that maybe the VPN configuration on the server needs to be checked.  When you connect through the VPN then the VPN has to resolve the internal IP addresses and servers.  I'm betting there is an ip address but no server alias name.   Whatcha think?
0
 
andreomAuthor Commented:
No, in fact the database is mapped to a named server not an IP (if I understand the question). And if there's an ip more straightforward the connection would be, as there would no need for name resolution. But, as the trace log shows, I´m connecting to the server all right, the question may be a delay on the server response (maybe due to design). Not all aperations return the error "the network operation couldn´t complete in a reasonable amount of time" (of something like that), all Lan users can do all operations and most of the Wan users also.

Is there a way to modulate an action (transaction) timeout by configuration? A transaction (I don´t know of how much does the concept apply no Notes) can be a collection of operations (all of them executed successfully or the transaction would fail).

Is there a way to mantain the server connected, not on a connection per demand regime?

0
 
SysExpertCommented:
Not to th best of my knowlesge.

Notes is not transaction based, except for transaction logs.

The fact that it works most of the time except for some slow VPN connections means that it is timing out somewhere.

I would look at any functions that take too much time, or require client server communication.

I hope this helps !
0
 
andreomAuthor Commented:
"I would look at any functions that take too much time, or require client server communication. " => does Notes have the ability to work in a real Client-Server fashion? As far as I know Notes database is processed in a File-Server architecture, generating high I/O and taking long to process where the band is not > 100kbps... Is it right?
0
 
andreomAuthor Commented:
The link of the quoted article is not working
0
 
marilyngCommented:
Works for me.. hmmm. try pasting it into notepad and make sure it's one line.

Try this: http://www-10.lotus.com/ldd/nd6forum.nsf

then search on: Show stopper for R5 to R6 upgrades - Intermittent connection
0
 
Sjef BosmanGroupware ConsultantCommented:
> Notes database is processed in a File-Server architecture...
What is a File-Server architecture, and where is that different from a Client/Server architecture?

Install Ethereal (http://www.ethereal.com/) on the PC, and try to analyse the traffic.
0
 
andreomAuthor Commented:
File-Server: The server just shares files, does not process any of the database commands.
Client-Server: The server actually receives the database commands, process them locally and returns the results.

0
 
Sjef BosmanGroupware ConsultantCommented:
With your definitions, Notes is definitely Client-Server. Notes-to-Domino communication is entirely based on Remote Procedure Calls (Notes RPC or NRPC). The data for the form that is put on the local Notes client screen is fetched from the Domino server. Sometimes, data for one particular field is "hard to get", e.g. a view needs to be refreshed in a very large database on a slow server. When you try again some minutes later, it might work for the view might have been refreshed by then.

Still, the VPN worries me. Is it possible that your administrator drills a temporary hole (port 1352 by default) in the firewall, so you can test through the Internet and without the VPN?? Notes communication is very secure.
0
 
andreomAuthor Commented:
It can´t be done for security reasons (company policy)
0
 
Sjef BosmanGroupware ConsultantCommented:
Company policies... please read my EE-profile.

Not even for 10 minutes?? Notes is VERY VERY VERY secure, opening port 1352 is very safe.
0
 
andreomAuthor Commented:
I believe you, but that´s "untouchable" ;)
0
 
Sjef BosmanGroupware ConsultantCommented:
So you are more or less stuck now? I like partitioning the problem, so section by section can be ruled out. In this case, as it seems, communication over the internal network is okay but communication via VPN won't work. That's as deep as you can get, for you need assistance to create new sections of the problem. Apparently they are "reluctant" to give it... Only one way: escalate the problem in your organization, starting with your boss.

My conclusion: your network (VPN or firewall or anything else in between your system and the server) isn't properly configured.
0
 
andreomAuthor Commented:
I´ll scan the open ports... if the 1352 port is opened then we can exclude the possibility of vpn problem?
0
 
Sjef BosmanGroupware ConsultantCommented:
If session logging is enabled on the server, you should see the start of your session in the log.nsf ddatabase, under Miscellaneous. AFAIK, port 1352 is opened for any network connection to a server, whether VPN or not. It has to be open for Notes to work.

Do you use VPN for other things? Everything works as intended?
0
 
andreomAuthor Commented:
"Do you use VPN for other things? Everything works as intended?" => Yes
0
 
Sjef BosmanGroupware ConsultantCommented:
As I see it, the problem isn't solved. PAQ/Refund??

Unless, andreom, you made any progress...
0
 
andreomAuthor Commented:
Thanks for the effort, I solved the problem with a VPN setting (Double IP Connection) which worked who knows why.
0
 
andreomAuthor Commented:
I split then points between the 3 that helped me in this issue, thanks
0
 
marilyngCommented:
andreom, all you would have had to do was say the problem wasn't resolved, would you rather it be unresolved and refunded?   We can make the request, rather than have the  question judged as a "C"

:)
0
 
Sjef BosmanGroupware ConsultantCommented:
So I was right after all!

sjef_bosman wrote in http:Q_21874538.html#16840865 "Transaction Timeout":
> At that speed, it won't be the link speed or timeouts due to a "slow
> link". It might be the setup of the VPN, though...

sjef_bosman wrote in http:Q_21874538.html#16862886 "Transaction Timeout":
> Still, the VPN worries me.

A B seems more appropriate, thank you.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 15
  • 11
  • 7
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now