• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1209
  • Last Modified:

%Homepath% is not set per user profile

Hi,
Windows Server 2003 DC
Windows XP SP2 client

Using the "Profile" tab in the "Properties" window for a specific user, the user's Home Folder is set to a local path on the server (D:\Users\username).

A policy was then created to redirect the My Documents folder of all users to their home directory.

When tested by logging in at the client, the My Documents folder was not being redirected. So I checked the state of %HomePath% at that session, and it was still set to the local default setting despite the profile setting. Am I missing something?

Thanks,
Bill
0
westone
Asked:
westone
  • 4
  • 3
  • 2
1 Solution
 
NJComputerNetworksCommented:
"Using the "Profile" tab in the "Properties" window for a specific user, the user's Home Folder is set to a local path on the server (D:\Users\username). "

Create a share on the USERS folder


Then set the path as :  \\servername\users\%username%

0
 
westoneAuthor Commented:
I've already been doing that. My goal is, in using the Local Path option for the Home Folder setting, to avoid using shares on the users home directories.
0
 
westoneAuthor Commented:
I meant to say using a share on the USERS folder.
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
NJComputerNetworksCommented:
Ok...  I'm a little confused...(sorry)...


When using this technique:

\\servername\users\%username%

There is only one share for all of your users...  So the share is called USERS...  But this will give each individual user, thier own folder under the users directory:

e:\users\john
e:\users\Bill
e:\users\joe
e:\users\...

So, there is only one share...  


To use the LOCAL PATH in the profile, (which I am not too familiar with), means that the patch will be set to the client's local machine (not server based).

c:\users\%username%

So, on the users personal computer, there would be a c:\users\bill directory.  (hosever, you must manually create the C:\users\bill directory on bills personal computer before setting this in AD)



0
 
TheCleanerCommented:
If My docs isn't being redirected, check the local system event logs and see if there are errors regarding the GPO being applied correctly.

Do a GPRESULT /V on the workstation and see if the policy is getting applied ok.
0
 
westoneAuthor Commented:
Okay, Thanks for the responses.

Perhaps I have misunderstood the Local Path option when setting the Home Folder. When setting this option under user properties in AD Users and Computers at the server, this option requires the use of a valid local path on the SERVER, not the workstation client. A valid local path must be entered or an error message will result.

There was an error in the event log on the client resulting from attempting to carry out the My Docs redirection policy. It works correctly when I use the "Connect To:" option w/ a UNC address.
0
 
TheCleanerCommented:
that's correct, it will need a UNC path like \\serverA\users\%username% as opposed to the D: local path you gave it.

Basically you are telling My docs to redirect to d:\blahblah, and that path doesn't exist locally.
0
 
westoneAuthor Commented:
That makes sense, but what doesn't make sense is that the Local Path option will only accept a valid local path for the server, otherwise the option cannot be set.
0
 
TheCleanerCommented:
The path in the "profile" tab isn't the %homepath% variable.

Best quick link I can give you:  http://www.jsifaq.com/subF/tip2900/rh2965.htm

The profile tab sets the %homedrive% and %homeshare% paths.
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 4
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now