Event ID 1103 and 1106

Posted on 2006-06-05
Last Modified: 2012-05-05
I know that some threads have addressed this issue, but I have not seen any resolution on Presentation 4.0.  I have searched the internet and found one thread stating that this is a known issue with Citrix MF Presentation 4.0.  I have one Server in my farm at this point and about to add two more once I get this resolved.  Several of my users that are connecting via ICA client 9.1 are logging event id's 1103 and 1106 in the Citrix Application log.  I have added DisableError DWORD value of "1" in HKLM\Software\Citrix\IMAPrinter and it still logs these events.  The users are mapping their printers in their sessions successfully.  This is the policy that I have in Citirix Presentation Console, Under Printer Management:

Client Printing:
I have Auto Creation Enabled and set to "Auto Create the clients default printer only"
Printer Properties retention is set to "Disabled"

Unverisal Driver is set "Only if requested driver is unavailable"

As I said the users are mapping their printers in their sessions.  I have imported the printers from my Network Print Server and when the driver is not available on the server the mapping is created with UPD.  Users are not experiencing any printing problems they can all print fine.  At this time I do not want to add the other two servers to the new farm until I resolve this problem.  Any help would be great!
Question by:scopeortho

    Author Comment

    I have been able to reduce the Event ID 1106 on the server dramatically, what I am seeing quite a bit is Event ID 1103:

    Event Type:      Warning
    Event Source:      MetaFrameEvents
    Event Category:      Printer Management
    Event ID:      1103
    Date:            6/5/2006
    Time:            3:22:17 PM
    User:            N/A
    Computer:      CITRIXPRESN1
    An error occurred while retrieving client printer properties. Default printer properties will be used instead. Client name: (#) Printer: (# on # (from #) in session 39) Printer driver: (hp LaserJet 1320 PCL 6)

    This is just one instance, anytime a user connects this will get logged on the server.  I am a bit confused since I did disable Printer Properties on the Farm with the policy, why would I be getting this warning.  I also see this driver in the Presentation Console.  I know that if the session was to create a printer with UPD it would aqcuire the printer properties, but since the driver is in the Presentation Console and I have a policy set to only install UPD if driver is unavailable.  I am not sure why it would be getting this error.
    LVL 5

    Expert Comment

    According to Microsoft this is a harmless error:

    To getrid of the error you need to install the correct printer driver in the Terminal server. In the above case the error is for hp LaserJet 1320 PCL 6. Get the exactly same driver as the client PC have and install on the Terminal Server. It will hopefully resolve the problem. If it doesn't then you also need to map the printer drivers correctly in Citrix Metaframe.
    See the below link for printer mapping and trouble shooting:

    Good Luck!

    Author Comment

    Thanks for the reply, when I look at the Driver inside the Presentation Console doesn't that tell me what driver is installed on the server?  If so, then the drivers are the same.  As far as what I know mapping was not needed in Presentation 4 only on XP and lower.  
    LVL 13

    Expert Comment

    Even with the matched correct driver, you can still see the error if the driver is attempting some query operations against the printer that aren't getting through the TS layers. You might have better luck forcing this printer to use the UPD.

    Author Comment

    I received even more event ids 1106 with force to use UPD.  I have cut down on the 1106 with just having the user mapped their primary printer and now I am just logging the 1103 warnings.  If there is a way to disable that please advise but as for now no problems with autocreation or printing.  So I will leave the farm as is.  

    Expert Comment

    Has there been any resolution to this issue? I am having very similar problems. I upgraded to PS 4.0 this week and since them , users are calling and saying they are not able to print from their session. We use locally configured printers (IP Printers) and we also allow client printers. The problem I am having is that since upgrading to PS 4, they are not able to print. Here is the twist. Not all client printers are having the problem. So i to am getting the 1103 and 1106 errors. is there a hot fix for this?

    Author Comment

    I am sorry for not posting my results, here is where I am at this time.  I had to change the Citrix Farm Policy in Citrix to autocreate all client printers.  I still have the printer properties disabled in the policy and I have the use of UPD only if requested driver is unavialable.  But, on June 30th citrix released two patches PSE400R01W2K3069 which is the latest update.  The following is stated:

    For certain printer drivers, changes made to printer properties or advanced printer settings within a session do not persist between sessions.
    This is the server-side component of an enhancement that allows you to modify the client-side appsrv.ini file to set the client to always use the printer settings from the actual printer rather than the retained settings in the properties store. This setting also forces the client to attempt to write settings modified within a client session to the client printer if the drivers are determined to be equivalent.To get the full benefit of this enhancement, you must also deploy Hotfix Client 9.200 or later of the Presentation Server Client and add the following line to the [WFClient] section of the client-side appsrv.ini file:
    This fix also adds the capability to inherit, retain, and restore the following settings from a printer's Advanced tab:
    •      Spooled versus print directly to printer
    •      Wait for last page or start immediately
    •      Enable/disable advanced printing features
    •      Give preference to complete jobs
    [From PSE400R01W2K3033][#127407]

    I did not have PSE400R01W2K3033 installed on my servers, so I installed PSE400R01W2K3069 and the event id's of 1103 and 1106 are no longer appearing in my application logs.

    Hope this helps

    Accepted Solution

    PAQed with points refunded (200)

    Community Support Moderator

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Highfive + Dolby Voice = No More Audio Complaints!

    Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

    #Citrix #XenApp #Citrix XenApp #Citrix Concurrent License #Citrix Licensing #Citrix Policies
    Citrix XenDesktop, gold image, VMware, vSphere.
    How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
    This video discusses moving either the default database or any database to a new volume.

    760 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    11 Experts available now in Live!

    Get 1:1 Help Now