RPC over HTTPS Almost Working!!!

Current situation.

1 Windows 2003 Server SP1, MS Exchange 2003 SP1, this machine has active directory installed and is a global catalog.
I have installed “Rpc over http” and I have installed CA. I have edited the registry options, Valid ports and NSPI interface protocol sequences as instructed. I then shutdown MSExchangeSA as instructed and rebooted my server.
I am using a client that is directly connected to the same subnet. (No firewall!)
IIS – Default website – rpc – has been configured for https/ssl only and basic authentication.
I installed a server certificate on the server and also connected the client to the server and installed a client certificate and tested successfully by using IE to connect to the RPC virtual directory and getting access denied. But then adding rpcproxy.dll and getting a blank page. If I click on the lock it shows the proper certificate and shows status as internet.
My outlook client is configured to use HTTPS only, 128bit encryption and basic authentication. And fast and slow networks using http first are checked.  
If I connect using outlook.exe /rcpdiag… I get the connection status page showing mail as https but directory as tcpip!?!?

I had a test network setup almost identical to my production one above and I had the same problem. It was port 6004 wasn’t listening. I fixed that by editing the registry under NSPI and rebooted and it worked fine… Now I have the same issue with my production network but cannot get it to work. Port 6004 is listening!
Any help would be greatly appreciated.
Thank you.
Who is Participating?
CetusMODConnect With a Mentor Commented:
PAQed with points refunded (500)

Community Support Moderator

Please these two links for reference:


and verify the steps again from these sites.

Directory would tend to indicate that you haven't made the domain controller entry on to that machine. Even though you have gone against good practise and installed Exchange on to DC, you still need to make the domain controller registry change.


Create a new key of type REG_MULTI_SZ

Name: NSPI Interface protocol sequences
Value: ncacn_http:6004

Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

alexL3Author Commented:
Both articles were very helpful but I've followed those intstructions and  I have it working perfectly in my Test network.
But there must be something running on my Production server that is not allowing me to connect completely under https.
Only the "Directory" connection is coming up TCP/IP?
The "Mail" connection comes up HTTPS?
So I believe my settings are correct. I must be off by one little registry edit or one little checkbox!!!  ARGH!!!!
alexL3Author Commented:
Hello Simon, I should of noted in my original question that I did make this change.







NSPI interface protocol sequences - ncacn_http:6004

The registry settings can be wrong by the smallest thing - a semi-colon in the wrong place, the wrong name or the name resolution not working.

alexL3Author Commented:
I triple checked these registry settings... ;o)
I can't figure it out... I have the exact same setup on a test network and it works.. same client connecting to both.
alexL3Author Commented:
I figured it out... using rpcping... great too!!!!!  Thanks
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.