Apt-get proxy problems

I am using Ubuntu (Dapper Drake) but with the KDE desktop, when I first installed the system I was behind a proxy server and adjusted the settings accordingly. However I am no longer behind a proxy so I removed the settings and now when I try to run apt-get I keep getting an error message stating it cannot connect to the proxy server. Does anyone have an idea why Ubuntu wont release my old proxy settings?
LVL 6
ITHelper80Asked:
Who is Participating?
 
nedvisConnect With a Mentor Commented:
In Dapper Drake Ubuntu you can ( using Gnome DE ) click on System ---> Preferences ---> Network Proxy

If the "Manual Proxy configuration" is checked make sure to remove former proxy's IP address ( clear boxes)
and the check "Direct Internet connection" box.
Save settings .
Restart network deamon.

nedvis
0
 
Heem14Commented:
look in /etc/apt/apt.conf

I don't have a machine with apt installed here, so I can't look and specifically give you which directive to edit, but I'll bet you'll find it in there.
0
 
ITHelper80Author Commented:
I checked in the apt.conf but I couldnt find anything in reference to my old proxy settings.
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

 
nedvisCommented:
"I checked in the apt.conf but I couldnt find anything in reference to my old proxy settings."
there's the line in  /etc/apt/apt.conf file that shoul read :
Acquire::http::Proxy "false";

in order for apt-get to skip checking for proxy when trying to connect to repositories sources.

nedvis

0
 
MattyK_NHCommented:
You might also check your environment variables. If you are using bash then type 'export' at the shell prompt. apt-get will use http_proxy= and ftp_proxy= variables over any of your /etc/apt/ settings. It will probably be set in your ~/.bashrc if you find it. To temporarily remove them, you can type 'export -n http_proxy ftp_proxy'. For more information you can find a complete manual by typing 'man apt.conf'.
0
 
ITHelper80Author Commented:
Ok I got it to work, when I originally installed Ubuntu it of course came with gnome so I configured it to work with the proxy so I could download Kubuntu-desktop, once I had that install I configured the proxy for KDE, when I got home I only removed the proxy settings for KDE I didn’t realize I had to also remove the proxy settings in gnome. Once I did that everything worked fine. Thanks for all the suggestions!
0
 
nedvisCommented:
What you acctually did is you've configurred your network ( and proxy settings ) SYSTEMWIDE. True , there are some more detailed network settings you can tweak in  Konqueror and/or  KDE Control Center's network module  but cganhes are immediately applied -systemwide.

Glad to hear you managed to get back to network.

nedvis
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.