• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 180
  • Last Modified:

Search doesn't work in Windows Explorer

Hi,

Running a server with W2K/SP4. All the users, except the Administrator account, are unable to search using either Windows Explorer or right clicking on the Start button, e.g. On right clicking on the C drive in Windows Explorer, the menu appears but when you click on Search, nothing happens. There are no messages, no entries in the event logs and seemingly no problems caused to Windows.

Any ideas anyone?

Thanks,

Grape
0
Grape65
Asked:
Grape65
1 Solution
 
dovcampCommented:
Perhaps the search option is disbled in group policy.  Try the following (except in step for you will want to disable instead of enable the option)

You can disable Search Assistant by removing the search option from both the Start menu and the toolbar in Windows Explorer through the use of Group Policy settings.

To Remove the Search Menu from the Start Menu

1. On a server running Windows 2000, follow the instructions in Help for opening Group Policy in the appropriate way, depending on whether you want to apply the Group Policy object (GPO) to an organizational unit, a domain, or a site.

2.  In Group Policy, click User Configuration, click Administrative Templates, and then click Start Menu & Taskbar.
 
3. In the details pane, double-click Remove Search menu from Start menu.
 
4. Select Enabled.
 
0
 
Grape65Author Commented:
dovcamp,

Thanks for the reply. I've looked in the group policies and the above settings were not configured. The users that it's affecting have the option appear when they either right click on explorer or use search from the start button. When they then click select search, literally nothing happens, no hour glass, no message, nothing. The session isn't affected in anyway, they can then carry on and do anything else they are allowed to do except search.

Regards,

Grape
0
 
Grape65Author Commented:
I'd like to close the question now, please, as I've found the answer.


The problem was caused by explicit permissions being assigned in the security tab in dcomcnfg. The only allowed user was the admin account. When this was removed, the everyone and system groups were given implicit permissions and search was again available to the users.


http://support.microsoft.com/kb/274696/en-us

0
 
WMIFCommented:
please read here on how to close questions:
http://www.experts-exchange.com/help.jsp#hs5
0
 
GhostModCommented:
Closed, 500 points refunded.

GhostMod
Community Support Moderator
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now