Corrupted Fonts/Display in Windows Server 2003

Hello,

Several months back I installed the MS Clear Font Tuner powertoy. I went through the process of checking the display but when it was complete the system returned a bunch of garbled characters.  At least I think this is what caused the problem. When I click on the Start button, at the top, where it shows the name of the account logged on, there is nothing but garbage. The same is true for certain settings windows such as the Firewall window from the Control Panel.  It does not seem to affect system performance but it is very annoying. I removed the Clear Type tuner and tried to go to the display settings to correct the problem, to no avail.  I've tried everything I know but I can't seem to clear up the garbage.  It dosen't really affect system performance but it is very annoying.  Don't want to have to reinstall Windows, specially since this is my Domain Controller.

Any ideas on how to resolve this issue will be appreciated.

Thanks,

Armando
ajcanalAsked:
Who is Participating?
 
ajcanalConnect With a Mentor Author Commented:
Solved problem myself. Posting solution.

"Well, well, I'll be. While composing this response to you I went in to the Appearace Tab of the Dispay Properties to look at what fonts were available so I could tell you. Initially only System, FixedWidth and Tahoma were available.  I then went to my WinXP system to see what listed there.  All available fonts were listed.  I went back to the server and went to the Fonts section of the Control Panel.  It simply opened a Windows Explorer screen that showed no fonts.  I closed that window and navigated to the Fonts folder again.  Now all of the sudden they are there.  Went back to the Advanced tab in Display Properties and now all fonts show available.  I changed the Menu font from Tahoma to Arial.  Surprise! Problem Solved!!! I can't believe it.... after six months of dealing with this.  Who would've known."
0
 
Netman66Commented:
Have you tried SFC /scannow?

You'll need your CD handy.

This should fix any corrupted files that are base to the system.  If it fixes something, then please recheck your patches at Windows Update.

0
 
ajcanalAuthor Commented:
Netman66

Thanks, gave that a try and it did not work.
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
Netman66Commented:
Bummer....

Not sure where to go from here.  Did you return to the software vendor's page to see if that piece of software was compatible with 2003 and if there are any issues similar to yours there?

0
 
ajcanalAuthor Commented:
Unfortunately it’s Microsoft’s own Powertoys which they don’t support.  One thing I haven’t tried is to change my video card.  I’ve got an extra one so I’ll give that a shot.  You never know….
0
 
Netman66Commented:
It's a longshot...I doubt it though.

Does RDP work to the server properly?

0
 
ajcanalAuthor Commented:
Yes, RDP to the server works fine.
0
 
Netman66Commented:
How about if you create a shortcut to MSTSC on your desktop.
Once created, right-click it and select Properties.
In the path to the exe, add this switch at the end of the line :  -console
Make sure you leave a space between mstsc.exe and - console.

Let me know if the Fonts are still messed up when you connect that way.

0
 
ajcanalAuthor Commented:
Netman66,

Thanks for your help.  Sorry to be such a newbie but I don't understand your last reply. I am having the problem directly on the computer, not through RDP or any other access means. Thanks again.
0
 
Netman66Commented:
That's ok.

Create a shortcut to MSTSC.EXE on your desktop.  It's in C:\Windows\System32

Once it's created, right-click it and select properties.
In the Target line, add a space and -console to the end of the line.  It will read like this:

C:\Windows\System32\mstsc.exe -console

Now, click ok.

Run the RDP session to the server using this shortcut - it will connect directly to the console session and this will let me know if you see the same bad fonts.

0
 
ajcanalAuthor Commented:
Thanks Netman66... I tried what you suggested and even through the RDP I get the same garbled characters. They occur on the top of the Start menu where is should say Administrator and in some, but not all, properties windows. For example, in the Add Hardware wizard the only legible text is where it says, "This Wizard Will hepl You..."  the rest of the text is garbage and illegible.

I installed and ran Spyware Doctor, nothing found. I removed AdAware which also had garbage, no effect. Installed and ran Registry Mechanic.  It cleaned a bunch of stuff in the Registry but that did not solve the issue. I've also tried changing the Themes and all the Advanced settings in the Appearance tab, every item, one by one, changing from System to .............  Oops, wait..

Well, well, I'll be. While composing this response to you I went in to the Appearace Tab of the Dispay Properties to look at what fonts were available so I could tell you. Initially only System, FixedWidth and Tahoma were available.  I then went to my WinXP system to see what listed there.  All available fonts were listed.  I went back to the server and went to the Fonts section of the Control Panel.  It simply opened a Windows Explorer screen that showed no fonts.  I closed that window and navigated to the Fonts folder again.  Now all of the sudden they are there.  Went back to the Advanced tab in Display Properties and now all fonts show available.  I changed the Menu font from Tahoma to Arial.  Surprise! Problem Solved!!! I can't believe it.... after six months of dealing with this.  Who would've known.

Anyway, thanks again for all your help
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.