?
Solved

VPN error on XP Pro - TCP/IP CP reported error 2 - The system cannot find the file specified.

Posted on 2006-06-06
7
Medium Priority
?
6,819 Views
Last Modified: 2013-11-29
The error reported is on a Dell Dimension 4600 with XP Pro (With all the latest updates) when attempting to connect a vpn connection (through a NIC)
I can connect this VPN connection from other computers, but not this one.
I cannot connect this computer to any other VPN connections - Same error
After rebooting, when connecting to a vpn,  the first error message is "TCP/IP CP reported error 31 - A device attached to the system is not functioning."
Then any other attempts will bring back the merror message "TCP/IP CP reported error 2 - The system cannot find the file specified."

I tried with another NIC, same error
I removed the Integrated NIC from Device manager, reinstalled it; same error
I removed the entries in the registry under; KKLM/... network cards: Same error

From what I read on the Web, people have reinstalled XP without resolving the issue?

Any suggestion?
\
0
Comment
Question by:monahansolo
6 Comments
 

Author Comment

by:monahansolo
ID: 16845466
Found the solution!

From: http://www.tek-tips.com/viewthread.cfm?qid=1199801&page=3

A registry tweak seems to have resolved the issue:

From:
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Dhcp\Parameters
there are one or more REG_BINARY values witha long (GUID?) name in brackets { }

Copy all of the bracket names (one by one) into clipboard.
e.g. {A2F5650E-D377-4A0A-9C90-784ED1EA5A92}

Make a new Key under
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\NetBT\Parameters\Interfaces\

With that name and 'Tcpip_' in front of it:
e.g. "Tcpip_{A2F5650E-D377-4A0A-9C90-784ED1EA5A92}"

I copied  and pasted all the values, tried the VPN connection and voila!

Once rebooted, when I tried again, the first attempt failed with the error 31, but was successful on the second attempt.

I am able to connect and disconnect ,many times successfully, but when I reboot, the firat attempt to connect still fail, before being successful afterwards.

There is another step that I didn't do (Perhaps a MULTI_SZ (Multi-String_Value) with the name
"NameServerList" is needed under that new key too.), which I'll try right now to see if it resolve the issue.

0
 
LVL 3

Expert Comment

by:ykamp
ID: 16846355
I always believed on your abilities!!!!!!!!!!!!!!!! :)
0
 

Author Comment

by:monahansolo
ID: 16846678
Greetings again,

I am not able to resolve the error message at the first connection, so i simply put the redial time at the minimum ( 1 second).

So, I think this is the best I'll get without having to do a fresh start on XP...

This question is considered resolved.
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 

Author Comment

by:monahansolo
ID: 16846744
This question is considered resolved by myself and will be asked for deletion.

Claude
0
 

Accepted Solution

by:
ee_ai_construct earned 0 total points
ID: 16878088
Closed, 125 points refunded.
ee_ai_construct
Community Support Moderator
replacement part #xm34
0
 
LVL 2

Expert Comment

by:amaraa12
ID: 21122987
This is works of me. Thank you monahansolo. But i think when you have a problem first you are checking it from internet then create question on here then answer your question aanhh method man... Just joking thank your for your resolution.
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you’re involved with your company’s wide area network (WAN), you’ve probably heard about SD-WANs. They’re the “boy wonder” of networking, ostensibly allowing companies to replace expensive MPLS lines with low-cost Internet access. But, are they …
This program is used to assist in finding and resolving common problems with wireless connections.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Suggested Courses

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question