Changed NLS_LANGUAGE and now getting ORA-12514, 10g XE Edition

Hello all, recently I Installed Oracle 10g XE on my Windows XP PC.

I tried ran this command (Charachter set was not OK):
ALTER SYSTEM SET NLS_LANGUAGE = 'AMERICAN_AMERICA.IW8PC1507' SCOPE=SPFILE;
and since then I cant connect to my DB, all i'm getting is:
ORA-12514: TNS:listener does not currently know of service requested in connectdescriptor
I tried to do everything the Oracle 10g libraries says, but they all reffer to the Net Services Administrator's Guide and more stuff that are not supported in the XE.
I cant even see the connect page of the Oracle XE Management!!
please try to help me if you can.

Tomer.
LVL 1
tomerbarAsked:
Who is Participating?
 
schwertnerCommented:
No! I fixed some typos!
Follow the instructions.
The idea is to start the instance with parameter file instead with the incorect SPFILE.
After that you will be instructed to replace the incorrect SPFILE.

Go to $ORACLE_BASE\admin\pfile directory.
Will find there a parameter file (not SPFILE!!!!!).
Rename it to init.ora.
Try to connect the instance. Stop the Oracle service and restart it.
SQL>connect sys/manager@your_entry as sysdba
or
SQL>connect / as sysdba

if you connect:
SQL>shutdown immediate

SQL>startup pfile=....\admin\pfile\init.ora

After that wait for further instructions.
0
 
paquicubaCommented:
Did you shut down your database?
Is the service running?
0
 
tomerbarAuthor Commented:
Yes I shut it down many times,
and the whole computer, Doesnt work.
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
schwertnerCommented:
Go to $ORACLE_BASE\admin\spfile directory.
Will find there a parameter file.
Rename it to init.ora.
Try to connect the instance. Stop the Oracle service and restart it.
SQL>connect sys/manager@your_entry as sysdba
or
SQL>connect / as sysdba

if you connect:
SQL>shutdown immediate

SQL>startup pfile=....\admin\pfile\init.ora

After that wait for further instructions.
0
 
tomerbarAuthor Commented:
well i didnt really understand,
do you want me to change the file spfilexe.ora to init.ora??
well i tried and it didnt work,

or did I understand you wrong.
0
 
Pradeepgv03Commented:
Hi,
Problem looks related to Listner/Services.
Can you please upload the result of

lsnrctl > status

Also your TNSNAMES.ORA Entry

-Pradeep
0
 
Tareq_AsebieCommented:
conn sys as sysdba / password
then
select tname from tab where tname like 'V_$NL%';

u will get

---------------------
V_$NLS_PARAMETERS

then write this statment :
update props$ set value$ = '  here write your character set u want    ' where name = 'NLS_CHARACTERSET' ;
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.