[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

IP Helper Address not working! PLS HELP!

Posted on 2006-06-06
21
Medium Priority
?
1,276 Views
Last Modified: 2008-01-09
2 vlans setup with IP-helpers but my second vlan will not get an IP from the dhcp server located on vlan 1.

this is what i have,

!
interface Vlan1
 ip address 192.168.100.201 255.255.255.0
ip helper-address 192.168.100.5
no ip route-cache

!
interface Vlan2
 ip address 192.168.200.201 255.255.255.0
 ip helper-address 192.168.100.5
no ip route-cache


no dhcp server set, i have tried that as well without luck... I have a second NIC on another server the i setup dhcp on, and i plugged that right into the 192.168.200.x range and i am able to get an ip.  so it must be the helper in some way?

Please help!
Thanks in advance!
0
Comment
Question by:lgropper
  • 12
  • 9
21 Comments
 
LVL 50

Expert Comment

by:Don Johnston
ID: 16848404
First off (not that it's causing a problem), you don't need the helper address on the VLAN1 interface.

Do you have scope setup for the 192.168.200.0/24 network?

Does the DHCP server have it's default gateway set to 192.168.100.201?

Just for testing, if you assign an ip address to a device on VLAN2, can you ping the DHCP server?
0
 

Author Comment

by:lgropper
ID: 16848435
I was just playing around, didn't think i needed it but thought i would try!

scope is setup for that network.

the default gateway of the dhcp server is 192.168.100.71 which is one of our firewalls.  the firewall  has a static route for anything for 192.168.200.0/24 gets routed to 192.168.100.201

If i assign a static ip i am unable to ping andthing on the 192.168.100.x range with the settings of 192.168.200.10/24 gateway 192.168.200.201

chad
0
 

Author Comment

by:lgropper
ID: 16848440
here is a copy of the config

version 12.2
service config
no service pad
service timestamps debug uptime
service timestamps log datetime
no service password-encryption
service sequence-numbers
!
hostname CMT3560_Server_Room
!
enable secret 5 $1$D3rC$mYqVJa9nbjoOi3hKvU58r.
!
ip subnet-zero
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface GigabitEthernet0/5
!
interface GigabitEthernet0/6
!
interface GigabitEthernet0/7
!
interface GigabitEthernet0/8
!
interface GigabitEthernet0/9
!
interface GigabitEthernet0/10
!
interface GigabitEthernet0/11
!
interface GigabitEthernet0/12
!
interface GigabitEthernet0/13
!
interface GigabitEthernet0/14
!
interface GigabitEthernet0/15
!
interface GigabitEthernet0/16
!
interface GigabitEthernet0/17
!
interface GigabitEthernet0/18
!
interface GigabitEthernet0/19
!
interface GigabitEthernet0/20
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface GigabitEthernet0/27
!
interface GigabitEthernet0/28
!
interface GigabitEthernet0/29
!
interface GigabitEthernet0/30
!
interface GigabitEthernet0/31
!
interface GigabitEthernet0/32
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet0/33
!
interface GigabitEthernet0/34
!
interface GigabitEthernet0/35
!
interface GigabitEthernet0/36
 no switchport
 no ip address
 no ip route-cache
!
interface GigabitEthernet0/37
!
interface GigabitEthernet0/38
!
interface GigabitEthernet0/39
!
interface GigabitEthernet0/40
!
interface GigabitEthernet0/41
 no switchport
 no ip address
 no ip route-cache
!
interface GigabitEthernet0/42
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet0/43
!
interface GigabitEthernet0/44
!
interface GigabitEthernet0/45
!
interface GigabitEthernet0/46
!
interface GigabitEthernet0/47
!
interface GigabitEthernet0/48
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet0/49
!
interface GigabitEthernet0/50
!
interface GigabitEthernet0/51
!
interface GigabitEthernet0/52
!
interface Vlan1
 ip address 192.168.100.201 255.255.255.0
 ip helper-address 192.168.100.5
 no ip route-cache
!
interface Vlan2
 ip address 192.168.200.201 255.255.255.0
 ip helper-address 192.168.100.5
 no ip route-cache
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.100.71
ip http server
!
snmp-server community public RO
snmp-server enable traps tty
!
control-plane
!
!
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 50

Expert Comment

by:Don Johnston
ID: 16848455
>If i assign a static ip i am unable to ping andthing on the 192.168.100.x range with the settings of 192.168.200.10/24 gateway 192.168.200.201

Then you don't have a DHCP problem. You've got a routing problem.

With the statically assigned IP address, can you ping 192.168.200.201?

What port is this PC connected to?
0
 

Author Comment

by:lgropper
ID: 16848470
lol... makes sense..

I am unable to ping 192.168.200.201.  the pc is connected to port 48 at the moment.
0
 

Author Comment

by:lgropper
ID: 16848493
scratch that. i am able to ping 192.168.200.201 but nothing else.

chad
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 16848494
Can the PC ping 192.168.200.201?
0
 

Author Comment

by:lgropper
ID: 16848495
yep it can ping that but nothing else
0
 

Author Comment

by:lgropper
ID: 16848502
i just put another pc on vlan 2 and i am able to ping it as well.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 16848504
The only thing I can think of at the moment is that IP routing is disabled. From global config, try issuing an "ip routing" and see if that helps.
0
 

Author Comment

by:lgropper
ID: 16848525
it seems it was off.  i issued that command and it took.

Also i have looked through the cisco network assistant software and noticed the the ip default route was off.  i set that to our firewall 192.168.100.71 and still no luck.

i have verified the static route in the firewall to be correct.

chad
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 16848543
"Also i have looked through the cisco network assistant software and noticed the the ip default route was off.  i set that to our firewall 192.168.100.71 and still no luck."

That's only going to be a factor when you try to get past the 192.168.100.0 network. First things first, is there any change in the symptom? Can the 200.10 device ping the 100.201 address now?
0
 

Author Comment

by:lgropper
ID: 16848555
i didn't try that before but yes, i can ping 192.168.100.201 from 192.168.200.198
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 16848576
How about pinging 192.168.100.5 from 192.168.200.198?
0
 

Author Comment

by:lgropper
ID: 16848580
i cannot ping that nor anything on the 192.168.100.x range
0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 2000 total points
ID: 16848615
It sounds like the firewall is not forwarding traffic to the 192.168.200.0 network. To confirm this, you could change the default gateway on one of the devices on the 192.168.100.0 network to 192.168.100.201 and see if that fixes it.
0
 

Author Comment

by:lgropper
ID: 16848627
i changed it and hen i try and ping 192.168.200.198 from 192.168.100.2 with a gateway of 192.168.100.201 i get a hardware error.

could it be the cisco?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 16848664
"hardware error"??? What gives you a hardware error? The 100.2 device? If so, then you've got issues with THAT device.

I suggest taking a couple PC's. Assign them unused IP addresses for each network with default gateways of 100.201 and 200.201 (respectively) and try to get them talking to each other.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 16848684
I gotta run for now. I'll back in around 10 hours...
0
 

Author Comment

by:lgropper
ID: 16849094
ya i changed the gateway as requested and then tried to ping 192.168.200.198 from that pc and it gave a hardware error from the ping command instead of a reply or time out.

i'll try some more tomorrow and keep you posted.

Thanks,
0
 

Author Comment

by:lgropper
ID: 16852929
wow, figured out the problem! you were very right it was a routing issue. the subnet 192.168.200.0 was added as a remote network vpn.

thanks for all your help!!!
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

New Server 172.16.200.2  was moved from behind Router R2 f0/1 to behind router R1 int f/01 and has now address 172.16.100.2. But we want users still to be able to connected to it by old IP. How to do it ? We can used destination NAT (DNAT).  In DNAT…
Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question