• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 718
  • Last Modified:

Exchange Server SMTP ISSUES

OK here is the situation:

Small office has SBS 2003 but does not have a fully qualified domain, therefore the local domain is company.local and e-mail is handled by telus.  so each user has a telus box.  right now each computers ms outlook 03 checks both the local box and the telus account.  I realize that this could be done with POP3 Connector, but the users want to leave the mail on the server after checking and  I couldn't figure out how to have the POP3 connector leave the mail there after routing it.  And, more importantly  in order for the outgoing mail to go out using the SMTP connector I had to set the users mail boxes, on the server, under users, as their telus box address othereise the SMTP connector wouldn't send through the smtp.telus.net bercause it thought it was comming from an outside address.  After doing this it seems everything works sending internal mail is sent to the users telus box and the exchagne server just routes it locally and external mail is routed externally - except sending to any other @telus address other than the 10 local ones because the exchange server wants to look locally for the address and it isn't there. It even routes there @ telus accounts localy but since the server thinks that the @ telus account are local it delivers the internal e-mail ok.   Now I know that I have done something way off so if someone could even recommend a way to set this up correctly please do.   But if there is a way to just have the server send the telus e-mail that doesn't match an internal box, to the external smtp  then it would work this way.  
0
eke-the-electron
Asked:
eke-the-electron
  • 8
  • 7
  • 2
1 Solution
 
eke-the-electronAuthor Commented:
Maybe Simpler this way

Only @Telus.net External mail not routed externally by the exhange server.
All other mail from other servers routed externally.

Office user accounts on SBS 2003 have the users @telus.net email listed in user
This is so the SMTP connector can send mail out to the smtp.telus.net server.  If i left the users mailbox/reply address as @company.local the smtp thought it was from an outside mailbox.  And external people would see .local reply addresses which wouldn't work.

Users check both internal @company.local and @telus.net accounts
not using pop 3 connector for external boxes.  Couldn't get POP 3 connector to leave messages on the server.

problem: mail that should go to @telus.net people outside the office don't go, they are routed internal and bounced back because the uiser doesn't exist. They should be routed to the external smtp.telus.net.



0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
I think you are making this much more complicated than it should be.  Your problems are starting because "users want to leave the mail on the server after checking".  Why?  You have Outlook Web Access available to them which would combine their email and calendaring in one place so they don't have to use the Telus webmail anymore.  Instead they just connect to your IP address/exchange.

Better yet, why don't you get a FQDN?  It's only about $10.

So... rerun the Configure Email and Internet Connection Wizard (CEICW) and use the POP3 connector for now.  Show everyone how they can access OWA instead of Telus Webmail (actually the instructions for this are linked in http://companyweb 's links under "Information and Answers".

Jeff
TechSoEasy
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Further to this... to switch to Exchange Email, see http://sbsurl.com/pop2smtp

Jeff
TechSoEasy
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
eke-the-electronAuthor Commented:
The Company is so stuborn, they won't have it they need web mail, they say that some of them don't know enough and there not going to change so they need the "simplicity of telus web mail" honestly ... a direct qoute... and they won't bite on the domain name either i pushed before wae started and i asked again today and they just dont want it and furthermore they were totally against having to change there e-mail addresses

And there is another problem, if i use the POP 3 Connector and give everyone back there .local addresses then the SMTP connector isn't going to work because telus smtp.telus.net won't let the messages go through... and the reply addresses would show up as user @company.local even if it would go through.

its so close the onjly problem with the current setup is that @telus addressses get routed internally instead of externally, if there was just a way to explicityl set the addresses that get routed internally I would have it .
0
 
eke-the-electronAuthor Commented:
obviously this was never ment to work like this...
0
 
eke-the-electronAuthor Commented:
I must sound so stupid but i just dont get the smtp connector problem, If I was using exchange mail and had the domain name and everything, wouldn't i still be using the smtp server at my internet providers, and there fore there must be a way to have the smtp connector work with the smtp.telus.net server no matter what e-mail address its comming from, i thought it checked the ip address and if you had one of theirs you could send, but i tried the only way i could get mail to go through was when i set the users mail boxes as @ telus.net addresses.
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Well, silly them!  Since the users will be using OUTLOOK it would be SIMPLER for them to use Outlook Web Access... but what do I know.

At any rate... you need to configure all of this in the Configure Email and Internet Connection Wizard (CEICW).  Don't manually configure the SMTP connector unless you have a specific need to do so (such as a user that does not have an Exchange mailbox).  In the CEICW you'll be asked for the Email domain name, which is apparently telus.com, and that's what will show up on the replies.

See http://sbsurl.com/ceicw

Jeff
TechSoEasy
0
 
sam_coganCommented:
Exchange will not send email to external @telus.net domain, as it is setup to be resposible for all the email in the domain. To change this, go into systems manager, then recipents, recpient policies and right click and go to properties on the default recipient policy.

under the email tab, find the @telus.net entry and click on edit. untick the box that says "This exchange organisation is responsible for all mail delivery to this address"



Sam Cogan
MCSE, MCSA:Messaging Specialist
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Sam,

I don't think that would be necessary because internal emails do not go via the POP3 connector anyhow.  They just resolve through Exchange and the local AD domain name.

Jeff
TechSoEasy
0
 
eke-the-electronAuthor Commented:
Sam

See thats what I thought too.

I have been trying to get the policy to work and it's doing some weird things.  I tried  taking the checkmark out of the "This exchange organisation is responsible for all mail delivery to this address"
but i had problems with the smtp connector sending the e-mails after i chaged this.
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Delete your SMTP Connectors and rerun the CEICW which will recreate them properly.  That's all you need to do.

Jeff
TechSoEasy
0
 
eke-the-electronAuthor Commented:
I hope you're right.
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
I am.
0
 
sam_coganCommented:
well no they don't go through the pop3 connector, but the do use smtp, and exchange does check the recipient policy when it sends mail, so if you are sending email to external accounts on the same domain, it still trys to deliver them internally.
I have fixed this in the past but only on a small network in a makeshift way. It basicly involved running the ICW, setting their email domain to .local one, then going through each account and adding the main accounts, setting them as default and unticking the use recipient policy box, its not a great solution, and its only really usefull if you have a small number of clients, but it got them working.

sam
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
The thing is with SBS 2003's CEICW, you don't set an email domain if you are only using the POP3 connector.  You just configure the POP3 connector, leave the email domain name box blank per the instructions on the wizard and the CEICW does the rest.  No need to go through and change each account and whatnot.

Please review http://sbsurl.com/ceicw if you want a pictoral overview.

Jeff
TechSoEasy
0
 
eke-the-electronAuthor Commented:
the CEICW puts the .local address in there by default if you leave it blank
0
 
eke-the-electronAuthor Commented:
Many good thoughts ... thanks.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 8
  • 7
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now