Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 276
  • Last Modified:

Redirect mail after migrating Exchange 2000 to Exchange 2003?

Hi.

I have red the article http://www.msexchange.org/tutorials/Migrating-Exchange2000-Exchange-2003-Hardware.html but have a few questions.

First one, right now I have two mailservers running, the old one with Exchange 2000 and the new one with Exchange 2003. It seems that the new mailserver use the old one for send & receive by default after the installation, is that correct?

The second question is about how to find the server. It says in the article that i should config my firewall to point on my new server, is this the only thing I have to do so the mail now where to go? I have logged in to the firewall but I can not find any settings for pointing to the mailserver (Netscreen 5).

0
Handersson75
Asked:
Handersson75
  • 8
  • 7
  • 3
2 Solutions
 
aa230002Commented:
Is your old Exchange 2000 and new Exchange 2003 in the same administrative group and same Routing group?
first you need to check the properties of your SMTP connector which is sending mails to the internet and see which server is responsible there as a bridgehead server to send mails to the internet. You need to change it to the new server.
Now, check your MX records on the internet and see which Exchange box is receiving emails from the internet? it should be your old Exchange 2000, you need to update them to the new Exchange 2003 server so that from now onwards, all external (internet) domains contact to your new Exchange 2003 server to deliver mails to your domain. and you will have to configure your Firewall to allow these external Exchange servers to contact your new Exchange 2003 server so that they can establish a SMTP connection on port 25 to your new server and deliver the emails.

Thanks,
Amit Aggarwal.
0
 
rakeshmiglaniCommented:
1) you MX record would be pointing to the ip of your firewall and then the firewall would be forwarding smtp traffic (port 25) to your old exchange server
2) you can check the same by entering your domain name in http://www.dnsstuff.com/ and checking your MX record
3) If your firewall is forwarding smtp traffic to your old exchange server then that can be changed in the firewall to reflect the ip of your new exchange server
4) Check whether you are forwarding your mail to any smart host (smtp connector properties/smtp virtual server properties)

0
 
Handersson75Author Commented:
Yes, both servers under the same administrative and routing group.

How to check which server is responsible there as a bridgehead server to send mails to the internet? Prop on "Default STMP Virtual Server", and after that?

How to check mx records/ how to change? : Do the ISP change it? Is it my internal IP adress I tell or?

Regarding the firewall I can not find anywhere that it points on the mailserver...Any suggestions?
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
rakeshmiglaniCommented:
put your domain name in the link that i have pasted above and it would tell you about your MX record.
0
 
aa230002Commented:
Is your Exchange server configured to directly receive emails from the internet or you use some POP3 connector to downlaod mails from some ISP?
If you are using POP3 connector, then you simply need to reconfigure your POP3 connector on the new server.

Thanks,
Amit Aggarwal.
0
 
Handersson75Author Commented:

oki .. did a DNS lookup MX record...  and its pointed on the old server like srv01.company.com

I suppose I have to contact my ISP and tell them to change it, or?
0
 
rakeshmiglaniCommented:
Can you let me know your smtp domain name?
0
 
Handersson75Author Commented:
domain leimdorfer . se
0
 
rakeshmiglaniCommented:
you are correct. the MX record is pointing to an exchange server name, which i assume is your old exchange server.
are your hosting your own MX record or is your ISP doing it for you?
if it is your ISP then you need to tell them to change the MX record for you so that it points to your new server.
Same goes for A record as well.

other way would be to create a new MX record for the new server and set the cost lower than the other MX.
right now your existing MX is set to cost 0. you can get that changed to 5 or 10 and set the cost on the new MX to 0

0
 
Handersson75Author Commented:


Yes, its the old one... Really do not know if i take care of my own mx-record, can I see it somewhere?
0
 
rakeshmiglaniCommented:
Check the following link. It tells something about your DNS

http://www.checkdns.net/quickcheck.aspx?domain=leimdorfer.se&detailed=1
0
 
Handersson75Author Commented:
oki, The dns3 and dns4.telia.com is the ISP. Does this mean that it is the ISP is able to change the mx-record?
0
 
rakeshmiglaniCommented:
Yes
0
 
Handersson75Author Commented:
oki, Ill will contact them.

Do I have to change anything on the inside or in the firewall or does the mail know where to go?

0
 
rakeshmiglaniCommented:
i don't think so.

check your MX record again. there is an ip address listed there. if that ip belongs to your exchange server then no change is required. if that ip belongs to your firewall then change would be required.
0
 
Handersson75Author Commented:

Contacted the ISP and they will change the servername for me.

this one again:
How to check which server is responsible there as a bridgehead server to send mails to the internet? Prop on "Default STMP Virtual Server", and after that?



0
 
aa230002Commented:
You need to check the properties of the SMTP connector and not the SMTP virtual server.
Right Click on the Exchange org name on the top of the tree in your Exchange System Manager and click on properties, check the checkbox "Display Routing Groups".
Now expand routing groups , expand connectors and prop for SMTP connector and check the bridgehead server listed there.

Thanks,
Amit Aggarwal.
0
 
rakeshmiglaniCommented:
that is if you have a smtp connector configured. if it is not configured then check the properties of the default smtp virtual server. over there you have an option to specify the smart host address (which is not recommended) if there is no smart host configured there then it means that the exchagne server is using dns to send mail to the internet
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 8
  • 7
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now