Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2247
  • Last Modified:

Session size exceeds 10240 Kb error message - Exchange 2003

All

We are having problems sending messages to a remote organisation. The error message is as below -

            There was a SMTP communication problem with the recipient's email server.  Please contact your system administrator.
            <mailserv.mydomain.co.uk #5.5.0 smtp;552 172.168.0.3: your total session size exceeds maximum inbound size of 10240 kilobytes>

Sometimes, there is an attachment, other times not...but, in each case, any attachment was not larger than 3 MB's.

I cannot seem to find anything on the web for this and certainly haven't seen this before.

Under my SMTP Virtual server on mailserv.mydomain.co.uk properties there is no session limit set.

Any ideas?

Thx
0
Dilan77
Asked:
Dilan77
  • 6
  • 3
  • 3
  • +1
3 Solutions
 
aa230002Commented:
Its not the problem at your end but the problem at the destination end. You need to check with the remote organization for the message size limit set. Try to send the same mail from an external domain like hotmail.com or yahoo.com to this remote organization and see if it gets delivered.

Thanks,
Amit Aggarwal.
0
 
amaheshwariCommented:
Are you using any software/ hardware Firewall.Then please check incoming maximum inbound size.

thanks
0
 
Dilan77Author Commented:


Amaheshwari - We are using a PIX Firewall and a Trend Micro SMTP Gateway (for incoming mail only). However, since this is not related to incoming mail (from our perspective)
is it relevant?

Amit - I've tried sending from our organisation to Gmail, and the email works fine. I'll now try from Gmail to the remote organisation.

Thanks
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
amaheshwariCommented:
There is limit set for incoming messages on recipient side.That may be through ISA server , PIX Firewall .
Check these article for ISA and PIX:

http://www.isaserver.org/tutorials/smtprelaypart3.html  for ISA at recipient side.

http://support.microsoft.com/?kbid=895857 for PIX at recipient side.

Thanks
0
 
Dilan77Author Commented:
Thanks...but all of the messages are no larger than 3 MB. In fact, some of the messages have no attachments at all.

Additionally, the error message states 'exceeds maximum inbound session size' not '...inbound message size' so I'm thinking (perhaps wrongly) that the size
of the messages has nothing to do with it.

Any thoughts?

We have had no problem emailing them before.

0
 
aa230002Commented:
Did you try to send mail from gmail to this remote organization? what was the result? When this problem started? any changes at your end? are you facing problem sending mails to anyother domain also on the internet?


0
 
aa230002Commented:
Please have a look at this KB ->

Cannot send or receive e-mail messages behind a Cisco PIX firewall
http://support.microsoft.com/kb/320027/en-us
0
 
ExchgenCommented:
If you get the MX of the remote domain and try to telnet on port 25, what happens?

Are you able to drop an emails using telnet?

What answers in the remote end? Exchange or some other mailing system?

Did you bounce logging on transport and enable SMTP logging? did we find anything in these logging.

As the first reply, i would may be agree to an issue at the remote end But would like to negate the possiblilty of an issue at your end.

Raghu
0
 
Dilan77Author Commented:
Hi Exchgen

I can't drop emails using telnet as they're behind a PIX firewall (as aa230002 states).

I've looked at Message tracking - the last two entries are for a test mail i sent out there, which wasn't received, was -

SMTP: Started outbound transfer of message

I have just enabled the advanced option on SMTP logging for hourly logs and will resend the message again.

0
 
ExchgenCommented:
Hmmmm....

That makes a lot of sense.

Cerate an SMTP connector with an address space at the remote domain.

In the advanced tab check the checkbox that says send HELO insted of EHLO.

Restart SMTP and routing engine service.

Test email to that domain

Update me.

Raghu
0
 
Dilan77Author Commented:
Hi Raghu

Well, the issue stopped for a while back but it's intermittently back on again :(

I'll create a new SMTP connector as you advise, but what difference would the HELO instead of EHLO make out of interest?

Thanks
0
 
ExchgenCommented:
The HELO connector is recommanded coz, PIX is known for stripping ESMTP VERBS

EHLO sample;

220 IGT-IMC-01.redmond.corp.microsoft.com Microsoft ESMTP MAIL Service <Inbound
SMTP Virtual Server> Fri, 9 Jun 2006 02:53:06 -0700
ehlo
250-IGT-IMC-01.redmond.corp.microsoft.com Hello [xxx.xxx.xxx.xxx]
250-TURN
250-SIZE 10485760
250-ETRN
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-8bitmime
250-BINARYMIME
250-CHUNKING
250-VRFY
250-TLS
250-STARTTLS
250-X-LINK2STATE
250-XEXCH50
250 OK

HELO sample;
220 IGT-IMC-01.redmond.corp.microsoft.com Microsoft ESMTP MAIL Service <Inbound
SMTP Virtual Server> Fri, 9 Jun 2006 02:54:35 -0700
helo
250 IGT-IMC-01.redmond.corp.microsoft.com Hello [xxx.xxx.xxx.xxx]

The above sample explains that HELO is a simple handshake and EHLO (esmtp) has extended features that PIX does not like.

Raghu

0
 
Dilan77Author Commented:
Thanks Raghu

I've been in contact with the IT staff on the recipient end, and for the moment they've unchecked the session size box on their default SMTP virtual server..

We'll see how we get along and I'll update you.

Thanks for the help though, much appreciated. :)

D
0
 
Dilan77Author Commented:
No repeat of problem since remote side unchecked the session size box on their default SMTP virtual server.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 6
  • 3
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now