• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4321
  • Last Modified:

Visual SourceSafe. Network Not Found error.

Hi all,

I have SourceSafe 6.0d.

We have recently (a few months ago) transferred our SourceSafe database to a new server. Although this was unpleasant, once I'd got over all the problems, everything worked fine. All functions worked correctly.

This weekend, the old server was switched off.

Now, every time I check in a module I get an error 'Network Not Found'. The module DOES check in properly and nothing seems to be wrong, other than the error dialog.

Clearly, somewhere in the settings is a reference to the old server but where? I cant find it! Any ideas where I could look?

Paul
0
PaulCaswell
Asked:
PaulCaswell
  • 4
  • 4
1 Solution
 
PaulCaswellAuthor Commented:
I've monitored the process using FileMon and it shows no access to the old server and no relevant file access errors!

Paul
0
 
Mikeh926Commented:
Are you checking in from SourceSafe itself, or checking in from Visual Studio (or some other IDE that uses Sourcesafe)?
0
 
PaulCaswellAuthor Commented:
I'm checking in from VS C++ 6.0!

I've also noticed that it only happens when the file has actually changed, i.e. its not turning the checkin into an undo-checkout.

I've searched all the DSP and DSW files for references to the old server. No hits.

When we moved over to the new server I deleted all the .NCB and .OPT files to get them rebuilt.

Paul
0
Restore individual SQL databases with ease

Veeam Explorer for Microsoft SQL Server delivers an easy-to-use, wizard-driven interface for restoring your databases from a backup. No expert SQL background required. Web interface provides a complete view of all available SQL databases to simplify the recovery of lost database

 
Mikeh926Commented:
Do you get the same error if you check in from SourceSafe directly?
0
 
PaulCaswellAuthor Commented:
I just tried that (hadnt thought of that test). Yes! The same error happens!

Paul
0
 
Mikeh926Commented:
Check the following registry locations to see if the path to your sourcesafe database is correct:

HKCU\Software\Microsoft\Sourcesafe
HKCU\Software\Microsoft\Sourcesafe\databases

Check the following file for the correct path to your database:

c:\program files\Microsoft visual studio\vss\srcsafe.ini

If that all seems correct, try disconnecting and reconnecting to the database. From Sourcesafe, choose file/open Sourcesafe database and choose the correct one. Also Remove any others that are no longer valid.

Regards,
Mike.
0
 
Mikeh926Commented:
A couple more things I just thought of - you moved the database to a different server, is your user login credentials the same for the new server as the old server? Do you have the same access rights to the source safe directory share?

Also, sourcesafe has the concept of a temporary directory (not sure what it uses it for). Check SourceSafe, options, general, folder for temporary files and make sure this is on your local hard disk. If you run SSADMIN, it has a "clean up temporary files" option which (on my setup) has a network path. I don't know where this is set but does that point to a valid location.

Finally, check the srcsafe.ini file that is in the root directory of your database and make sure that it does not contain any references or paths to your old server.

Mike.
0
 
PaulCaswellAuthor Commented:
>>is your user login credentials the same for the new server as the old server?
Yes! And I've been working with the new one for quite a while now (several months).

>>...temporary directory...
I checked that. It points to a valid location and I do have full access to that location.

>>...check the srcsafe.ini...
Cracked it! There is a line in there that says:

Journal_File = \\<old server>\...

Thanks MIke! :-)

Paul
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now