• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 251
  • Last Modified:

Password Expiration for POP/ HTTP /MAPI users

Hi,
 

We have Exchange2003 on Win2003 both has sp1. We have OWA and POP client access. Most of our employees are pop users. We have enabled password expiration on every 50 days in AD. But there is no alert for any users for their password expiration, how to make alert for the OWA users and POP Users & MAPI users. Please suggest if any ready made tools are available.
 
Note : Most of the users are accessing mail from different forests and different domains.
 

Regards,

Ganesh Kumar. A
0
nessmssit
Asked:
nessmssit
  • 5
  • 4
1 Solution
 
SembeeCommented:
OWA users will get an alert through OWA.

POP3 users will not get any form of alerts. You will also have to find yourself a way that they can change the password, as there is nothing available through the POP3 interface.

Therefore you will need to use an email message to alert the users.
Take a look at this script from another MVP, Michael B Smith.
http://blogs.brnets.com/michael/archive/2005/09/13/1474.aspx

Simon.
0
 
nessmssitAuthor Commented:
Any other ready made tool available for alerting?
0
 
SembeeCommented:
I haven't seen anything commercial.

There was a tool called PEWA that was an unsupported tool from Microsoft, but I have had very little success with it it. It would break for no reason whatsoever and I have seen I am not the only one to have that problem.

You really should learn scripting, as it is the only way to do many things with Exchange. The next version of Exchange is all script based - with the GUI just running scripts in the background.

Simon.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
nessmssitAuthor Commented:
Excellent!, your script works in a fantastic way.

this is what i have expected.


Thank you so much.

Regards,

Ganesh
0
 
nessmssitAuthor Commented:
Hi,

I need some help, we are not having users under the Users OU.

We have separate OU named as MINDTS. In the script where you have specified the from which Hosting_OU this has to take. I also specified only the OU Name. But it is not working.

If i am moving the users to the Users OU then this script works fine. We have some 1000 users under this MINDTS OU.

Any suggestion or help will be appreciated.

Thanks

Ganesh
0
 
nessmssitAuthor Commented:
Hi,

This scripts works well if it is the object=users are in User OU. If it is in diferent OU it is not sending email message.

Please help..

Regards,

Ganesh
0
 
SembeeCommented:
The script isn't mine - it was written by someone else. I haven't actually deployed it myself. You could try contacting the author, he is quite active on other forums and email lists.

Simon.
0
 
nessmssitAuthor Commented:
Please help if you can contact him and get the solution for the same.

Regards,

Ganesh.
0
 
SembeeCommented:
Sorry - I am not being the middle man. I have provided you with a solution. If you are having problems with the solution then you need to speak to the person who has created the solution. Going through a third party is never a good idea.

Simon.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now