[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

VPN

Posted on 2006-06-07
14
Medium Priority
?
855 Views
Last Modified: 2012-05-05
I would like to be able to connect to my workstation here at work from a VPN connection at home. I am currently using a VPN connection to connect to my various servers, but if I enter the IP address for my workstation (W2K Pro) it says: "The client could not connect to the remote computer>  Remote connections might not be enabled or the computer might be too busy to accept new connections. It is also possible that network problems are preventing your connection.  Please try connecting again later.  If the problem continues to occur, contact your administrator."

I've set up a "new connection" on my W2k Pro workstation here at the office that is configured as follows:  

General tab shows no devices selected. Virtual Private Network "Allow others to make private connections to my computer by tunneling through the Internet or other network" is checked.

Users tab (can only add local users) the Administrator user is checked and "Require all users to secure their passwords and data" is checked.

Networking tab:  Internet Protocal(TCP/IP), File and Printer Sharing for Microsoft Networks, & Client for Microsoft Neworks are all present and checked.  The properties for Internet Protocal(TCP/IP) are:  "Allow callers to access my local area network" is checked and Assign TCP/IP addresses automatically using DHCP is selected. Nothing else is selected here.

I read somewhere that both PC's must have the same userid and password setup on both computers (don't know if this is true), but setup the Administrator userid and password on my work PC.  Still haven't done this at home, as I wasn't even sure if that would help, but will try it tonight.

I am running XP Pro at home - use a cable modem and a linksys router. Our VPN connects thru our firewall with a Cisco VPN Client.

The boss wants this setup so that if there are issues with certain things, I can access my PC from home to assist other employees.

Is there something else I need to do?  I'm new to this site and posted a less specific question earlier, but nothing helped. Tried replying to my original question with another question and haven't received an answer so I assumed I would have to repost the question with more detail.  Thanks!
0
Comment
Question by:ricounty
  • 4
  • 4
  • 4
  • +1
13 Comments
 

Accepted Solution

by:
TTL79 earned 480 total points
ID: 16853799
I presume you're using Remote Desktop Connection to make the connection. Do you have remote connections enabled from your computer at work?

Right click "My Computer" -> Select "Properties" -> goto tab "Remote" and from there select the box that says "Allow remote users to connect remotely to this computer".

Other way to do this is to install RealVNC on your work and home computers and make the connection with that since you already have the VPN working.
0
 
LVL 13

Assisted Solution

by:prashsax
prashsax earned 900 total points
ID: 16854028
Your Home PC is directly connected to internet.

But your workstation at office is behind a firewall.

Also, it has a private IP address.

You need to do a static NAT from Public IP to Private IP on firewall.

Then, from your Home PC, put the Public IP address of your workstation.

Then it will connect.

Sample Diagram.
                         NAT                                                                      NAT
Home PC---------DSLRouter---------------Internet------------------------Firewall----------------------Workstation
192.168.x.x                       65.x.x.x                                  90.x.x.x                                    172.x.x.x
0
 

Author Comment

by:ricounty
ID: 16854050
Wouldn't I have a security issue using RealVNC to connect from home to work. The userid and password might be secure but I believe everything else is open to hackers.?

Also, I believe you misunderstood in that I don't wish to connect from work to home, but from home to work. If I right-click on "My Computer" -> Select "Properties" -> goto tab "Remote" (There is no tab called "Remote" on my W2K Pro machine when I do this.  However, as I said above:  "I've set up a "new connection" on my W2k Pro workstation here at the office that is configured as follows:  

General tab shows no devices selected. Virtual Private Network "Allow others to make private connections to my computer by tunneling through the Internet or other network" is checked.
 and
Networking tab:  Internet Protocal(TCP/IP), File and Printer Sharing for Microsoft Networks, & Client for Microsoft Neworks are all present and checked.  The properties for Internet Protocal(TCP/IP) are:  "Allow callers to access my local area network" is checked and Assign TCP/IP addresses automatically using DHCP is selected. Nothing else is selected here."

So what is it that isn't allowing this to work? Like I said above, the only thing I haven't tried is setting up both PC's so that they both have an identical local userid with the same password.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 13

Assisted Solution

by:prashsax
prashsax earned 900 total points
ID: 16854648
You do not have REmote Desktop on Windows 2K Pro machines.

You can use VNC without any fear as you would be using it over a VPN.

VPN in itself is secure, and will protect even clear text password.(If any, although VNC uses encrypted).

So, go ahead if you can connect VPN between both machines, use VNC.

0
 

Author Comment

by:ricounty
ID: 16854824
Since I'll be connecting from XP Pro to W2K Pro - Doesn't XP Pro have Remote Desktop Connection? If so, can I use that to connect to the W2K Pro Machine?
0
 
LVL 13

Assisted Solution

by:prashsax
prashsax earned 900 total points
ID: 16854839
XP Pro has RDP client, but W2K Pro cannot host RDP connections.

You either need Windows 2000 Server or install VNC server on W2K Pro.
0
 

Author Comment

by:ricounty
ID: 16854883
So in a nutshell in order for an XP Pro PC to have a virtual remote connection to a W2K Pro PC I'll need to set up VNC on both PC's. I won't be able to set up Remote Desktop on the XP Pro to communicate with VNC on the other end.

Also, is there anything in particular that I need to know to set up the VNC on the two PC's? and Is there a particular VNC you would recommend (I've heard of a couple)?  Thanks!
0
 
LVL 13

Assisted Solution

by:prashsax
prashsax earned 900 total points
ID: 16854935
You can use UltraVNC.

VNC runs in two modes.

Server mode is run on machines, which you want to control.(W2K in your case)

Viewer mode is run on machines, from which your want to control remote machine.(XP in your case)

Just run the Server part on W2K pro machine and connect using Viewer Part from XP machine.

It also has ability to encrypt the data, so its secure.

0
 
LVL 78

Assisted Solution

by:Rob Williams
Rob Williams earned 620 total points
ID: 16856921
VNC even with it's basic configuration is not as secure as Remote Desktop, but as mentioned, that is not an option with Win2K. Using VNC with a VPN is much more secure but it requires you configure the router to port forward the PPTP traffic to your PC. Where you are already doing this with server there are complications; 1) you need to modify the standard ports, as they would be being forwarded to the sever 2) not all routers support multiple PPTP tunnels.
A couple of other options are:
-Use Hamachi VPN free software that allows you to create a VPN tunnel between 2 sites with no port forwarding. This in conjunction with VNC works well.
http://www.hamchi.cc
-Use the LogMeIn service. They offer both free and paid versions
http://www.logmeim.com
0
 

Author Comment

by:ricounty
ID: 16857656
OK Got the VPN started. Then set up the VCN on my home computer and opened it.  So I started the VPN, then started VNC. Ended up having to use in internal IP to connect to my ocomputer. I'm using UltraVNC to connect to workstation at office. Screen is up and appears to be connected but when I click the "Send Ctrl+Alt+Del to host" button nothing happens. Am I doing something wrong or is there something I still need to configure? Thanks!
0
 
LVL 78

Assisted Solution

by:Rob Williams
Rob Williams earned 620 total points
ID: 16858163
>>"Ended up having to use in internal IP to connect to my ocomputer"
That is correct. Treat the connection as if you are in the office, on the same LAN.

As for the connection you sometimes need to play with the properties of the connection. Often best to first configure locally. However, try to choose options that require less bandwidth because of the connection you are using. I find the problematic one is often "preferred encoding". Personally i find "Hexile" works best. Then also choose reduced colors and remove backgrounds/wall papers.

One other problem can be a firewall on the machine to which you are connection. If you are getting the logon screen this is probably not the problem, but try disabling, if there is one, until you have it working.

Another way to do this by the way is if you have a VPN connection to the server, is to install VNC on the server and workstation. Then through the VPN connect to the server with the VPN and Remote Desktop, then from there connect to the PC with VNC. Sounds round a bout but works well.
0
 
LVL 78

Assisted Solution

by:Rob Williams
Rob Williams earned 620 total points
ID: 17250874
It seems the original question related to enabling the VPN, which seems to have been achieved. As well, all questions relating to connecting to services such as VNC have been addressed to date. Perhaps a point split is warranted on this question.
0
 
LVL 78

Expert Comment

by:Rob Williams
ID: 17252163
Thanks ricounty,
--Rob
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A 2007 NCSA Cyber Security survey revealed that a mere 4% of the population has a full understanding of firewalls. As business owner, you should be part of that 4% that has a full understanding.
In this article, WatchGuard's Director of Security Strategy and Research Teri Radichel, takes a look at insider threats, the risk they can pose to your organization, and the best ways to defend against them.
NetCrunch network monitor is a highly extensive platform for network monitoring and alert generation. In this video you'll see a live demo of NetCrunch with most notable features explained in a walk-through manner. You'll also get to know the philos…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question