Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1590
  • Last Modified:

The system cannot find the path specified

Hello All -

I have an OWA server in a DMZ - while in IIS Manager, both the Exchange virtual directory and the public virtual directory give me this error whenever I click on these folders "The system cannot find the path specified". I can start the information store and this error disappears.

I can get properties for these virtual directories, the the local path is pointed to M:\hcc.hctx.net\MBX for Exchange, and M:\hcc.hctx.net\Public Folders for public.

We recently completed an in-place upgrade for our front-end and back-end server, and the upgrade may have caused the problem (it looks to me like the M drive is being retained).

I am thinking about re-building the virtual directories within IIS Manager, and I need to know if anyone has used this technique before to resolve this problem, or a similar problem.

Thanks in advance
0
mainbearing
Asked:
mainbearing
  • 2
1 Solution
 
SembeeCommented:
The path not being found on IIS for Exchange virtual directories with the M: drive is very common.
It is down to the fact that IIS starts before Exchange and consequently IIS cannot find the path to the location at the point of startup.

As a rule, I don't do inplace upgrades and I don't put OWA in to the DMZ.
The inplace upgrade may be the reason that the M: drive has been retained. It is an option only on Exchange 2003.

Simon.
0
 
mainbearingAuthor Commented:
The final problem that I am trying to solve (by solving this problem first) is re-directing non-ssl requests to ssl.

Since the local path can't be found, I don't have access to any of the tabs with which to implement the respond.redirect code (or other).

Given this info, would re-building the virtual directories within IIS Manager fix this problem?

Thanks
0
 
SembeeCommented:
Rebuilding the virtual directories might fix the problem.

http://support.microsoft.com/default.aspx?kbid=883380

However the trick I do for redirecting to SSL is to block port 80 totally - not allow it in to the site. Then I put a web page on the public web site that redirects to the SSL version. The idea being that I don't want any anonymous connections coming in to the network.

Simon.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now