Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 594
  • Last Modified:

Problem connecting a router to a switch

Hi,

I'm having the following issue regarding the connection of a router to a switch:

I have a Linksys wrt54gc broadband router, it has wireless functionality, but that doesn't has anything to do with the problem. Also, I have a 3net 8-port switch (ALN-5008T) which is supposed to be 'intelligent'.

I ha ve a friend in the next floor who has a DSL connection to the Internet; the ISP assigns a maximum of 4 IP addresses dinamically via DHCP. So we decided to share his connection, connecting my 3net switch directly to the DSL modem. When we connect our 2 main PCs to the switch using straight-thru ethernet cables, we get 2 different IPs from our ISP; so far, it works fine. So I thrown an ethernet cable from his department thru mine, leaving the switch in his department. It still worked fine.

But then I decided to place the router mentioned above in my department, in order to share the connection between my two PCs, and there started the problem; I connected the same straight-thru cable I had in the PC to the 'Internet' port of the linksys, and connected the PC (straight-thru also) to a regular port of the router. The linksys router connected to the ISP, got an IP address and connected to the DNS servers.

I can ping from my PC and from inside the router. I can receive and send email using mail clients (which indicates that at least some ports and services are working in some level), but I can't browse the internet.

I´ve already tried changing the cable that goes from the switch to the Internet port of the router, from straight-thru to crossover, and it didn't work anyway. I discarded a problem of communication between the router and the switch inverting their position (connecting the router to the switch, and then the PCs to the Switch; it worked perfectly). Both the switch and the router work using IEEE 802.3 and 802.3u. I made (I think) every possible combination of cables (crossover or straight-thru) between PCs, router, modem and switch; but when the router is subordinated to the switch, there is no way to make it work.

Finally, a friend borrowed me a Hub. I made the desired connection using the right cables, and I got to make it work connecting the Hub to the Modem, the a PC and the Router to the Hub, and the other 2 PCs to the Router. Everything worked fine. But I need this to work without the borrowed hub, and using my own switch.

There must be something I don't know about, or maybe something really stupid i'm totally missing. I have two days searching the net for answers, but nobody seems to have tried to connect a router and a switch in that particular way (everybody connects the router to the modem, and the switch to the router; I need router and modem inverted).

I hope somebody has an answer on this... if not, this is probably going to be sadistically fun, as it has already been for me...
0
tr0pic4l
Asked:
tr0pic4l
  • 6
  • 5
  • 5
2 Solutions
 
Irwin SantosComputer Integration SpecialistCommented:
on your linksys router... configure the WAN to accept dynamic IP...

then configure the LAN on your router for another IP schema

If the upstream modem was offering  192.168.1.x, then you change your LAN settings to 192.168.0.x  OR 192.168.2.x
subnet 255.255.255.0
gateway is the IP of the Linksys router you just configured.

Enable DHCP on the router, start at 192.168.0(2).100 - >>> whatever.
0
 
tr0pic4lAuthor Commented:
Thanks for your comment,

The Linksys Router comes by default configured to accept dynamic IP. The ISP's modem assigns directions in the order of 201.249.x.x.

The Linksys Router, also, comes by default configured to offer DHCP dynamic IPs, and offers IPs inthe order of 192.168.1.100 ~ 150; I found not necesary to change that since the IP range is very different from the IP range assigned by the ISP. The local router's (gateway) IP address is, by default, 192.168.1.1.

The thing here is that even assigning good IPs from the linksys router (which has a good IP address given by the ISP, good DNSs and good Subnet Mask); even being able to ping from the PCs (since the PCs seems well connected to the Internet), and being able to check mail, I can't browse the internet.

Think I'm gonna raise the points on this question.

Thanks!

0
 
pseudocyberCommented:
Some diagnostic testing ...

On the machine which can't browse the Internet ...

Open a command window, and type "ipconfig /flushdns".

Then, do the following in order - and reply if they work or not.

ping 127.1.0.1
ping 192.168.1.x where .x is the IP of the PC itself
ping 192.168.1.1 where .1 is the IP of the Default Gateway (router or modem)

Type "ipconfig /all" and determine IP's of your DNS servers - can you ping them?

ping 64.156.132.140

Open a browser - put in www.experts-exchange.com - can you get to us? with the URL?  Put in the IP, 64.156.132.140.  Can you get the page that way?  

If that doesn't work, open a command window and type, "telnet 64.156.132.140 80".  Then, if you connect, type "get" and enter and you should get some html code - this verifies connectivity over port 80 - if this works and your browser doesn't, then it's an application/OS issue.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Irwin SantosComputer Integration SpecialistCommented:
on the machine that can't browse the net. in the TCP/IP property settings do you have Under DNS, "Obtain automatically" or do you have an actual IP address in there?  If the former, then manually enter the DNS server of your ISP.  If the latter, confirm the DNS is correct OR make it obtain an IP automatically.
0
 
tr0pic4lAuthor Commented:
Pseudocyber,

I did the tests you say. Here are the results.

 - Did the ipconfig /flushdns.
 - the ping to 127.1.0.1 worked.
 - ping to 192.168.1.102 worked.
 - ping to 192.168.1.1 worked.

 - I checked on the DNS servers; the router gets the DNS servers from the ISP, and the PC gets the DNS from the router; I can perfectly ping both of them.
  (IRWINPKS: tried putting the DNS manually on the PC: it didn't work anyway, as with the automatic configuration).

- The ping to 64.156.132.140 worked.

- Telnet returned HTML to me; it was, however, the HTML of a site saying that experts exchange is down, under mainteinance. That's not the main page of experts exchange at the present moment. ¿Suspicious?

So there are the tests. However, I doubt that my problem relies on an application, because, as I said before, If I connect any of my PCs (there are 3 different ones) directly to the ISP, I can navigate perfectly, and if I connect the router to the ISP, and the PC to the router, it also works. Even If I connect the router to the ISP, the Switch to the router, and the PCs to the switch, it works; but I need the router to be connected between the PCs and the Switch, for personal reasons (the first device that I connect to the ISP is going to stay in my friends department, and I want to keep the router in my department in case of a future need for its wireless capabilities).

Thanks.
0
 
pseudocyberCommented:
Can you do an nslookup from the command line on www.experts-exchange.com and get it resolved to the IP?

Can you put in the URL and get the website?

(It's normal to get the message about the site down).
0
 
tr0pic4lAuthor Commented:
Hi,

Yes, I can do the nslookup.

¿What exactly do you mean by 'put in the URL and get the website'?

I can't browse in any way, if that's what you mean... I only can browse when I connect the PC directly to the Modem, or in any of the other combinations mentioned above as working.
0
 
Irwin SantosComputer Integration SpecialistCommented:
Is that suspect machine running AOL and Portmagic????
0
 
tr0pic4lAuthor Commented:
Nop, none of those.

Remember, the problem occurs in all 3 PCs.
0
 
Irwin SantosComputer Integration SpecialistCommented:
do

ipconfig /all

on those 3 computers... post your results please
0
 
pseudocyberCommented:
>>¿What exactly do you mean by 'put in the URL and get the website'?

I mean, put he URL - http://www.experts-exchange.com - in the address and hit enter.  Doesn't go to the website?!!?  But you can telnet to www.experts-exchange.com 80 and issue a "get" command and get html code back!?!?
0
 
tr0pic4lAuthor Commented:
Pseudocyber,

That's right!

Impressive isn't it?
0
 
pseudocyberCommented:
Then it's not a network problem - it's an application/OS problem.
0
 
tr0pic4lAuthor Commented:
Hi,

If found out that the problem was caused by a problem in my switch; I suppose it's broken, or that it's too cheap or something; cause it worked for some things, but not for other...

However, i'm splitting the points between the two pals that took some time thinking about this crap... thanks pseudocyber and irwinpks!
0
 
Irwin SantosComputer Integration SpecialistCommented:
cool. thank you!!!
0
 
pseudocyberCommented:
Hey, thanks.  :)
0

Featured Post

[Webinar] Database Backup and Recovery

Does your company store data on premises, off site, in the cloud, or a combination of these? If you answered “yes”, you need a data backup recovery plan that fits each and every platform. Watch now as as Percona teaches us how to build agile data backup recovery plan.

  • 6
  • 5
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now