Setting up a Thompson/RCA DCM 425 cable modem to work with a Linksys WRT54GC router.

Hi Experts!

I'm one of those "knows just enough to be dangerous" people when it comes to this networking stuff and thought I'd let somebody that knows what they're doing help instead of mucking through it myself!

If the modem is hooked up directly to my computer, I can release and renew the IP with no problems.
Running through the router, however, I go to the router admin site, left at the default http://192.168.1.1
And then try to do a IP release/renew for the Internet Connection section of the admin site and it won't get an IP from the modem....

When the modem is connected directly to the computer...I can get to a diagnostics page on the modem by going to: http://192.168.100.1
I thought maybe if I changed all the router stuff to 192.169.*   that it would make a difference...no luck...tried setting the router to act as router and not gateway...no luck...

There isn't much info I could find on this particular modem...but the user manual said that I could hook this modem into a hub or switch by using a crossover cable, or using a normal cable and plugging it into the uplink port of the switch....
would that really work? why? would not using dhcp on the router make the modem work?...i really don't want to do that though...





LVL 37
samtran0331Asked:
Who is Participating?
 
callrsConnect With a Mentor Commented:
Re: "I thought maybe if I changed all the router stuff to 192.169.*"
Hmm. Ok I recommend: press the RESET switch on the router for 30 seconds.

Then ensure:
- internet coax cable is connected to the modem
- ethernet cable goes from modem to your router
- ethernet cable goes from router to your computer

Now turn off power to your modem & router
Reboot the computer
Turn on power to your modem & router
Wait til they come online etc.
Then open Internet Explorer, it may work now

If it doesn't work then in IE:
Tools-> Internet Options --> Connections -> Lan Settings
Make sure "Automatically detect settings" has a check
Make sure "Use a proxy server..." has no check
Then close IE & restart IE

0
 
callrsConnect With a Mentor Commented:
Also, just to make sure:
According to this http://www.inversiones.marmier.net/images/wrt54gc-1.jpg
The cable connecting your modem to your router should connect to the ethernet jack, colored BLUE, next to the power plug.
You normally don't need a crossover cable with the modern modems & routers -- they auto-detect & adjust with the standard cable.
0
 
FriarTukConnect With a Mentor Commented:
if it works connected to you pc but not with your new router, then it is probably due to the fact the the isp uses both the mac addr of the modem & the pc's nic - try setting the router to clone the mac addr of the computer's nic
0
 
samtran0331Author Commented:
Hi guys!

Thanks for the assistance!

callrs, I reset everything to factory defaults and rebooted everything in the order you suggested...still no go...cables were right....guess I should have mentioned that I moved and at my old place the network worked fine...except I was with time warner...moved and got a new modem and service with adelphia....

FriarTuk, tried the clone mac addy and still no luck...

...I turned off dhcp on the router and all seems well!  had to give everything static ip's but at least it all works.

thanks again!
Sam
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.