spamassassin returned message

when I run
spamassassin -D --lint

I got messages like

[21999] dbg: config: using "/etc/mail/spamassassin" for site rules dir
[21999] dbg: config: read file /etc/mail/spamassassin/local.cf
[21999] info: config: can not determine userstate dir
[21999] warn: config: could not find userprefs file

so what is suppose the last 2 lines means ?

I run the command as root and the 2 lines are not there. Is spamassassin suppose to be run as root ?
ChanYiuPongAsked:
Who is Participating?
 
pjedmondCommented:
Spamassassin can be run as any user.

When run as a non-root user, spamassissin first reads the 'global' spam assassin settings, and then these can be over-ridden by the local user settings enabling the user to customise the spam-assassin setup for their mail. The user file is normally:

~/.spamassassin/user_prefs

The above messages indicate that this file does not exist. Merely create it (as a blank file), and those warnings will go.

Here for a information/list of possible settings in this file if you wish to customise the spamassassin behaviour:

http://spamassassin.apache.org/full/3.0.x/dist/doc/Mail_SpamAssassin_Conf.html

HTH:)
0
 
pjedmondCommented:
..or, as the user concerned, to make it nice and simple:

mkdir ~/.spamassassin
touch ~/.spamassassin/user_prefs

and the messages will not occur;)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.