• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1160
  • Last Modified:

fstab with SMBFS?

hi I have this problem:

//SERVER/C      /home/USER/C      smbfs      rw,username=***,password=***,uid=500,gid=100,dmask=770,fmask=770 0 0

this is the line in my fstab.

now I can use it all fine and everything, but after each file copy I get a Warning: Could not change File permission? can anyone tell me what I should do?

Also, if I want to delete a file from the mount, it tries to copy it to my local rubish bin 1st then delete it, so big files i can delete them remotely, anyone have any suggestions on that as well??

Thanks very much in advanced
0
sakuya_su
Asked:
sakuya_su
  • 4
1 Solution
 
pjedmondCommented:
The reason is that permissions on the remote server do not allow you to change the file permissions as required by the fstab entry. Removing the dmask=770,fmask=770 in the fstab will correct this. Alternatively, you can change the configuration of the samba server to allow this.

With respect to the file being copied to you rubbish bin, this behaviour is a function of how the samba daemon is configured. Do you have the ability to alter the smb.conf on the server? Depending on how that is set up, you may find that removing uid=500,gid=100 helps.

HTH:)
0
 
sakuya_suAuthor Commented:
the samba server is a windows machine, so i dont think i can do anything, removing dmask=770,fmask=770 cause my drive to mount as read only for some reason dispite the fact i have rw flag
0
 
pjedmondCommented:
In which case, I suspect that the windows share that you are mounting is on a FAT32 partition? FAT32 has no concept of rwx for ugo, and attempting to do it will give you an error similar to that reported. The solution is to migrate the share to an NTFS partition.

HTH:)
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
pjedmondCommented:
I'm trying to find what matches a FAT32 set of permissions. You could try:

fmask=664,dmask=775

and see what happens? Otherwise I suspect that you may have to live with this or possibly convert the partition:

http://www.microsoft.com/technet/prodtechnol/winxppro/maintain/convertfat.mspx

Obviously back up everything before doing this!
0
 
AnonymouslemmingCommented:
You might want to move from SMBFS to CIFS as SMBFS is no longer maintained and has some bugs.
0
 
pjedmondCommented:
Another possible fmask is 666, or 660, but be aware that this might make files on the host windows machine viewable by others that you don't want to have viewing access.

HTH:)
0

Featured Post

Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now