[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1026
  • Last Modified:

OMA and ActiveSync

Dear All,

     I have an EXchange 2003 server with SP 1 installed on windows 2003 server sp1, the server is a member server and its not a DC, Once I tried OMA I receive this error"   A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator"

I have installed exchange 2003 with SP 2 on a test server which is s Domain controller and OMA and Activesync worked fine, Does this mean that I have to installed SP2 on the live one??

In the live one Im using Forms Based Authentication, also I saw an article from MS to change some reg settings, but I did not do it.


any Help
0
ibmas4002
Asked:
ibmas4002
  • 13
  • 13
1 Solution
 
SembeeCommented:
You should really install SP2 for Exchange 2003 before you go any further.
The whole mobile device support was updated heavily in that service pack and as such many things have changed.

There is also a known issue with having FBA enabled and trying to use OMA/EAS. I have some information about that on my web site: http://www.amset.info/exchange/mobile-omafba.asp

However before making any more changes, get the service pack on the machine.

Simon.
0
 
ibmas4002Author Commented:
Hi Sembee.

I installed sp 2, but still im getting the same error, and when sych from outside using GPRS Im receiving this error
your account does not have permission to sync with your  current settings

the access is fine.

any help
0
 
SembeeCommented:
Have you enabled all the options in ESM, Global Settings, Mobile Services?

Does OMA work from a desktop?

Simon.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
ibmas4002Author Commented:
Hi Sembee

No OMA gives the same error from the desktop, also i have enabled all the options in ESM,  but im using forms based auth, but my default web server does not have ssl enabled on it, I have SSL for a different VD which is the one used for uses to login to their Mailbox

Thanks
0
 
SembeeCommented:
Do you have require SSL enabled on either /exchange, /oma or /Microsoft-Server-ActiveSync virtual directories in IIS?
If so, you need to remove that option.

Simon.
0
 
ibmas4002Author Commented:
No I dont have it enabled
0
 
SembeeCommented:
Can you clarify what you mean by this:

"... different VD which is the one used for uses to login to their Mailbox"

OMA/EAS makes calls to the /exchange virtual directory to get the data. If you have changed the behaviour of OWA then you may well have broken OMA/EAS.

Simon.
0
 
ibmas4002Author Commented:
I mean The default /exchange is running without SSL, I have another Cirtual directory which use another Ip and has the SSL enabled


0
 
SembeeCommented:
Are you using host headers?
When you attempt to login to oma, any errors in the event viewer on the Exchange server?

Simon.
0
 
ibmas4002Author Commented:
Yes Im receiving MSExchangeOMA 1503 error.

0
 
ibmas4002Author Commented:
ok Thanks simon, it worked locally now, but from outside its giving error ( error commmunicating with server)


which ports to open from the PIX???


Thanks for ur support
0
 
SembeeCommented:
It only needs one port if you are using SSL - 443. If you are using http (which means username and password information is going across in the clear) then you need port 80 open.

Simon.
0
 
ibmas4002Author Commented:
again im getting system error?
0
 
SembeeCommented:
Need rather more information than that.
What sort of errors?
If you browse to OMA using Internet Explorer on a desktop or a laptop with show friendly http error messages disabled, what do you see then?

Simon.
0
 
ibmas4002Author Commented:
Hi Sembee

its showing A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator"


and MSExhangeOMA 1503 mesage
0
 
SembeeCommented:
What do you mean by MSExhangeOMA 1503 message? Is that an error in the event log? If so, post the full event log message - the error ID on its own is not enough.

Was that error about a system error occurring displayed in Internet Explorer when you had show friendly http error messages disabled?

Check that the authentication and application pool settings in IIS Manager are set as I have outlined on my web site here: http://www.amset.info/exchange/mobile-eastrouble.asp

Simon.
0
 
ibmas4002Author Commented:


This error im getting in the application log
An unknown error occurred while processing the current request:
Message: The remote server returned an error: (403) Forbidden.
Source: Microsoft.Exchange.OMA.ExchangeDataProvider
Stack trace:
   at Microsoft.Exchange.OMA.ExchangeDataProvider.OmaWebRequest.GetRequestStream()
   at Microsoft.Exchange.OMA.ExchangeDataProvider.ExchangeServices.GetSpecialFolders()
   at Microsoft.Exchange.OMA.ExchangeDataProvider.ExchangeServices..ctor(UserInfo user)

Message: Exception has been thrown by the target of an invocation.
Source: mscorlib
Stack trace:
   at System.Reflection.RuntimeConstructorInfo.InternalInvoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean isBinderDefault)
   at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
   at System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
   at System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
   at Microsoft.Exchange.OMA.UserInterface.Global.Session_Start(Object sender, EventArgs e)

Message: Exception of type Microsoft.Exchange.OMA.DataProviderInterface.ProviderException was thrown.
EventMessage:
UserMessage: A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator.
Source: Microsoft.Exchange.OMA.UserInterface
Stack trace:
   at Microsoft.Exchange.OMA.UserInterface.Global.Session_Start(Object sender, EventArgs e)
   at System.Web.SessionState.SessionStateModule.RaiseOnStart(EventArgs e)
   at System.Web.SessionState.SessionStateModule.CompleteAcquireState()
   at System.Web.SessionState.SessionStateModule.BeginAcquireState(Object source, EventArgs e, AsyncCallback cb, Object extraData)
   at System.Web.AsyncEventExecutionStep.System.Web.HttpApplication+IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)


For more information, see Help and Support Center at
0
 
SembeeCommented:
The only bit that is relevant is this:  (403) Forbidden

Everything else is a consequence of that.

Did you check the settings in IIS Manager from my web site?

Simon.
0
 
ibmas4002Author Commented:
Yes its the same, anything else i have to check it.
0
 
SembeeCommented:
OMA does not work either inside or outside? Nor from the server either?

Simon.
0
 
ibmas4002Author Commented:
Its not working from inside and ouside as well as the server.

Thanks
0
 
SembeeCommented:
Do you get an authentication prompt when you browse to OMA?

Simon.
0
 
ibmas4002Author Commented:
Yes, im getting it

Thanks
0
 
SembeeCommented:
What do you enter when you are asked for authentication?

Username
domain\username
username@domain ?

Something else?

Do you have multiple SMTP addresses on the Exchange server?

Simon.
0
 
ibmas4002Author Commented:
Yes I do have multiple addresses, im trying domainname\myuser name

thanks
0
 
SembeeCommented:
There is a common problem where people have more than one SMTP address on the server, but the user account only has one, which isn't the default address the Exchange server uses. This can cause problems.

For example, if the domain name is domain.local and your account only has an SMTP address in domain.com, then you will get an issue. You would need to add an address @domain.local to the account - but it does not have to be the default address.

Simon.
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

  • 13
  • 13
Tackle projects and never again get stuck behind a technical roadblock.
Join Now