[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Exchange 2003 server stops local delivery

Posted on 2006-06-08
19
Medium Priority
?
3,713 Views
Last Modified: 2013-11-15
Dear Experts,

we have a critical problem.

FUll-meshed VPN domain between 3 countries.

They each have a Windows 2003 AD controller (also DNS) and Exchange 2003 SP1 server.

Everything works ok except for one country, this server nearly every morning "freezes" the exchange application, by this I mean that local delivery doesn't work anymore (outside emails do work). After a while then also Outlook web access is also not available at that time anymore and connecting Outlook to exchange also fails.

EventID errors:

MSExchangeSRS / ID 1400
The Microsoft Exchange Site Replication Service could not initialize its Exchange database (EDB) and returned error 1.  The Site Replication Service will wait in a semi-running state so the database can be restored from backup and the SRS can mount it.

Winlogon / ID 1015
A critical system process, C:\WINDOWS\system32\lsass.exe, failed with status code 128.  The machine must now be restarted.

MSExchangeAL / ID 8250
The Win32 API call 'DsGetDCNameW' returned error code [0x862] The specified component could not be found in the configuration information.  The service could not be initialized.  Make sure that the operating system was installed properly.

MSExchangeMTA / ID 2219
The MTA is running recovery on the internal message database because the MTA was not shut down cleanly. This operation may take some time.  Status updates will be written to the Windows 2000 Event Log. [DB Server MAIN BASE 1 0] (14)

MSExchangeMTA / ID 2206
The MTA database recovery operation is now checking queue: XAPIWRKQ, the filename of this queue is: 01000020. [DB Server MAIN BASE 1 29] (14)

MSExchangeMTA / ID 2207
The MTA database recovery operation has completed successfully. Recovery details can be found in the file: D:\Program Files\Exchsrvr\mtadata\.\MTACHECK.OUT\MTACHECK.LOG. [DB Server MAIN BASE 1 67] (14)

ESE / ID 206
Information Store (2992) First Storage Group: Database D:\Program Files\Exchsrvr\mdbdata\priv1.edb cannot be incrementally backed-up. You must first perform a full backup before performing an incremental backup

MSExchangeIS / ID 9611
Error code 0xfffffdd0 when freezing the Storage groups.

LSASRV / ID 5000
The security package Negotiate generated an exception.  The exception information is the data.

Can anyone help ?

Thx
0
Comment
Question by:ulensr
  • 10
  • 5
  • 2
  • +2
19 Comments
 
LVL 12

Accepted Solution

by:
aa230002 earned 1200 total points
ID: 16859227
Is your online maintenance and backup timings over-lapping? i have seen this creating these type of problems with Exchange.

Thanks,
Amit Aggarwal.
0
 

Author Comment

by:ulensr
ID: 16859323
Can you please tell me where to check the online maintenance ?
0
 
LVL 12

Expert Comment

by:aa230002
ID: 16859351
In Exchange system Manager - Properties of the Mailbox store - Database tab - Maintenance interval.

Please have a look the following KB for more info -> (specially 3rd paragraph from the section "Defragmenting the Database"

Overview of maintenance, backup, and disaster recovery for Exchange Server
http://support.microsoft.com/kb/272234/en-us

Thanks,
Amit Aggarwal.

0
Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

 

Author Comment

by:ulensr
ID: 16859428
I just looked and it was scheduled from 2 to 6AM, the backup starts at 8PM.

I did notice that it said for Full and incremental backup "This type of backup was never performed."

Thx
0
 
LVL 12

Expert Comment

by:aa230002
ID: 16859497
Why do you have Site Replication Service in your Exchange 2003? did you ever have an Exchange 5.5 in this organization? if you dont have any Exchange 5.5 box right now and have already removed that, you also need to remove the SRS and change your Exchange mode from Mixed to Native.

Please have a look at these KBs ->
XADM: Preparing a Mixed Mode Organization for Conversion to Native Mode
http://support.microsoft.com/kb/272314/

How To Convert from Mixed Mode to Native Mode in Exchange
http://support.microsoft.com/kb/327779/en-us

Thanks,
Amit Aggarwal.
0
 

Author Comment

by:ulensr
ID: 16859661
We are running in exchange native mode, shall I simply stop and disable the SRS ?
0
 
LVL 29

Expert Comment

by:mass2612
ID: 16859678
Try running dcdiag and netdiag on the Exchange server in question also and make sure the AD and the global catalog is working ok.
0
 
LVL 12

Expert Comment

by:aa230002
ID: 16859690
yes, stop and disable the SRS service. and then monitor the server for couple of days. In case, everything goes fine, you can remove the SRS instance from Exchange System Manager and delete the SRS database also srs.edb.

Navigate to the Tools container in Exchange System Manager, click the Site Replication Services container, right-click each SRS, and then click Delete

Thanks,
Amit Aggarwal.
0
 

Author Comment

by:ulensr
ID: 16859772
I have stopped and disabled this service on all 3 servers.
0
 

Author Comment

by:ulensr
ID: 16859774
Hi Mass2612,

I am running dcdiag and netdiag now, I will paste the results asap
0
 
LVL 12

Expert Comment

by:aa230002
ID: 16859791
I would suggest you to cross check your Exchange org mode, if its in Native or Mixed.  You also need to check the properties of each and every Administrative Group to make sure that all Administrative groups are running in Native Mode.

Please check the attribute values given in this KB using the tool like ldp.exe or Adsiedit.msc to make sure that you are running in Native Mode.

The Change Mode button is unavailable in the Organization Properties dialog box after you upgrade Exchange Server 5.5 Service Pack 3 to Exchange 2000 Server or to Exchange Server 2003.
http://support.microsoft.com/kb/260781/en-us

Thanks,
Amit Aggarwal.
0
 

Author Comment

by:ulensr
ID: 16859803
NETDIAG results:
===========

....................................

    Computer Name: SDEMSEXCHANGE
    DNS Host Name: sdemsexchange.renov.local
    System info : Microsoft Windows Server 2003 (Build 3790)
    Processor : x86 Family 15 Model 4 Stepping 3, GenuineIntel
    List of installed hotfixes :
        KB831464
        KB883114
        Q147222


Netcard queries test . . . . . . . : Failed
    GetStats failed for 'Intel(R) PRO/1000 MT Network Connection #2'. [ERROR_INV
ALID_FUNCTION]
    GetStats failed for 'Intel(R) PRO/1000 MT Network Connection'. [ERROR_INVALI
D_FUNCTION]
    [FATAL] - None of the netcard drivers provided satisfactory results.



Per interface results:

    Adapter : LAN

        Netcard queries test . . . : Failed
        NetCard Status:          UNKNOWN

        Host Name. . . . . . . . . : sdemsexchange
        IP Address . . . . . . . . : 192.168.132.4
        Subnet Mask. . . . . . . . : 255.255.255.0
        Default Gateway. . . . . . : 192.168.132.1
        Dns Servers. . . . . . . . : 192.168.132.2
                                     192.168.131.3


        AutoConfiguration results. . . . . . : Passed

        Default gateway test . . . : Passed

        NetBT name test. . . . . . : Passed
        [WARNING] At least one of the <00> 'WorkStation Service', <03> 'Messenge
r Service', <20> 'WINS' names is missing.

        WINS service test. . . . . : Skipped
            There are no WINS servers configured for this interface.

    Adapter : Local Area Connection 2

        Netcard queries test . . . : Failed
        NetCard Status:          UNKNOWN

        Host Name. . . . . . . . . : sdemsexchange
        IP Address . . . . . . . . : 0.0.0.0
        Subnet Mask. . . . . . . . : 0.0.0.0
        Default Gateway. . . . . . :
        Dns Servers. . . . . . . . : 192.168.132.2

        IpConfig results . . . . . : Failed
            [WARNING] The network card is Dhcp Enabled, but you do not have a va
lid DHCP server address for the card.

        AutoConfiguration results. . . . . . : Passed

        Default gateway test . . . : Skipped
            [WARNING] No gateways defined for this adapter.

        NetBT name test. . . . . . : Passed
            No names have been found.

        WINS service test. . . . . : Skipped
            There are no WINS servers configured for this interface.


Global results:


Domain membership test . . . . . . : Passed


NetBT transports test. . . . . . . : Passed
    List of NetBt transports currently configured:
        NetBT_Tcpip_{CB007FFC-FBA0-4CAF-A54F-366E63C06BD0}
    1 NetBt transport currently configured.


Autonet address test . . . . . . . : Passed


IP loopback ping test. . . . . . . : Passed


Default gateway test . . . . . . . : Passed


NetBT name test. . . . . . . . . . : Passed
    [WARNING] You don't have a single interface with the <00> 'WorkStation Servi
ce', <03> 'Messenger Service', <20> 'WINS' names defined.


Winsock test . . . . . . . . . . . : Passed


DNS test . . . . . . . . . . . . . : Passed

Redir and Browser test . . . . . . : Passed
    List of NetBt transports currently bound to the Redir
        NetBT_Tcpip_{CB007FFC-FBA0-4CAF-A54F-366E63C06BD0}
    The redir is bound to 1 NetBt transport.

    List of NetBt transports currently bound to the browser
        NetBT_Tcpip_{CB007FFC-FBA0-4CAF-A54F-366E63C06BD0}
    The browser is bound to 1 NetBt transport.


DC discovery test. . . . . . . . . : Passed


DC list test . . . . . . . . . . . : Passed


Trust relationship test. . . . . . : Passed
    Secure channel for domain 'RENOV' is to '\\sdemsad.renov.local'.


Kerberos test. . . . . . . . . . . : Passed


LDAP test. . . . . . . . . . . . . : Passed


Bindings test. . . . . . . . . . . : Passed


WAN configuration test . . . . . . : Skipped
    No active remote access connections.


Modem diagnostics test . . . . . . : Passed

IP Security test . . . . . . . . . : Skipped

    Note: run "netsh ipsec dynamic show /?" for more detailed information


The command completed successfully

0
 

Author Comment

by:ulensr
ID: 16859808
DCDIAG result running the AD controller in the same site


Domain Controller Diagnosis

Performing initial setup:
   Done gathering initial info.

Doing initial required tests
   
   Testing server: Germany\SDEMSAD
      Starting test: Connectivity
         ......................... SDEMSAD passed test Connectivity

Doing primary tests
   
   Testing server: Germany\SDEMSAD
      Starting test: Replications
         ......................... SDEMSAD passed test Replications
      Starting test: NCSecDesc
         ......................... SDEMSAD passed test NCSecDesc
      Starting test: NetLogons
         ......................... SDEMSAD passed test NetLogons
      Starting test: Advertising
         ......................... SDEMSAD passed test Advertising
      Starting test: KnowsOfRoleHolders
         ......................... SDEMSAD passed test KnowsOfRoleHolders
      Starting test: RidManager
         ......................... SDEMSAD passed test RidManager
      Starting test: MachineAccount
         ......................... SDEMSAD passed test MachineAccount
      Starting test: Services
         ......................... SDEMSAD passed test Services
      Starting test: ObjectsReplicated
         ......................... SDEMSAD passed test ObjectsReplicated
      Starting test: frssysvol
         ......................... SDEMSAD passed test frssysvol
      Starting test: frsevent
         ......................... SDEMSAD passed test frsevent
      Starting test: kccevent
         ......................... SDEMSAD passed test kccevent
      Starting test: systemlog
         ......................... SDEMSAD passed test systemlog
      Starting test: VerifyReferences
         ......................... SDEMSAD passed test VerifyReferences
   
   Running partition tests on : ForestDnsZones
      Starting test: CrossRefValidation
         ......................... ForestDnsZones passed test CrossRefValidation
      Starting test: CheckSDRefDom
         ......................... ForestDnsZones passed test CheckSDRefDom
   
   Running partition tests on : DomainDnsZones
      Starting test: CrossRefValidation
         ......................... DomainDnsZones passed test CrossRefValidation
      Starting test: CheckSDRefDom
         ......................... DomainDnsZones passed test CheckSDRefDom
   
   Running partition tests on : Schema
      Starting test: CrossRefValidation
         ......................... Schema passed test CrossRefValidation
      Starting test: CheckSDRefDom
         ......................... Schema passed test CheckSDRefDom
   
   Running partition tests on : Configuration
      Starting test: CrossRefValidation
         ......................... Configuration passed test CrossRefValidation
      Starting test: CheckSDRefDom
         ......................... Configuration passed test CheckSDRefDom
   
   Running partition tests on : renov
      Starting test: CrossRefValidation
         ......................... renov passed test CrossRefValidation
      Starting test: CheckSDRefDom
         ......................... renov passed test CheckSDRefDom
   
   Running enterprise tests on : renov.local
      Starting test: Intersite
         ......................... renov.local passed test Intersite
      Starting test: FsmoCheck
         ......................... renov.local passed test FsmoCheck
0
 
LVL 4

Assisted Solution

by:san_swa
san_swa earned 800 total points
ID: 16860190
Server which freezes every morning, does it have a DC and GC in the near vicinity?
If yes, when the problem occurs...did you check if Directory Access tab shows all the DC\GC and Config GC's?
Also, it is not clear what do you do when the server freezes? Do you just restart or does it start on its own?
Backup time is scheduled at 8 PM....when does it finish....what type of backup do you take? Full/Incremental/differential?
When was the last successful full backup taken?
0
 

Author Comment

by:ulensr
ID: 16868880
Hi San Swa,

the server doesn't really freeze like if windows or the hardware freezes, it just stops local delivery and then slowly people are no longer able to connect.

There is a domain controller in the same subnet yes and when I check now, the DC/GC and Config GC is visible.

When the server "freezes", we reboot it and everything works again.

Backup finishes at 9PM and the last full backup was last sunday, incremental backup for some reason doesn't work.

We get Backup Exec failure : Final error: 0xe000fed1 - A failure occurred querying the Writer status.

But weekly full backup works. We do Sunday full backup, during week daily incremental.
0
 

Author Comment

by:ulensr
ID: 16869540
I think I might have isolated the problem:

1) It is related to the incremental backup which fails every night. This will proof next week because I have set the backup to daily full, which never fails.

2) It is related to this strange Exchange error I sometimes receive which locks out just a few users:

Event Type: Error
Event Source: MSExchangeIS
Event Category: General
Event ID: 9646
Computer: SDEMSEXCHANGE
Description:
Mapi session "0078-zoih-87ji-897jnju-lpl90098-008" exceeded
the maximum of 32 objects of type "session".

If the error is related to the latter, then I guess I need to concentrate on resolving this problem. Any ideas about this one ?

Thanks again


0
 

Author Comment

by:ulensr
ID: 16910143
I have split the point because both experts pushed me toward checking the backup and changing to full backup daily solved all my problems.

Thanks all

!!!
0
 

Expert Comment

by:disax
ID: 20356221
sadfasd
0

Featured Post

Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you discover the power of the R programming language, you are going to wonder how you ever lived without it! Learn why the language merits a place in your programming arsenal.
Today as you open your Outlook, you witness an error message: “Outlook is using an old copy of your Outlook Data File…”. Probably, Outlook is accessing an old OST file.
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …
Suggested Courses

872 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question