[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 631
  • Last Modified:

Bringing up eth0

Hi when my linux starts up (in verbose mode)

When it gets to "bringing up eth0" and "bringing up eth1"

It hangs for about 20 seconds before failing, how can i stop this

Im using mandiva 10

Thanks

0
bryanchellen
Asked:
bryanchellen
1 Solution
 
adi_vladutCommented:
It fail with what error?
Try to replace or deactivate the ethernet card that generate the failure.
0
 
pjedmondCommented:
You can either rectify the source of the error. If the ethernet connection is not connected and it is configured to get it's details by DHCP, then it will wait until it times out.

In /etc/sysconfig/network-scripts/ifcfg-eth0 (and ifcfg-eth1) you probably have an entry like:

BOOTPROTO=dhcp

If it said 'static', then there would be additional entries relating to the configuration of the eth interface, and you wouldn't have the timeout associated with DHCP which is causing your current delays.

As this problem is on boot, you can either enter an additional line in these files:

ONBOOT=no

(or change the current line to be no rather than yes). This will stop the ethernet starting at boottime, and you will have to enable then manually later:

ifconfig eth0 up

man ifconfig for more details.....or /etc/init.d/network restart (depending on linux distro)

HTH:)
0
 
mass2612Commented:
It sounds like the adapters are trying to find a DHCP server. If there is no DHCP server then you may want to stop the dhcpcd daemon or configure the nics for a static ip.
0
 
spm_clCommented:
Hi,

Without any more information, I would suppose that eth0 and eth1 are configured with DHCP. When the interface is brought up it has no IP address and broadcasts messages hoping that a DHCP server will respond to. It waits for a given timeout and if it has received no response, it just brings up the interface with a "default" IP address.

I've never used mandriva linux myself so I don't know where the configuration files are. On Debian based distributions it is in /etc/network/interfaces. Change the interface type from "dhcp" to "static" and add the address, netmask, and gatweway lines, and your done.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now