• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 331
  • Last Modified:

How to send a mail with plain text using character set ISO-8859-1

hi,

we use a self written form sending a very simple mail to the internet.
it is verya important that the body text is sent as plain text.
this all works fine with r5.

now after migrating to r6 the sent text is not readable at all.
it looks like rubish.

when sening a mail using the standard mailfile the notes client ask me if i want to
use character set UTF8 or ISO-8859-1.

using ISO-8859-1 will bring the needed result.

now my question is: how can i implement in the self written form that this mail should be "converted" to character set ISO-8859-1 ?

any ideas?


thanks
hreinart
0
hreinart
Asked:
hreinart
  • 3
  • 2
2 Solutions
 
SysExpertCommented:
It ma not be possible.

I would simply send out an email with both character sets, to yourself, and see what fields are different.

Those are the ones that need to be modified.

I hope this helps !
0
 
marilyngCommented:
hreinart,

Have you tried setting the preferences in your mail file:  File>>Preferences>>User Preferences>>Click on the Mail tab to expand it, then click on Internet Mail, then change the Internet Mail Format to "Plain Text Only"
0
 
hreinartAuthor Commented:
marilyng
hi, nice to hear from you again.

yes i've tried it.
on my notes client it works well.
i send mails directly via smtp to my provider.

the problem is that they send this out using their domino server.
so it might also be a question of character sets used/defined on the server.

i think that specifying "use allways plain text" is not suitable because html mails etc. will not be possible anymore.

i found sofar this, but i have no idea if it'S the right way to go at all (and how i could do it):

- SetContentFromText method
- charset property
- addValText method

in the end a simple mail needs to be sent out that should use this charset: Content-Type: text/plain; charset="ISO-8859-1"


any idea how to enable this?


thanks
harald

0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
marilyngCommented:
Oops, so sorry, I must have missed the message with your last note in it.

There are two places in the NAB where you can configure outbound messaging options:

NAB>>Messaging>>Configuration Document for Server.
Server>>Mime>>Outbound

and Settings by Character Set Groups
and Advanced Outbound Message Options

But, this will only set it globally, and not do the SetContentFromtext. Is that what you're looking for?  I'm not seeing the specific character set, the Mime Outbound you can set to Text and see if that works.

Then if not, set the Advanced Outbound Options and declare your own alias.

Never tried this before, so I'm guessing... ?:)
0
 
hreinartAuthor Commented:
marilyng,

i'll pass this information to the admin to see if they can set these options and try it.
i also have no idea if this works.

it looks like that this topic is more complicated than i assumed.
0
 
hreinartAuthor Commented:
i did not get a feedback yet.

from my point of view the problem is still open, but splitting might be the right way to go.
i'm fine with any suggestion.



thanks
harald
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now