Crystal XI: Failed to open Connection, Database Vendor Code: 17

Hi,

I am on the verge of pulling my hair off on this one. I've got web reports built on Crystal XI and they work absolutely fine on my Windows XP machine. I now transfer the web application to my Windows 2003 Enterprise Production Server and the web application is still running fine except all my reports keep giving the following error:

Failed to open the connection. Details: [Database Vendor Code: 17 ]
Failed to open the connection. C:\WINDOWS\TEMP\{ADB8090C-40ED-499D-88E3-915E23B0C5C3}.rpt Details: [Database Vendor Code: 17 ]

I have the latest service packs for crystal & windows. The Business Objects website doesn't talk about this error.

Anybody who can help?

Thanks,
Irfan.
netfreak99Asked:
Who is Participating?
 
wsinvConnect With a Mentor Commented:
Try changing the database connection for the report.

Log onto the CMC as administrator.

Select Objects

Select the report object and click on it to see the report properties.

Go to the process tab and define your database connection for the report.

Good Luck.

wsinv
0
 
wykabryanConnect With a Mentor Commented:
Is the enterprise server application a custom built or BOE Enterprise?

Are you using any store procs in a subreport?

0
 
netfreak99Author Commented:
Hi wykabryan,

The Enterprise server is the standard Windows 2003 Enterprise Edition. I am not using any stored procedures for a subreport. I am using Views for the main report and the sub report in it.

Please help.

Thanks,
Irfan.
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
netfreak99Author Commented:
Hi wsinv,

CMC = Computer Management Console????

I think you know the answer to this problem it's just that I am unable to understand the direction you are guiding me to. Kindly, elaborate. This would immensely immensely help me and I've been very frustrated with this problem.

Thanks,
IRfan.
0
 
wsinvCommented:
The CMC is the Central Management Console for Crystal XI. My URL is http://servername/businessobjects/enterprise11/admin/en/admin.cwr

Replace servername with your Crysyal Reports Server Name.

Log on as administrator and follow the instructions above.

wsinv
0
 
wykabryanCommented:
Yes, also make sure the ODBC connection is set up on the server in the ODBC management area of the Control Panel.  It addition to having it set up on the CMC.
0
 
netfreak99Author Commented:
Hi wsinv,

When I run the URL with the servername replaced with my servername, it comes up with a 404. I don't think I have CMC installed on my server. What I have installed on the Windows 2003 machine is a Crystal Developer Full version 11.0.0.1994.

I am not using an ODBC connection or a DSN. My connection string is stored in the WEB.CONFIG file of my application and all I do to open up the report is the following:

 Dim logonInfo As New TableLogOnInfo
        Dim table As Table

        ' Set the logon information for each table.
        For Each table In rptTimesheet.Database.Tables
            ' Get the TableLogOnInfo object.
            logonInfo = table.LogOnInfo
            ' Set the server or ODBC data source name, database name, user ID, and password.
            With logonInfo.ConnectionInfo
                .ServerName = userver
                .DatabaseName = udatabase
                .UserID = uid
                .Password = upassword
            End With
            ' Apply the connection information to the table.
            table.ApplyLogOnInfo(logonInfo)
        Next table
        Crystalreportviewer1.ReportSource = rptTimesheet
        CurrentReport = rptTimesheet

And this works absolutely fine on my Windows XP machine.
Thanks,
Irfan.
0
 
wykabryanCommented:
So everything is the same between the two environments.  The last thing to check is the permission assigned to the folders.  
0
 
wsinvCommented:
I found a simular post here  http://www.experts-exchange.com/Databases/Crystal_Reports/Q_21733415.html

Hope that points you in the general direction...

wsinv
0
 
netfreak99Author Commented:
Hi All,

Thanks for all the help guys, one stupid MONTHLY HOT FIX by crystal fixed the problem.

Thanks,
Irfan.
0
 
Shayju_kasimCommented:
Hi can u provide some information about the hot fix. From where can we download it
0
 
marcporlierCommented:
Shayju,

This may be too late to be helpful, but if anyone is looking for Crystal Report Hot Fixes and Service Pack downloads, they can be found here:

https://www.sdn.sap.com/irj/boc/downloads

Marc
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.