• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 7857
  • Last Modified:

Interactive Logon message text syntax

I am trying to edit our security banner in Group Policy Managment under the default domain policy.  Whatever I type in, it doesn't recognize any tabbing or paragraph spacing.  What do I have to do to get this to recognize paragraphing and carriage returns.  I have a windows 2003 Domain controller and we use XP desktops.  I have tried creating the message on a Windows 2003 Server and on an XP desktop with the same results.  Any help would be appreciated.
0
sst01
Asked:
sst01
  • 4
  • 3
  • 2
  • +2
1 Solution
 
TheCleanerCommented:
0
 
Keith AlabasterCommented:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurentVersion\Winlogon
This gives access to the text box but you will not be able to use tabs etc. You have to use spaces and carriage returns to lay it out. As I recall you can only have three or four lines maximum. I think Group Policy has its own location but I am not sure.
0
 
TheCleanerCommented:
yeah keith, the GPO setting is under computer config, windows settings, security settings, local policies, security options.

There it shows as a full text window where you can tab, return, etc.

I believe the default limit is 512 characters IIRC.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
sst01Author Commented:
I know where to set the message and even when manually typing it in it doesn't recognize spacing if its the start of a line and if you use a carriage return to put a line space in it automatically takes it out.  Here is an example:

I type the following:

Warning!

This system blah blah blah

More text here
· this that and the other
· some more text here that
  spills onto the next line
· More text here

This becomes:

Warning!
This system blah blah blah
More text here
· this that and the other
· some more text here that
spills onto the next line
· More text here

Any ideas would be greatly appreciated.  I tried copy/paste and manually typing from a windwos 2003 server and an XP pro pc and get the same results each time.

Thanks!
0
 
Keith AlabasterCommented:
Thanks Cleaner :)
0
 
TheCleanerCommented:
You can create a blank line by hitting enter, then 1 space, then enter again.  There has to be a "character" on each line basically.

As far as a space at the beginning of a line of text, I don't think that's possible...
0
 
sst01Author Commented:
Hi,

Tried adding a space on the line then hitting enter.  after hitting apply/ok it truncated everything after the space I created.  Any more ideas?

Thanks!
0
 
TheCleanerCommented:
Not sure then...it works fine for me...here's what I did:

1.  Remote into a DC
2.  Open GPMC
3.  Create test GPO
4.  Go to the interactive logon text setting
5.  Open the setting (get the big box)
6.  Typed "test" on the first line
7.  Hit enter
8.  Hit space once
9.  Hit enter
10.  Typed "testing again"
11.  Hit apply

It then showed it correctly, and I hit OK.  Applied it to a test OU with test computer.  Went to that computer and rebooted.  Worked fine.
0
 
Keith AlabasterCommented:
Ditto. No problem here.
0
 
odom1846Commented:
This question was not answered correctly. The correct solution to this is to edit the file manually with Notepad. This file is located here: \\DOMAIN.local\SYSVOL\DOMAIN.local\Policies\{GPO-GUID}\MACHINE\Microsoft\Windows NT\SecEdit\GptTmpl.inf
Wherever you want to break the line and leave an empty space you need to end the sentence with a comma then type " " and then another comma to start the next sentence. If you edit the GPO through GP edit the changes will be reverted. Example:
to leave a space between these two phrases:
The big red dog

jumps very high
would look like this in the notepad file.
The big red dog," ", jumps very high.
This question has not been answered correctly on many websites and forums except for one that I have to give credit to. This is a major annoyance and not many IT companies have resolved it. This solution is true for windows server 2003 , sp1, R2 etc. and is a known bug that microsoft does not mention. I hope this helps someone.
Thanks to  Jakob H. Heidelberg and his solution at http://heidelbergit.blogspot.com/2007/12/formatting-text-for-users-attempting-to.html
1
 
XTSIncCommented:
I agree with odom1846, that is the proper solution until it is fixed in the GPEDIT gui.
0

Featured Post

Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

  • 4
  • 3
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now