How can I get Task Scheduler to Allow My Pop Up?

I have a task scheduler that opens a .vbs file, which does open my first web page.

That page then needs to open a pop up, which works fine if I just open the first page in IE, however
when I run it from the .vbs file in Task Scheduler it blocks the pop up.

IE is set to allow pop ups from this site.
LVL 1
net_susanAsked:
Who is Participating?
 
Rich RumbleConnect With a Mentor Security SamuraiCommented:
Does the VBS open IE, but block the pop-up window? Is the scheduled task using your username/pass to run, or is it using the system account in the scheduled task?
On most sytems you can open a command prompt and type
"at \\127.0.01" to see detail about scheduled tasks (that's on a local machine) you can also type "at \\PC_name" to remotely query a remote pc by name or IP
You may also try on the local machine from a cmd prompt:
schtasks.exe /query /V /FO list

To list the details of your task quickly.
-rich
0
 
r-kConnect With a Mentor Commented:
"IE is set to allow pop ups from this site"

I think this is happening because the "allow pop-ups" option is set on a per-user basis.

I would guess that the Task Scheduler is running under a different account, and pop-ups are not allowed for that account. If you log-in as that user, and allow pop-ups, that should fix the problem.
0
 
net_susanAuthor Commented:
It's the same account.

Maybe I didn't do it right. Is there a way to make IE actually open? Right now it doesn't visably open.

The pop up is

onload=window.open('http://www.

etc.
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
net_susanAuthor Commented:
Actually, I guess I enabled the popup through the Google toolbar.
0
 
r-kConnect With a Mentor Commented:
Does it mean it's working now?

Another test you can try is to Schedule IE directly first. If that works, then schedule your script next to narrow it down a bit.
0
 
net_susanAuthor Commented:
No, it's not working now.

I can schedule IE directly.
0
 
Rich RumbleConnect With a Mentor Security SamuraiCommented:
As a work-around solution, you can have IE point to an hta file and see if that works... there are additional restrictions on IE in XP SP2 that might be hindering you. Your scheduled task can even run an HTA to open IE for you...

https://www.microsoft.com/technet/scriptcenter/hubs/htas.mspx  https://www.microsoft.com/downloads/details.aspx?FamilyId=231D8143-F21B-4707-B583-AE7B9152E6D9&displaylang=en
http://msdn.microsoft.com/workshop/author/hta/overview/htaoverview.asp

http://www.irt.org/articles/js191/index.htm (making a web-browser using an HTA)
http://www.webmasterworld.com/forum91/4815.htm
-rich
0
 
net_susanAuthor Commented:
Yeah, when I put this in the task scheduler, it worked:

C:\PROGRA~1\INTERN~1\IEXPLORE.EXE "http://www.mypage.aspx"
0
 
net_susanAuthor Commented:
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.