Mapping drives to or from a XPPro ceased working one day, works using TCP-IP address

Posted on 2006-06-08
Last Modified: 2010-03-18
The short question: My worklaptop is suddenly unable to do share drives (sharing out to others or sharing others have mapped) if I just use the hostname. It worked fine, then one day (it gets rebooted often) all share attempts fail with Network path not found or Error 53 (depending on which command I use to map). Also I notice when looking for a share with the GUI browse tool it only sees itself on the Window network.

The Long background info:
Laptop problem machine: WinXP Pro SP2 (windows Autoupdate running, I usully accept fixes from MS). Network is "standard" as after a normal install, ie TCPIP, MSnetClient, MS FileShare. There is both a wireless and a LAN interface, and the problem is identical whichever I use. (Also modem, Bluetooth, IR, but they're not in use)

Before the misery started, the laptop travels between work and home and a few CT sites, usually set up with DHCP on the wireless connection. At home I have (my own) WinXP Home machine which shares out som directories and the printer. The ADSL router w/wireless does the DHCP. Laptop home, shares appear, printouts work. At work a similar situation.

Then one day after a forced shutdown the laptop refuses to map to the home machine. The same with the machines at work. Substituting the ip-address makes things work again. That is OK when I map to stationary machines, but anything that is DHCP based does of course change its address, which is why I prefer to use the node/machine names.

I also have VMWare installed and I need to map drives between the hostlaptop and the virtual machines.

Just to reiterate: This has all worked. I have not (consiously) made any change to the network configuration.

So what have I tried? Pull my hair, scream, cry... I have compared my network setting with well working machines. I have compared services that are running. I have verified that itis my laptop that is the problem, and not everybody else. I have browsed MS-site, Googled and read about 20 posts here on EE. I have tried "netsh" to reset/rebuild the winsock registry. The probelm is the same on the LAN and the wireless connection. I have asked knowledgable colleagies - we tried varying the "simple network share", all 3 variations of NetBios over TCP/IP, flushing IP, DNS and whatnot chaches....

I have one very drastic option left - revert to a saved image (we use Ghost to backup the laptops against loss, theft and cosmic rays).
Question by:Msquare
    LVL 48

    Accepted Solution

    Hi Msquare,

    have a look at this it may be relevant, its not the link i was looking for but have a check

    here it is
    LVL 2

    Author Comment

    WoW - that was just the ticket (the 2nd link) ! It works!

    I dont understand at all why it "flipped" into the peer-to.-peer network mode, but "ours is not to question why", we just do the MS magic chant with regedit.

    Thank you.
    LVL 48

    Expert Comment

    not a problem

    Featured Post

    Top 6 Sources for Identifying Threat Actor TTPs

    Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

    Join & Write a Comment

    Have you ever set up your wireless router at home or in the office to find that you little pop-up bubble in the bottom right-hand corner of Windows read "IP Conflict - One of more computers on the network have been assigned the following IP address"…
    Are you one of those front-line IT Service Desk staff fielding calls, replying to emails, all-the-while working to resolve end-user technological nightmares? I am! That's why I have put together this brief overview of tools and techniques I use in o…
    Migrating to Microsoft Office 365 is becoming increasingly popular for organizations both large and small. If you have made the leap to Microsoft’s cloud platform, you know that you will need to create a corporate email signature for your Office 365…
    Sending a Secure fax is easy with eFax Corporate ( First, Just open a new email message.  In the To field, type your recipient's fax number You can even send a secure international fax — just include t…

    754 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    22 Experts available now in Live!

    Get 1:1 Help Now