Solved

Cisco Pix 501 to Pix 501 site to site vpn config files

Posted on 2006-06-08
1
436 Views
Last Modified: 2013-11-16
Hello, and thanks in advance Experts.

I'm a J2EE programmer who's also the Sys Admin for a small firm (which is probably the root of my problem).  We've got two offices between which I'm trying to set up a site to site vpn connection using 2 PIX 501 appliances.  Both offices use Comcast as their ISP, so the PIXs each sit behind a Comcast router/modem in the DMZ and act as the gateway for their respective internal networks (HQ and Satellite). The network looks like this:

       (HQ)                      In     (PIX)    Out                 In  (Modem) Out        INET         Out (Modem)  In               Out     (PIX)     In                 (Satellite)
  [192.168.5.0] -- [[192.168.5.1]-[10.1.10.10]] -- [[10.1.10.1]-[4.5.6.7]] -- ((=)) -- [[1.2.3.4]-[10.1.10.1]] -- [[10.1.10.10]-[192.168.1.1]] -- [192.168.1.0]

Naturally, I can't get it to work.  I specifically joined this site to look through all of the other solutions for similar issues, but none of them seem to increase my ability to grok this problem.

Could someone please look through the config files below and offer some advice, or just plain out tell me what I need to fix?  I'll gladly bankrupt my points if somebody can help me with this.  Thanks.

================
            HQ Config
================

Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password bddYvmtpNxIoIQ8W encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pixfirewall
domain-name something.net
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list echopermit permit ip 192.168.5.0 255.255.255.0 192.168.155.0 255.255.255.0
access-list echopermit permit ip 192.168.5.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list echo_split permit ip 192.168.5.0 255.255.255.0 192.168.155.0 255.255.255.0
access-list echo_csnet permit ip 192.168.5.0 255.255.255.0 192.168.1.0 255.255.255.0
pager lines 24
icmp permit any echo-reply outside
icmp permit any echo inside
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute
ip address inside 192.168.5.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool EGRemote 192.168.155.1-192.168.155.50
pdm location 192.168.155.0 255.255.255.0 outside
pdm location 192.168.5.0 255.255.255.0 inside
pdm location 192.168.1.0 255.255.255.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list echopermit
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 192.168.1.0 255.255.255.0 70.89.37.85 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
ntp server 67.128.71.75 source outside
http server enable
http 192.168.5.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set echoset esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 10 set transform-set echoset
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map echomap 10 ipsec-isakmp
crypto map echomap 10 match address echo_csnet
crypto map echomap 10 set peer 1.2.3.4
crypto map echomap 10 set transform-set echoset
crypto map echomap 20 ipsec-isakmp dynamic outside_dyn_map
crypto map echomap interface outside
isakmp enable outside
isakmp key ******** address 1.2.3.4 netmask 255.255.255.255
isakmp identity address
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup EchoGroup address-pool EGRemote
vpngroup EchoGroup default-domain something.net
vpngroup EchoGroup split-tunnel echo_split
vpngroup EchoGroup idle-time 1800
vpngroup EchoGroup password ********
telnet timeout 5
ssh 192.168.5.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
username ****** password hj7X6lJU.qoHeNAm encrypted privilege 15
terminal width 80


================
    Satellite Config
================

Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password iaVhHwRbERz3GUsj encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list csnetpermit permit ip 192.168.1.0 255.255.255.0 192.168.195.0 255.255.255.0
access-list csnetpermit permit ip 192.168.1.0 255.255.255.0 192.168.5.0 255.255.255.0
access-list csnet_split permit ip 192.168.1.0 255.255.255.0 192.168.195.0 255.255.255.0
access-list csnet_echo permit ip 192.168.1.0 255.255.255.0 192.168.5.0 255.255.255.0
pager lines 24
icmp permit any echo-reply outside
icmp permit any echo inside
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool CSNetRemote 192.168.195.1-192.168.195.50
pdm location 192.168.5.0 255.255.255.0 outside
pdm location 192.168.195.0 255.255.255.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list csnetpermit
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 192.168.5.0 255.255.255.0 4.5.6.7 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set csset esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 10 set transform-set csset
crypto map csmap 10 ipsec-isakmp
crypto map csmap 10 match address csnet_echo
crypto map csmap 10 set peer 4.5.6.7
crypto map csmap 10 set transform-set csset
crypto map csmap 20 ipsec-isakmp dynamic outside_dyn_map
crypto map csmap interface outside
isakmp enable outside
isakmp key ******** address 4.5.6.7 netmask 255.255.255.255
isakmp identity address
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup CSNet address-pool CSNetRemote
vpngroup CSNet split-tunnel csnet_split
vpngroup CSNet idle-time 1800
vpngroup CSNet password ********
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.50-192.168.1.75 inside
dhcpd dns 22.33.44.55 22.33.44.56
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
username ****** password poM/q8AlZmxsJazI encrypted privilege 15
terminal width 80
0
Comment
Question by:ebellinger
1 Comment
 
LVL 9

Accepted Solution

by:
stressedout2004 earned 500 total points
ID: 16867042
1) On the VPN configuration side, it is perfect. Just disable the following static route because they are not needed:

HQ PIX:

no route outside 192.168.1.0 255.255.255.0 70.89.37.85

Satellite PIX:

no route outside 192.168.5.0 255.255.255.0 4.5.6.7

2) Now on the WAN connection, based on your description and  diagram, each site is behind a comcast router and is getting IP via DHCP. Now in order to make this work, you need to be getting a public IP address on each PIX and not a private one. If you do a "sh ip address" on each PIX, HQ PIX should show 4.5.6.7 and the Satellite PIX should be showing 1.2.3.4, if you are getting a private one then you need to change the comcast configuration such that it operates in bridge mode. If your ISP has control over it, then have them change it.

0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Cisco VPN client v5 migration to Anyconnect VPN? 8 52
cisco 2800 cannot ping lan 4 23
cisco switch 3750E port channel down 13 29
Cisco Router Security Commands. 2 31
This article will cover setting up redundant ISPs for outbound connectivity on an ASA 5510 (although the same should work on the 5520s and up as well).  It’s important to note that this covers outbound connectivity only.  The ASA does not have built…
To setup a SonicWALL for policy based routing to be used with the Websense Content Gateway there are several steps that need to be completed. Below is a rough guide for accomplishing this. One thing of note is this guide is intended to assist in the…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question