• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 538
  • Last Modified:

How to unshare wwwrooot

Hello.  I have "web-shared" my "wwwroot" directory.  I can't seem to "unshare" it, though.  It continues to revert to "share".  I can unshare all my other folders, but not "wwwroot".

Please help.

Thank you,
Shane
0
lshane
Asked:
lshane
  • 4
  • 2
2 Solutions
 
ZungeryCommented:
I believe wwwroot is the default directory for IIS and other HTTPD's to have your virtual site stored. If you are running a HTTPD that could possibly be the reason. To test this, change the directory in which your website is stored, reboot IIS / the machine, and try and unshare. After that check to see if the new directory you changed it to is being shared. If it is, there may be an option within the HTTPD to turn that off.
0
 
b0lsc0ttIT ManagerCommented:
lshane,

I am not sure that I understand what you mean by "web-shared."  If you mean that you have IIS running and http://localhost in your browser responds with pages and will run scripts then you can stop IIS to fix that.  Internet Information Services (IIS) is found in the Services area in Administrative Tools or Computer Management.  It can be stopped from there as well.

If I misunderstood your question then please clarify it.  If you need more information or details about the information above then please let me know.

b0lsc0tt
0
 
lshaneAuthor Commented:
Hi.  Yes I have XP Pro and I installed IIS.  For various reasons, I tried to "Web-share" the directoris of:  Inetpub, wwwroot, and my site directory.

If you right-click on the folder and select "properties", there are 4 choices:  General, Share, Web-Share, and Customize.  I selected "web-share" and then selected the option to "Share This Folder".  I did that for all the above-listed directories.  I then needed to "unshare" all of them.  I could unshare "Inetpub" and my own site directory listed underneath "wwwroot", HOWEVER, I could not unshare "wwwroot".  I right-clicked the "wwwroot" folder and selected "properties".  I then selected the "web-share" tab and tried to select "Do not share this folder" (as I did for the other 2), but it reverted to "Share this folder".  I rebooted the PC and tried again, but had the same problem.

Hopefully this will provide a little clarity.

Thank you so much,
Shane
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
lshaneAuthor Commented:
Well, I uninstalled the IIS components, rebooted, and reinstalled.  Then, I copied my site directory back to "wwwroot", and all is accessible now.

Now I have another issue of uploading an image and inserting the path into the database.  The image uploads and creates a folder with its part number, but the data from the form is not being inserted in the database.

This is another issue, however, so I will post another thread.

Thanks for your input.

I'll split points for you.

Shane
0
 
lshaneAuthor Commented:
Sorry, I inadvertently just opted to "Accept".  I apologize.  I don't know how to reverse that.
0
 
lshaneAuthor Commented:
Thank you.
0
 
b0lsc0ttIT ManagerCommented:
Thanks for the extra effort to split the points.  I'm glad I was able to help and nice to see it appreciated.  Thank you for the grade, the points and the fun question.

bol
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now