• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2710
  • Last Modified:

Multiple VLAN Port Config for for Cisco IP Phone connected to non Cisco Switch

I have a Cisco Catalyst 3560 switch in the main building and a Linksys SRW224P POE/Qos/Multi-VLAN switch in a 2nd building.  They are connected using a 1Gb/s .1Q trunk.

In the main building the ports are configured to suit Cisco IP phones with data on VLAN1 and Voice on VLAN2.  PCs are connected to the Switch on the phone and both data and voice are connected to the Catalyst switch via a single cable.

VLAN1 DHCP is from a local DHCP server.  VLAN2 (Phone) DHCP is from a remote location via a T1 line.

I cannot configure the Linksys ports to operate with Voice and data VLANs on the same port.  I currently have the ports configured as access for either VLAN1 or VLAN2.  Thus I can only use a port for either voice or data but not both simultaneously which means I that each phone location requires two cables connecting back to the switch.

From what I’ve read the basic problem is that the Linksys switches do not support Cisco CDP protocol although I can’t quite understand why this results in this problem. The phones are properly configured on power-up and perform perfectly well despite the switch not supporting CDP.

Is there any way to configure the Linksys switch to enable voice and data together from the Cisco IP Phone?
0
ianmal2
Asked:
ianmal2
2 Solutions
 
tomerleiCommented:
Basicly you can't fit 2 vlans in the same port unless they are tagged, and i don't belive that your VoIP phones support 802.1q frames.
My best idea is that because of that you used to connect it to a cisco switch that has the Cisco Discovery Protocol (CDP) it made it somehow adapt to the situation and it worked.

Another option is that your phone support tagging, and for some reason the ports on the linksys aren't configured well to suit it, from what i read the linksys supports 802.1q so there should be no problem.
0
 
nderryberryCommented:
Cisco voip phones all support 802.1q vlan tagging.. you need to set the connection between the linksys and the phone as a .1q trunk as well.  The phone is then configured to pass vlan 1 untagged to the pc and grab vlan 2 for the phone itself.
0
 
ianmal2Author Commented:
The problem is solved. tomerlei and nderryberry you are basically correct.  I set the Linksys phone ports to General which allows tagged and untagged packets with VLAN1 as native.  Set up a VLAN2 as voice and Tagged.  VLAN1 is set as untagged.  Works a treat.  Now I can connect Linksys POE port to Phone and PC to phone.

Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Become an IT Security Management Expert

In today’s fast-paced, digitally transformed world of business, the need to protect network data and ensure cloud privacy has never been greater. With a B.S. in Network Operations and Security, you can get the credentials it takes to become an IT security management expert.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now