Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

DHCP clients not registering in DNS

Posted on 2006-06-09
15
Medium Priority
?
527 Views
Last Modified: 2010-05-19
Hi,

Got a wierd problem in DNS thats driving me road the bend. I have users (all XP) in two sites authenticating from two diferent subnets to an AD DNS server. The clients in the remote site appear in DNS ok, the clients in the local site dont, (expect one!). IPconfig /all shows that the DNS suffix is registered correctly for thelocal users, ive tried clearing the cache, deleting and recreating the DNS zone, check all firewall settings but I cant figure out why it wont pass the details from DHCp to DNS.

Any ideas?
0
Comment
Question by:roadkill100
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 3
  • +3
15 Comments
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 16868712
Hi roadkill100,

uner the advanced options of your client tcpip properties, under dns, make sure the register this connection is dns tickbox is ticked
0
 

Author Comment

by:roadkill100
ID: 16868763
hiya,

yes it is. so is:
Append Primary and connection spefici DNS suffixes
Append Parent suffixe of the primary DNS
Use this connections DNS suffix in DNS registration
0
 
LVL 29

Expert Comment

by:mass2612
ID: 16868790
Do you recieve any error messages if you run ipconfig /registerdns from the client? Are there any events in the logs on the client or DNS server?
0
Fill in the form and get your FREE NFR key NOW!

Veeam® is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 

Author Comment

by:roadkill100
ID: 16868834
no error messages, nothing. the zone name is xxxxxxxx-xxxx.local and it reloads ok without any problems.
0
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 16869794
nothing different in the scopes that have been setup at all? if you restart your netlogon service on the DC does it populate?
0
 
LVL 51

Expert Comment

by:Netman66
ID: 16870157
Check the DHCP Client service on a workstation that isn't registering (you'll find that in Services) - it must be running.



0
 

Author Comment

by:roadkill100
ID: 16870196
yeah tried both of those. its a wierd one and im convinced its server based as no changes have been made to the user systems.
0
 
LVL 51

Expert Comment

by:Netman66
ID: 16870634
Did the SP1 firewall on the server somehow get enabled?

0
 

Author Comment

by:roadkill100
ID: 16870696
nope, its still disabled.
0
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 16870720
very strange problem, glad someone else jumped in as i am stumped!
0
 
LVL 51

Expert Comment

by:Netman66
ID: 16871509
I want you to enable Userenv debug mode on one (1) client that is not registering.  Before doing this, clear all logs.

http://support.microsoft.com/default.aspx?scid=kb;EN-US;221833

After one reboot and a logon, stop the debugging and reboot.

The logfile we are after is here:  %Systemroot%\Debug\UserMode\Userenv.log

Post only the sections that show us errors relating to this problem.  This log is huge, so be patient.

0
 

Author Comment

by:roadkill100
ID: 16886169
solved it. one of the other DC's wasnt replicating its info across to the named server list. Switche dit on and all ok now.
0
 

Expert Comment

by:khuiwong
ID: 16996492
roadkill100,

I have the same problem.  Can you help me how to check and see if one of my DC is replicating to the named server?  And how do you switch it on.

Thank so much.
0
 

Accepted Solution

by:
CetusMOD earned 0 total points
ID: 17206757
PAQed with points refunded (500)

CetusMOD
Community Support Moderator
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

So you have two Windows Servers and you have a directory/folder/files on one that you'd like to mirror to the other?  You don't really want to deal with DFS or a 3rd party solution like Doubletake. You can use Robocopy from the Windows Server 200…
Scenerio: You have a server running Server 2003 and have applied a retail pack of Terminal Server Licenses.  You want to change servers or your server has crashed and you need to reapply the Terminal Server Licenses. When you enter the 16-digit lic…
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …
This lesson discusses how to use a Mainform + Subforms in Microsoft Access to find and enter data for payments on orders. The sample data comes from a custom shop that builds and sells movable storage structures that are delivered to your property. …
Suggested Courses

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question