Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

dotnetfx.exe stops on win2k server setup

Posted on 2006-06-09
44
Medium Priority
?
3,340 Views
Last Modified: 2012-06-21
I downloaded dotnetfx.exe because something (i forget what now) required it, I think it was windows update.

I run it, and it starts going through the install sequence.

Then it stops here: http://www.yoimg.com/h/21280742-dotnetfx-problem.jpg.html

I have left this screen like this for 24 hours, it has not moved.

This is a fresh install of windows.

Any ideas why its doing this?
0
Comment
Question by:HM2K
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 18
  • 15
  • 4
  • +4
44 Comments
 
LVL 13

Expert Comment

by:Kini pradeep
ID: 16872280
any errors reported in the eventviewer ?
what is the role of the machine ?
what is the sp level ?
0
 
LVL 3

Author Comment

by:HM2K
ID: 16872910
There are no errors reported in the event viewer

The role of this machine will be a server, I haven't setup any server aspects yet.

It is SP4.
0
 
LVL 13

Expert Comment

by:Kini pradeep
ID: 16874057
what is the version of windows installer,
http://support.microsoft.com/?id=893803
its recomended to have 3.1 for .net 2.0
0
Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

 
LVL 3

Author Comment

by:HM2K
ID: 16876641
I believe I have the very latest which is 3.1 as I downloaded and installed this as it wouldn't install without it.
0
 
LVL 3

Author Comment

by:HM2K
ID: 17036455
Still no solution to this problem.
0
 
LVL 10

Expert Comment

by:kcarrim
ID: 17036615
Were you trying to install Visual Studio?

It could be that the installer was waiting for IIS Admin to terminate and IIS Admin was in turn waiting for World Wide Web Services to terminate. Uninstall .Net 1.1

Do a search of the machine and look for the file MSCOREE.DLL. Rename this file to MSCOREE.OLD wherever you find it and then try the installation again.

Also have a look at this article:
Resolve Partial Assembly failed for Microsoft.VC80.DebugCRT
http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=189630&SiteID=1
0
 
LVL 6

Expert Comment

by:engineer_dell
ID: 17036745
"the installer was waiting for IIS Admin to terminate and IIS Admin was in turn waiting for World Wide Web Services to terminate." is the reason for that,
I was facing the same issue, after trying hundred things I found that when I killed "inetinfo.exe" process from the task manager, it worked like a charm,

you may also try that if that doesn't work then. uninstall failed .net installation by this tool,
http://astebner.sts.winisp.net/Tools/dotnetfx_cleanup_tool.zip

If you have Zone Alarm > http://blogs.msdn.com/quanto/archive/2006/03/31/566191.aspx

Now after removing failed .NET, kill "inetinfo" process, now reinstall .NET Framework 2.0,

Hope this helps,

Engineer_Dell
0
 
LVL 3

Author Comment

by:HM2K
ID: 17037064
My windows updates never seem to complete, and I believed it was something to do with the dotnetfx as when I tried to install an update manually it said it required it installed...

It turns out I didn't have Windows Installer 3.1 installed...

http://download.microsoft.com/download/1/4/7/147ded26-931c-4daf-9095-ec7baf996f46/WindowsInstaller-KB893803-v2-x86.exe

So I have now installed it, and tried to install dotnetfx again...

But again it stopped in exactly the same place!

I can't rename mscoree.dll as its being used by windows.

I'm not getting an error, it just stops, and there's nothing in my event log.

I tried that cleanup program, and I viewed the cleanup_log, it says at the bottom: [07/04/06,22:16:46] ****ERROR**** Cleanup failed for product .NET Framework - All Versions

I don't have a process called inetinfo.

I don't have Zone Alarm.
0
 
LVL 10

Expert Comment

by:kcarrim
ID: 17037146
Have you tried to uninstall .NET 1.1 as i have mentioned earlier?
0
 
LVL 10

Expert Comment

by:kcarrim
ID: 17037155
Oh, by the way, try renaming the file from safe mode
0
 
LVL 10

Expert Comment

by:kcarrim
ID: 17037178
"inetinfo.exe" belongs to Microsoft Internet Information Services (IIS) and is used for debugging.
0
 
LVL 6

Expert Comment

by:engineer_dell
ID: 17037382
1. unplug your network

2. disable your virus checker

3. install .NET Framework

4. re-enable your virus checker

5. plug your machine back on the network

0
 
LVL 3

Author Comment

by:HM2K
ID: 17038637
I don't have a virus checker installed, and i've tried installing it without being on the network, it still stops at the same point.
0
 
LVL 6

Expert Comment

by:engineer_dell
ID: 17038661
What about IIS is installed and running ?
0
 
LVL 3

Author Comment

by:HM2K
ID: 17038688
IIS is neither installed nor running, its not a web server, and never will be.
0
 
LVL 6

Expert Comment

by:engineer_dell
ID: 17038754
It may sound silly but just confirming that you are installing .NET Framework Redistributable (Final) NOT SDK version as SDK version requires Redisributable pre-installed.
0
 
LVL 3

Author Comment

by:HM2K
ID: 17038809
What I am trying to install is dotnetfx.exe aka Microsoft .NET Framework 2.0.50727.42

I'm going to take a look at http://www.filemirrors.com/search.src?type=begins&file=dotnetfx&action=Find
0
 
LVL 3

Author Comment

by:HM2K
ID: 17038835
As it seems dotnetfx3.exe won't run on Windows 2000.

I have now re-downloaded it from here: http://www.microsoft.com/downloads/details.aspx?FamilyID=0856EACB-4362-4B0D-8EDD-AAB15C5E04F5&displaylang=en

But its done exactly the same thing again...
0
 
LVL 6

Expert Comment

by:engineer_dell
ID: 17038873
And follow installation guideline from these; Install from command line rather double clicking dotnetfx.exe

http://blogs.msdn.com/astebner/archive/2005/11/17/494312.aspx
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dnnetdep/html/ndp2_prere.asp

Regards,
Engineer_Dell
0
 
LVL 6

Expert Comment

by:engineer_dell
ID: 17038886
Please check these logs and post if you see any error

%temp%\dd_netfx20*.txt
%temp%\dd_netfxLP20*.txt
0
 
LVL 3

Author Comment

by:HM2K
ID: 17038898
[quote]To make a long story short, you can use the following command lines to create an administrative install point and install the .NET Framework 2.0 using the MSI directly:

   1. To extract the contents of the setup package - dotnetfx.exe /t:c:\temp /c (or you can substitute any path of your choosing for c:\temp)
   2. To create an administrative install point - c:\temp\install.exe /a
   3. To install using the MSI directly - msiexec.exe /i netfx.msi ADDEPLOY=1
[/quote]

I got to point 2, and it failed with an error... http://www.yoimg.com/i/41203059-dotnetfx-cmd-error.jpg

Also my server/install exceeds the required System Requirements
0
 
LVL 6

Expert Comment

by:engineer_dell
ID: 17038969
It is important to see the logs I mentioned above and also the detail of the error

Have you set the current date and time???
http://www.yoimg.com/h/239289366-dotnetfx1.JPG.html


0
 
LVL 6

Accepted Solution

by:
engineer_dell earned 2000 total points
ID: 17039006
Have you done this ?

Click on the Start menu, choose Run and type services.msc
Locate the Distributed Transaction Coordinator service, right-click on it and choose Properties
In the Startup type drop-down, select Disabled
If the service status is currently listed as running, click the button to stop the service
Close the Services control panel and try to install the .NET Framework again
0
 
LVL 3

Author Comment

by:HM2K
ID: 17039016
Those two files can be found here...

http://home.hm2k.org/dump/dd_netfx20MSI695A.txt
http://home.hm2k.org/dump/dd_netfx20UI695A.txt

I have coppied them onto another machine on my network which acts as a local web server.
0
 
LVL 3

Author Comment

by:HM2K
ID: 17039053
Time/Date was wrong! - no fix though

I have just disabled/stopped "Distributed Transaction Coordinator" via services.msc, now when I run dotnetfx.exe I get a similar style error as this one... http://www.yoimg.com/i/41203059-dotnetfx-cmd-error.jpg

I seem to get that same/similar error all the time now...

EventType : visualstudio8setup     P1 : 183     P2 : 8.0.50727.42_rtm_x86ret
P3 : msi     P4 : inst     P5 : f     P6 : installvalidate     P7 : -    
P8 : 1618     P9 : -     P10 : -    

What does it mean?
0
 
LVL 6

Expert Comment

by:engineer_dell
ID: 17039095
Thanks for the files...I just looking in to it...
0
 
LVL 30

Expert Comment

by:callrs
ID: 17039135
chkdsk /r  from command prompt
0
 
LVL 3

Author Comment

by:HM2K
ID: 17039141
This is a brand new system with a brand new hard drive and a brand new clean install, is it really likely to need this?

[quote]
Microsoft Windows 2000 [Version 5.00.2195]
(C) Copyright 1985-2000 Microsoft Corp.

C:\>chkdsk /r
The type of the file system is NTFS.
Cannot lock current drive.

Chkdsk cannot run because the volume is in use by another
process.  Would you like to schedule this volume to be
checked the next time the system restarts? (Y/N)
[/quote]
0
 
LVL 6

Expert Comment

by:engineer_dell
ID: 17039329
error: 1618 - "Another installation is already in progress. Complete that installation before proceeding with this install."

Try to kill all unncessary application, then try again, meanwhile I will continue to work on the log errors,

If you  have Visual Studio try uninstalling it,
http://blogs.msdn.com/astebner/articles/492809.aspx

0
 
LVL 3

Author Comment

by:HM2K
ID: 17039356
There's nothing else running, I simply boot up windows, and once its finished loading open dotnetfx.exe which I have placed on the desktop.

I don't have Visual Studio installed.
0
 
LVL 30

Expert Comment

by:callrs
ID: 17039977
>>is it really likely to need this?
Brand new drives can have bad sectors. Recommend is when you set up the drive, to do a FULL format, not a quick format. So if you haven't the full, you should say Y to "Would you like to schedule this volume to be checked the next time the system restarts?'

But remember, full surface scan can take hours to finish. (In contrast, A Full Format, the recommended route when you set up the drive, takes much less time)
0
 
LVL 7

Expert Comment

by:imacgouf
ID: 17040246
Maybe you can try the below exe.

http://www.ryanvm.net/forum/viewtopic.php?t=2276He
This silent addon installs dotNET 2.0 from SVCPACK @ T13 from one EXE to reduce clutter.  tested it(this addon) enough now to be sure the workaround is functional, installing from svcpack and running .NET programs, showing up in "add/remove programs", and no errors during install.
0
 
LVL 7

Expert Comment

by:imacgouf
ID: 17040258
Also

http://www.kbalertz.com/Feedback.aspx?kbNumber=908077
This step-by-step article describes how to troubleshoot issues that you may experience when you install the .NET Framework 2.0.
0
 
LVL 6

Expert Comment

by:engineer_dell
ID: 17041036
msiexec.exe /i netfx.msi /qb /l*v netfx20install.log ADDEPLOY=1 TRANSFORMS=<path>\strings.enu.mst
0
 
LVL 12

Expert Comment

by:GinEric
ID: 17041099
You can't spread a question over two point awards.  Each question has a maximum of 500 points.  So you should delete the other question.

About your problem:

You said the system is brand new; is it a 64-bit system?  Do you have the proper versions of both .NET Framework and Visual Studio?  And remember, Win2k is not really equipped to handle 64-bit systems.

You may be beating a dead horse trying to install this on Win2k.
0
 
LVL 3

Author Comment

by:HM2K
ID: 17041614
I always used to do a full format, but I realised that its very unlikely for a new drive to had bad sectors.

I did a chkdsk, no problems found, and it didn't fix donetfx installing.

I will try 00dNET20.exe

[quote]msiexec.exe /i netfx.msi /qb /l*v netfx20install.log ADDEPLOY=1 TRANSFORMS=<path>\strings.enu.mst[/quote] <- How do I make this function work? What do I put in replace of <path>?

Hmm, its possible my system is a 64bit system, how do I check?
0
 
LVL 6

Expert Comment

by:engineer_dell
ID: 17041776
Try "winver" command to check 64 bit os
if it is 64 bit then run uninstaller utility to clean failed installation,

Download 64 bit .NET Framework 2.0 and install,
http://www.microsoft.com/downloads/details.aspx?familyid=b44a0000-acf8-4fa1-affb-40e78d788b00&displaylang=en
0
 
LVL 3

Author Comment

by:HM2K
ID: 17041793
Winver doesn't tell me if its a 64 bit system, and the OS is windows 2000 server, which is not a 64 bit OS.
0
 
LVL 6

Expert Comment

by:engineer_dell
ID: 17041827
you can also use DXDIAG command to check 64 bit...

Click on Start -> Run, and type dxdiag. If a Windows dialog box is displayed asking if you want to verify your drivers, you can safely click no and continue

In the Operating System line, refers to Windows <some version> x64 or 64-bit edition
0
 
LVL 3

Author Comment

by:HM2K
ID: 17041870
Again, that simply tells me whether the OS is 64 bit not the system...

If my system is 64 bit, it should run a 32 bit OS fine right? This should not affect the install of dotnetfx?

Thanks.
0
 
LVL 6

Expert Comment

by:engineer_dell
ID: 17041880
I am sorry best way to check would be MSINFO32 command,

It will show you "system type" it would be either X86 (32bit) or X64
0
 
LVL 3

Author Comment

by:HM2K
ID: 17043102
For some very odd strange reason neither msinfo32 nor "C:\Program Files\Common Files\Microsoft Shared\MSInfo\msinfo32.exe" will load.

There's nothing about it in my event log.

Any thoughts?

In addition to this, i've noticed this error in the event log...
Windows cannot unload your registry file.  If you have a roaming profile, your settings are not replicated. Contact your administrator.  

DETAIL - Access is denied. , Build number ((2195)).

Any ideas?
0
 
LVL 3

Author Comment

by:HM2K
ID: 17043448
It is an X86, I was getting this machine confused with another one I recently built too.

After lots of messing around with fan speeds in bios (its hot in the UK atm), going into safe mode and running msinfo32, I then went into add/remove programs, where I found out that dotnetfx 2.0 was listed.

So I rebooted into normal windows, and issued a "Change/Remove", from there it appeared asif the install continued and then completed. At this point I then decided to run Change/Remove again, and completly uninstall/remove it, and that is what I did.

On complete, I ran dotnetfx.exe again, and this time it worked without a hitch, problem or fault.

As such now this is complete all my software is working correctly including windows updates.

I think perhaps a conbernation of stopping the "Distributed Transaction Coordinator" in services.msc, chkdsk and dropping into safe mode to check out some stuff has been part the way towards the solution to the problem.

Although no one here gave me a direct solution, and even though there didn't appear to be a direct solution, the most helpful person here has been engineer_dell, and on that basis I will be offering him the points for this question.

As for the "other" question, I will not be awarding this because as I said before he didn't provide me with a solution to the problem.

I believe this is a fair, if you disagree, please let it be known.
0
 
LVL 6

Expert Comment

by:engineer_dell
ID: 17048581
I am more than happy that it worked, no matter how....

I have officially given this error instance with log you provided to Microsoft...Let them work on it...I will update you when I get an answer from them,

Keep Smiling :)

Warm Regards,

Engineer_Dell  
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
The core idea of this article is to make you acquainted with the best way in which you can export Exchange mailbox to PST format.
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …
In response to a need for security and privacy, and to continue fostering an environment members can turn to for support, solutions, and education, Experts Exchange has created anonymous question capabilities. This new feature is available to our Pr…
Suggested Courses

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question