Solved

Patch cable connects laptop fine to router/switch, but not desktop?

Posted on 2006-06-09
16
958 Views
Last Modified: 2013-11-29
I have just made a patch cable (5e) and am using it right now to connect to my router/switch on my laptop.  But when I try and use it on my desktop I get the "connected" icon, but there is no connection to my LAN or the internet. I restarted the desktop and powered down the cable modem and the router, but this doesn't seem to fix it.  I don't get the DHCP SErver, Default Gateway, DNS server info in the Status Dialog box, the desktop works fine with the router, via a wireless-G USB adapter, which I disabled, when trying to get the hard-wire to work. Any ideas?
0
Comment
Question by:davidgareau
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 4
  • +3
16 Comments
 
LVL 27

Assisted Solution

by:pseudocyber
pseudocyber earned 220 total points
ID: 16870182
Is it a straight through cable?  Perhaps one device can do an auto crossover and one cannot.

Did you make a 568A or 568B cable - oranges on the left, or greens on the left?  Same on both ends, right?

What if you take another known good working cable and try it both on the laptop and desktop - does the other cable work?
0
 

Author Comment

by:davidgareau
ID: 16870227
568-B, because the 568-A didn't work on the laptop and didn't even give the non-working connection that 568-B gives on the desktop. I have taken another one and it does the same thing.  That's why I think it's something configured on the desktop itself or the router (somehow blocking the hard-wired connection) but I don't know what it could be.
0
 
LVL 27

Accepted Solution

by:
pseudocyber earned 220 total points
ID: 16870236
Check the NIC configuration on the desktop - it should be Autonegotiate.
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 29

Assisted Solution

by:masnrock
masnrock earned 40 total points
ID: 16870275
Try a different a cable that you did not make to connect the desktop and let us know what you notice.
0
 
LVL 13

Assisted Solution

by:prashsax
prashsax earned 160 total points
ID: 16870551
You should user cross cable to connect to passive devices.

Router and switches are active devices and can be connected to laptop using straight cable.

To connect laptop and desktop use cross cable and not cross over cable.

Cross cable would have 1,3 and 2,6 cross on each end.
0
 
LVL 27

Assisted Solution

by:pseudocyber
pseudocyber earned 220 total points
ID: 16870624
Prashsax,

I'm confused by your statements.

Active vs. Passive - this has nothing to do with if a cross over is needed or not.  What determines a crossover is whether the two devices are DTE or DCE - Data Terminal Equipment and Data Communication Equipment.

If two devices are alike - both DCE - say a switch to a switch, a cross over is required so that the Transmit crosses to the Receive and vice versa.  Same appllies to two DTE devices.

If two devices are dissimilar, then a straight through is required.

Note - some equipment can create an electrical cross over inside the interface - either manually with a button or automatically.  It is, nevertheless a cross over interface - MDI/X.

"To connect laptop and desktop use cross cable and not cross over cable."  It would be normal to connect a PC to a network device - a switch or hub - which would be a DTE to DCE connection and would require a straight through cable, not a cross cable or cross over cable.
0
 
LVL 13

Assisted Solution

by:prashsax
prashsax earned 160 total points
ID: 16870735
I meant to connect a laptop and desktop with each other witout a hub/switch use cross cable.
0
 
LVL 27

Assisted Solution

by:pseudocyber
pseudocyber earned 220 total points
ID: 16870753
Oh, I see.  Then I agree with you.  :)
0
 

Author Comment

by:davidgareau
ID: 16870775
I don't want to connnect the laptop to the desktop.
I want to get the desktop to connect correctly to the router/switch, just like the laptop does correctly.
I have tried another wire and get the same results.
How can I find out if the desktop is set to Auto-Negotiate? in Windows XP
0
 
LVL 13

Assisted Solution

by:prashsax
prashsax earned 160 total points
ID: 16870828
Goto Network Connections.

Find the LAN card. Right click->Properties.
 COnfigure->Advanced.

Find a setting Speed and Duplex. It should be at Auto.
0
 
LVL 14

Assisted Solution

by:ECNSSMT
ECNSSMT earned 40 total points
ID: 16870835
just a shot in the dark, but ...

If you do an IPconfig /all and you still see info for the wireless NIC probably with something like IP Address: 0.0.0.0.  It is probable that your desktop is attempting to obtain and still access your network from the wireless USB.

Ensure that the USB is disabled under the network properties area.  

Regards,
0
 

Author Comment

by:davidgareau
ID: 16870995
>>>>Goto Network Connections.
>>>>Find the LAN card. Right click->Properties.
>>>> COnfigure->Advanced.
>>>>Find a setting Speed and Duplex. It should be at Auto.

All I see is FIrewall setup and Network Wizard hyperlink

USB Adapter is disabled
0
 
LVL 27

Assisted Solution

by:pseudocyber
pseudocyber earned 220 total points
ID: 16871050
From Control Panel->Network Connections.  You should see one which says "Local Area Connection".  If you don't, that would be a problem.
0
 
LVL 13

Assisted Solution

by:prashsax
prashsax earned 160 total points
ID: 16871847
On General Tab you should see configure button, right on top.

You need to Click it first, before clicking  the Advanced Tab.


The advanced Tab you are talking about(Firewall Config) is on main LAN Properties windows.



0
 
LVL 44

Assisted Solution

by:scrathcyboy
scrathcyboy earned 40 total points
ID: 16872708
Why not simply remove all the networking protocols on the desktop in windows networking, and reboot.  If XP, it is no big deal, it will install them all over again, and then you go through a config wizard, choose the 2nd one on the list, and choose residential gateway, then with cable connected, you should be seeing the network.  It only takes about 2 minutes, and it clears up failed TCP/IP.

Also make sure the straightthrough cable is to industry specs.  
0
 

Author Comment

by:davidgareau
ID: 16874254
The problem was in the TCP/IP settings.
It was set to a static IP for the NIC, I had the Wireless-G USB Adapter set to Dynamic (Automatically Obtain) and I didn't realize that each one was independent of the other.  So, I got the connnection icons, but no transmission because the IPs were messed up.

thanks
david
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Background Information Recently I have fixed file server permission issues for one of my client. The client has 1800 users and one Windows Server 2008 R2 domain joined file server with 12 TB of data, 250+ shared folders and the folder structure i…
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
There's a multitude of different network monitoring solutions out there, and you're probably wondering what makes NetCrunch so special. It's completely agentless, but does let you create an agent, if you desire. It offers powerful scalability …

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question