• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 381
  • Last Modified:

On citrix server , i start the print spooler but i stops and i dont see any printers

Hi ,
we have a citrix server and it used to see all 120 printers in the company. Today i was told that the server doesnt have any printer isnatlled. I restarted the spooler  (net start spooler) and i saw the printers. By the time i went to the user's desk the printers were gone. I did the same thing from his desk and the printers came up. When i tried to add a new printer i got the message 'the subsystem is unavailable cannot add printer due to lack in resources.  I pressed F5 to refresh and indeed all printers were gone.

Any ideas ?

  • 2
1 Solution

If the print spooler service is no starting correctly it can help to delete old spool files from the


folder on the server.  Verify that the spooler service is stopped and then check the contents of this folder.
c_hocklandAuthor Commented:
i did , i see the printers (some of those). When i try to add a printer i get
' printer operation cannot continue to lack of resources. Operation could not be completed '

Any ideas?
c_hocklandAuthor Commented:
there were some hidden files which got them deleted as well. Thanks so much Saineolai.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now