?
Solved

SMTP outgoing IP address

Posted on 2006-06-09
8
Medium Priority
?
667 Views
Last Modified: 2008-02-01
Hi,

I am using IIS vSMTP for sending mail.  

My server has 3 IP addresses on one NIC.

I want to specify which IP address vSMTP should use when it makes it's outgoing connections....anyway to do this?
0
Comment
Question by:thomp361
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
8 Comments
 
LVL 34

Accepted Solution

by:
Dave_Dietz earned 1000 total points
ID: 16872813
I believe the SMTP service will simply use the first IP address in the binding order to make outbound connections.

Try shifting the binding order and see if that helps.

Dave Dietz
0
 
LVL 6

Assisted Solution

by:shambhusingh2004
shambhusingh2004 earned 1000 total points
ID: 16875825
Yes,You can use/blind other IP in local SMTP to send mails.

Go to IIS.
Select default SMTP virtual server properties.
Select IP address to which you want to use.
The go the Access TAB
Then select relay restration option
ADD IP address.

Warm Regards,

Vipin Gupta

0
 

Author Comment

by:thomp361
ID: 16877077
Hi Vipin,

My IP addresses are *.81, *.84, *.85

My server uses .81 for outgoing connections but I want vSMTP to use .85 for outgoing connections.

I tried your idea of adding a relay restriction option, I selected .85, and I granted relay to .85

However, when emails get sent they still have .81 in, so it seems that the vSMTP is still using .81 for outgoing connections.

Thanks for the help,
Marc.
0
Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 

Author Comment

by:thomp361
ID: 16877092
Hi Dave,

I changed the IP order in the NIC but the box (and vSMTP) still seems to use .81 for outgoing connections....I thought at first that might have done it but it hasn't.
0
 
LVL 6

Expert Comment

by:shambhusingh2004
ID: 16877119
Hi Marc -

I have production server on which mails are relaying from second IP of server.I have following configuration,please confirm with your server configuration :

My SQL IP are :

192.168.0.1 (Primery)
192.168.0.2 (Secondary)

>> Go to IIS :
>> General TAB >> Assigned IP '192.168.0.2' & advanced tab >> add IP '192.168.0.2'  & port 25.
>> Access TAB
>> Relay tab >> Only the list below >> add IP '192.168.0.2'
>> Allow all computers which successfully authenication to relay,regarding above list (check mark)

Warm Regards,

Vipin Gupta

0
 

Author Comment

by:thomp361
ID: 16877185
Hi Vipin,

That's what I tried to do, setup a relay for .85, but the when email's get sent they still have .81 in the header.

To confirm, I selected .85 on the 'General' tab, then on the 'Access' tab -> relay restrictions -> 'only the list below' -> granted .85

Thanks,
Marc
0
 
LVL 34

Expert Comment

by:Dave_Dietz
ID: 16879192
How did you change the order of the IP addresses?

I believe SMTP will use the one that shows up as the first on the list.

Did you restart the service after making the change?

Dave Dietz
0
 

Author Comment

by:thomp361
ID: 16885567
I changed the order in the NIC settings under "ip addresses" ...turns out that my server provider said I can only use on of my three IP for outgoing connections anways, so getting vSMTP to use a different IP is a moot point now.

Thanks for helping guys, I'll split the points.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Running classic asp applications under Windows Server 2008 R2 (x64) and IIS 7 is not as easy as one may think. It took me a while to figure it out while getting error 8002801d a few times. After you install the OS you will need to install the fol…
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question